First Update Following Purchase of M1


May 14, 2012
12
0
11
#1
Hi

I have followed all instructions I can find on this site and am unable to update at all.

1. I currently have miui 2.3.5v
2. I rebooted and wiped all data and updated partitions
3. I downloaded 2.5.11 and sought to install update.zip first with the Updater. I got the following message:

System update failed

The error log says:

script aborted: assert failed: getprop("ro.product.device") == "mione_plus" || getprop("ro.build.product" == "mione_plus"
assert failed: getprop("ro.product.device") == "mione_plus" || getprop("ro.build.product" == "mione_plus"

4. I tried installing from the reboot menu and also got an error.

I have also tried both install options using two other ROM versions.

If anyone can provide insight as to what I might possibly be doing incorrectly, it would be greatly appreciated!!
 
Mar 29, 2012
519
49
67
#2
Try to download again the newest version from the website and use the update function inside the recovery menu of the phone. check the md5 hash to see that your download is correct and then try again. remember to rename the update to update.zip the newest version got a different name then update.zip
 
Mar 29, 2012
519
49
67
#6
Then go back and do every step again from the very start, formating/total wipe and the update partitions both 1 and 2 and see if that helps
 
May 14, 2012
12
0
11
#7
I have done every step again. It seems that thismight be an issue specific to my device.

Once partitions are updated it states that they have already been updated. I have repeated this step anyway with every effort to update.

The Miui version (miuiandroid vs. stock miui) does not seem to make a difference, and neither does updating from Updater App or Recovery Menu.
 
May 14, 2012
12
0
11
#8
OK - I think I have gotten to the bottom of it. My model is a MiOne Plus C1, the CDMA model of the phone.

So, my next question is whether anyone knows where I can get a Miui update for the CDMA model.
 
Mar 30, 2012
3
0
11
#9
well you can always try the official build from miui.com or try to the following just changing the file for the newer build , you can skip the last step.
10-80 said:
Hi, rarelyamson I’ll try to explain what I did.
The start point was when I couldn’t boot into either partition – see post 33 above.
I have 2 ROMS in the root of my SD card, file names:
miuiandroid_mione-2.3.9c.zip
miuiandroid_mione-2.3.9-ICS.zip (if you don't have this file I can upload it somewhere for you if you provide a location)

  1. Power off phone (I had to pull the battery)
  2. Remove SD card from phone and mount in Windows PC using card reader
  3. In windows, browse to the root of my SD card and rename the file “miuiandroid_mione-2.3.9-ICS.zip ” to be named “update.zip”
  4. Safely remove the SD card from Windows and insert it in phone
  5. Power on phone and boot into recovery (hold down volume up when pressing the power button to turn on, don’t release volume up until the recovery menu is displayed – takes about 7 seconds)
  6. Navigate the menus in recovery using the volume keys to highlight option and the power button to select highlighted option.
  7. Select Language (English for me)
  8. Main menu > Wipe&Reset > Wipe All Data (takes about 1 minute) > Back to Mainmenu
  9. Main menu > Install update.zip to System One > Yes (takes about 3 minutes)
  10. Main menu > Reboot > Reboot to System One (takes about 3 minutes to boot into OS) (I may have selected System Two here, can’t remember for sure, sorry)
  11. Once in MIUI, I used the ‘Updater” tool to flash the “miuiandroid_mione-2.3.9c.zip” ROM from within MIUI, let me know if you need instructions for this.