Fix: Missing account sync contacts in google account / no contacts sync in Google account / new contact only Mi Account


katerpanne

Members
Apr 19, 2014
3,545
332
Hell together,

I wanted to add a telephone number to contacts. There I recognized, that I only can add it into the MI account.
In an earlier time, I was able to choose if I want to store it in google or mi account. In contacts now only the MI account contacts are shown.

I cant chosse google contacts because this entry is no longer visible. Is there a possibility to bring back the google account contacts entry in contacts ?

And in menue "Accounts & Sync" - "Google" - the entry "Contacts" is missing.

Kind regards Kater

Solution: The service "Google Contacts sync\ContactsSyncAdapterService" was not running
  • to enable it, download a tool like "Service Disabler"
  • select "system" and scroll down
  • search for "Google Contacts sync" and click on it
  • then enable "ContactsSyncAdapterService" and enable it

Now it is possible again to choose if you want your contacts in "Mi Account" or "Google Account" and there is an entry in "Google sync" that you can sync your contacts.
 
Last edited:
  • Like
Reactions: Gazzasore
What you don't say is that this tool "service disabler" needs roots permissions to work, not so easy to obtain root permissions on the mi10