Psyche HyperOS 1.0.3.0 issue with Google Wallet


-=Guybrush=-

Members
Feb 28, 2017
17
15
My best regards. As per thread title, I'm experiencing some issues (I tend to believe linked to my setup rather than to an issue with the Xiaomi.eu rom itself) with Google play services, this preventing me from using Wallet while all the other Google services (Play Store, multiple OAuth email accounts configuration etc.) work just fine. I can't even go past the first step of choosing what account to use with Wallet.
In different successive steps made in the effort of pinpointing the cause (that's clear) I've cleared the storage space for all the involved apps, tried to uninstall all the updates for them (when the option was available) and even tried to update them to the latest versions, all of this to no avail. Currently, the versions are the ones shown in the screenshots attached.
I keep getting an error saying that I need to grant SMS permission to Google Play services but then it brings me to the usual app details page from where a list of permissions is missing and it is replaced by an "All Services" menu item. What's quite strange too is the fact that all the other menu items are in my language while that one is in English (but I don't think that one is a relevant detail given that the translation for the rom is quite inaccurate with many other UI items untranslated (some in Chinese too) from where I could't find anything relevant to adjust apart from (let's say) something about verification SMSes (integration with browsers and autofilling) which I haven't ever thought for a single second it could help indeed it hasn't
I just get regularly bugged by recurring notifications by Wallet about that error with permissions and for now I've uninstalled it to avoid being constantly bugged at least.
As a side note I add that I've needed to update the xiaomi.eu app because I couldn't succeed with getting device integrity but only basic integrity by the version built inside the HyperOS 1.0.3.0 rom. Anyway, this is just an expected behaviour given the cat and mouse pursuit. Uninstalling the latest xiaomi.eu app update didn't help either: I've tried that too in spite of the fact that the latest update doesn't cause any issue on my other Xiaomi smartphones and without device integrity Wallet doesn't work anyway, just to see if I could adjust that SMS permission.
Thanks in advance for your advices.
 

Attachments

  • Screenshot_2024-04-13-10-06-47-850_com.miui.securitycenter-edit.jpg
    Screenshot_2024-04-13-10-06-47-850_com.miui.securitycenter-edit.jpg
    20.6 KB · Views: 78
  • Screenshot_2024-04-13-10-07-11-900_com.miui.securitycenter-edit.jpg
    Screenshot_2024-04-13-10-07-11-900_com.miui.securitycenter-edit.jpg
    22.9 KB · Views: 82
  • Screenshot_2024-04-13-10-07-39-046_com.miui.securitycenter-edit.jpg
    Screenshot_2024-04-13-10-07-39-046_com.miui.securitycenter-edit.jpg
    18.1 KB · Views: 79
Last edited:
  • Like
Reactions: missingu99
My bad. Found the solution by myself as I could have already done. My thread is a duplicate of this one.
Just solved by Termux (it works only if you are rooted and have the tsu package installed otherwise, as correctly adviced there, just use adb shell having enabled USB debugging and authorized the remote device before, that's clear) simply issuing these three commands:

Code:
pm grant com.google.android.gms android.permission.RECEIVE_SMS
pm grant com.google.android.gms android.permission.READ_SMS
pm grant com.google.android.gms android.permission.SEND_SMS

Another possible workaround is using Hidden Settings app as adviced in this post from the same thread or this one too (which does remove the need for installing third party apps).
Thanks to @maksz, @gogocar62, @Igor Eisberg and apologies on my side. :(
 
Last edited:
Hello again. In spite of what I was saying above, I can't get Wallet to work with the rom in the title. Everything seems fine, all the checkmarks needed by Wallet are present and green, I have both device and basic integrity, I can add credit and debit cards with no issues BUT when I make a payment (tried different cards with the same exact outcome) I always get the "transaction denied" error on the merchant's POS. It needs to be said that everytime I get this error with Wallet, I'm then forced to use the same cards phisically and they work with no issues at all as I'd expect. Also, this happening with different cards (both debit and credit as already said) from different banks and payment services providers makes me almost certain the problem isn't there but linked to some sneaky misconfiguration or some sort of issue on my smartphone. I'd also like to underline that the SAME EXACT setup was working just fine on a A12 MIUI 14 (still Xiaomi.eu stable) Gauguin (there, it wasn't even necessary to issue the commands I've recalled above, I believe something needed only on some HyperOS roms).
Is there a way to pinpoiint what's going on? I'm considering rolling back to MIUI given that HyperOS (at least on Psyche) seems to me too unripe (even the UI translation leaves a lot to desire) but I'm confident I can't dirty flash and I don't want to backup and restore everything again if possible. I'd like to underline, mine is just a personal consideration and I'm not arguing about anything: you all at Xiaomi.eu do an outstanding work doing development and maintenance work on such a lot of devices, HyperOS is quite a new thing and Psyche starts to be quite an old model so, again, NOTHING to argue about. I'm just trying to understand what's going on and maybe learn something new (how to troubleshoot issues with Wallet more thoroughly) if possible. Thanks in advance and have a nice day! :)
 
Last edited: