New Foursquare A-GPS issue


Apr 18, 2012
24
3
15
#1
Hello!
I didn't find information about my problem. It's not mentioned anywhere.
I have Mi-One Plus with latest V4 build from miuiandroid.com.
On past two weeks I was on my vacation in Turkey (gone there from Russia). In Turkey A-GPS positioning worked fine. Had no problems. When I returned to Russia, positioning based on mobile and Wi-Fi networks just stoped working. It works fine in Google Maps and other applications but not working in foursquare. I deleted all data from recovery and reflash firmware. Then tried it on a blank device and it's still the same result. Positioning by mobile networks works fine everywhere except foursquare.
I ran out of ideas what else I can do. Will be appreciate for any help!
Thx!
 
Apr 18, 2012
24
3
15
#2
Update:
If anyone will meet this problem on their device - the foursquare A-GPS location service was broken in 2.6.29.
Reflashing 2.6.15 from recovery not helping. Only thing that help me:
I reflashed official China firmware ICS 6.0 Stable with Mi-Flash. Tha wiped all data and flash 2.6.15 from recovery. Foursquare works fine.
Just to test then I flashed 2.6.29 from recovery and problem returned. So for now I'm using 2.6.15.
Hope it will help anyone, because I didn't find any information for myself.
 
Apr 18, 2012
24
3
15
#4
I managed to solve this problem my way. I replaced NetworkLocation.apk file from 2.6.15, reboot and it started working!
WIll be glad to help other people trying to solve this problem!