New Google Pay stopped working on 9.x.x, Mi8


Izbushka

Members
Jan 13, 2019
11
15
create bugreport and send it to me.. thanks
Google Pay stopped working. My phone is rooted, but Safety Net passes, and there was other reports without Magisk installed.
App works fine, but you can't actually pay and you can't enable contactless payments for new card.

Here some reports: 1, 2, 3
f693e51b-06f7-43d9-8694-5a1dc84213a5.jpeg

UPD. There is a solution but it seems needed to be done every update:
If you have Google Pay issue at Android 9.0 devices:
In the TWRP delete folder /data/data/com.google.android.gms
EN: If you have Google Pay issue, clean data of Google Pay and Google Play Services app..
 
Last edited:
  • Like
Reactions: mathpfvr

Izbushka

Members
Jan 13, 2019
11
15
I did, no luck. Screenshots are here

UPD. Well, i've just tried Magisk from here, didn't help either
 
Last edited:

cmarco71

Members
Sep 9, 2018
21
15
The same for my Mi 8 except that i don't installed magisk and can add new card.
But still can't to enable contactless payments in shops

Inviato dal mio MI 8 utilizzando Tapatalk
 

Izbushka

Members
Jan 13, 2019
11
15
Facing the same issue again on 9.3.14. Clearing the data of Google Pay, Google Play Services, Google Services Framework doesn't help this time. Same symptoms: couldn't pay, couldn't add new card - says phone is rooted.
 
  • Like
Reactions: Destronatic

koniu82

Members
Nov 14, 2018
48
20
I had that problem in mi mix 2s, today i fix it by reinstaling room, with full wipe of everything. After that i was able to add card. i don`t test if i am able to pay with so far, i will report asap if payment work

I am not using Magisk.
 

Plovel

Members
Jan 29, 2019
361
52
Same issue, Just stopped working and won't make me pay.... Even without magisk
Delete /data/data/com.google.android.gms
And reboot
Or try to set up magisk 18.2, hide Google play services(fully) and Google pay and clear data of Google pay

Отправлено с моего MI 8 через Tapatalk
 

Maninincognito

Members
Mar 16, 2019
15
5
Delete /data/data/com.google.android.gms
And reboot
Or try to set up magisk 18.2, hide Google play services(fully) and Google pay and clear data of Google pay

Отправлено с моего MI 8 через Tapatalk
I got It to work by downgrading to Xiaomi.eu 3.1.7, using Magisk 17.1 and by cleaning all app data to all the Google related apps (with Magisk 18.1 wasn't working)
 

Plovel

Members
Jan 29, 2019
361
52
I got It to work by downgrading to Xiaomi.eu 3.1.7, using Magisk 17.1 and by cleaning all app data to all the Google related apps (with Magisk 18.1 wasn't working)
Effective, right?)
Gpay (on mi 6) can find magisk even with Magisk hide, Google developed searching root

Отправлено с моего MI 8 через Tapatalk
 

dacow

Members
Oct 27, 2017
5
13
Works for me also, thanks.
Magisk 18.2
Looks like this might have worked for me too. I was able to add my original CC back to Google pay WITHOUT it saying my phone is rooted.

Will need to go buy something and see what happens and will post back.

FYI I also passed SafetyNet and is GooglePay certified.

edit: payment was successful so it looks like clearing the com.google.mms folder did the trick! (for me at least)
 
Last edited:

xusijia123

Members
Mar 16, 2019
2
3
Looks like this might have worked for me too. I was able to add my original CC back to Google pay WITHOUT it saying my phone is rooted.

Will need to go buy something and see what happens and will post back.

FYI I also passed SafetyNet and is GooglePay certified.

edit: payment was successful so it looks like clearing the com.google.mms folder did the trick! (for me at least)
it worked for me however after another update the same problem came back.
 

Izbushka

Members
Jan 13, 2019
11
15
it worked for me however after another update the same problem came back.
It looks like it might be not really related to an updated. It stopped suddenly working for me before the update. Deleting folder helped again, as well as after the update..
 
  • Like
Reactions: dacow

xusijia123

Members
Mar 16, 2019
2
3
It looks like it might be not really related to an updated. It stopped suddenly working for me before the update. Deleting folder helped again, as well as after the update..
this happened to me twice and both times it's after an update. it might be an coincidence. I hope the development team can look into this and we don't have to do this once per week.
 

dacow

Members
Oct 27, 2017
5
13
It looks like it might be not really related to an updated. It stopped suddenly working for me before the update. Deleting folder helped again, as well as after the update..
Same here, an update was available (weekly) but I hadn't updated yet but suddenly the payments stopped working. Quick delete and all was good again in the world.