GPS gone after update to 4.5.16

Discussion in 'Xiaomi Mi 3' started by se0067, May 17, 2014.

  1. se0067

    se0067Members

    Feb 18, 2014
    62
    10
    18
    Male
    Hi there,

    as I already mentioned in the title GPS is gone after I updated today to 4.5.16. The trouble started this morning when I installed the latest update and on reboot my phone only showed the golden icon. After about 30 minutes I forced some more reboots but that didn't change anything. So I went to recovery mode only to realize, that I didn't have an update.zip on my phone. Last option: Fastboot. Hadn't done that before. So I figured it out, prepped my laptop and started downloading the fastboot image. This took about 8 hours as over here in Shanghai the connection is just horrible and the download broke down again and again and again. In the end I downloaded it on my computer in Germany, cut it into 50MB pieces and then transferred them to me. The good thing: Flashing in Fastboot mode worked! The phone rebooted and.... tadaa! I got my phone back! But unfortunately I had downloaded and installed the fastboot image version 4.5.9. I had everything in place now to rescue my phone once more, so I dared to run the update to 4.5.16 again. This time I didn't encounter any booting issues. I was very happy! 4 hours later I noticed that I cannot activate GPS.

    Long story, short question: Has anyone experienced this, perhaps even fixed it?
     
  2. bigto

    bigtoMembers

    Apr 30, 2014
    4
    0
    11
    In short, my GPS is now terrible.
    It is one of the main things I use on my phone for satnav which makes it a real problem.
    It does work eventually but takes way too long and if I am in a rush or need it in an emergency than it is not acceptable.
     
  3. se0067

    se0067Members

    Feb 18, 2014
    62
    10
    18
    Male
    Bad GPS would have been a big improvement to my situation while my MI3 was running on 4.5.16. As mentioned before it just could not be activated at all. But as I am currently on a business trip in China I neither have the resources nor the time to figure this out, so I went back to 4.5.9 and everything is fine.
     
  4. se0067

    se0067Members

    Feb 18, 2014
    62
    10
    18
    Male
    Solved with a full download update and install of 4.5.23 via CWM! :) The GPS icon still does not show, but the app GPS Test shows great reception and Google Maps can find me without WLAN.
     

Share Our Site