Installation error (package file invalid) after having installed many apps

Discussion in 'Bugs' started by peanut, Nov 30, 2010.

  1. peanut

    peanutMembers

    Nov 30, 2010
    3
    0
    11
    Hello,

    I'm using the Acer Liquid MIUI port (11.26() which I like very much. All is great apart from one big issue I habve installing apps. I will just quote myself from another android forum:

    ---cut---

    I have strange installation issues with numerous apps, I get "package file invalid" if installing from market and "not installed" if I try by Titanium. It doesn't seem to be app specific - after flashing the first app installs always work, no matter what app, then when I have some more apps I start getting errors. Just to be clear: Installing app x in the beginning ist no problem, whereas the same app causes an error if I install it later on after having installed, say, 20 or 30 apps. Some apps will install later on, too.
    Uninstalling some other apps or moving them to the SD card sometimes (not aways) makes it possible to install one of the apps that didn'T install earlier.
    I still have about 108 free MB (internal) so I don't think it's a matter of space.

    I'm running the latest Froyo Leak + MIUI 11.19 + latest German language pack

    Oh, and some apps cause FC. Apart from those issues: great ROM, I'd like to keep it, I hope problems will be fixed in the future.


    --cut--

    I posted my problem to a Liquid forum (actually, two of them) but got no answer, that's why I'm trying here. I'm aware that there are probably no Liquid users here, but you're my last resort

    Any thoughts on this? For the records, I'm not a pro with android sdk and all, but it's installed on my computer and I can deal with adb if that's necessary.

    I posted my problem to a Liquid forum (actually, two of them) but got no answer.
    I'd really love to solve this problem instead of going back to another ROM because I like MIUI much better than anything I've tried so far. So please, if you have a suggestion, post it. Thanks!
    Karin
     
  2. peanut

    peanutMembers

    Nov 30, 2010
    3
    0
    11
    Following another thread I found out that after a fresh MIUI install always a certain library (com.google.android.maps.jar) is missing in /system/framework. I suppose this could have something to do with the errors I described, right? OK, now what exactly do I have to do about this? I know how to push files using adb, but

    - where do I get this file
    - do I have to push it before or after installing Google Maps
    - should I take care of other files, too?

    I'm sorry, but this is beyond my android knowledge. Anybody help me out, please?
     
  3. peanut

    peanutMembers

    Nov 30, 2010
    3
    0
    11
    Hi there,

    as described earlier in this thread I can't install most apps after having installed a number of them (message "package file invalid)

    Now here's a piece of the logcat file after I tried to install astro file manager.
    It's just an example, there are numerous apps that won't install either. On the other hand they all will install without problem if I install them right after flashing.

    --------cut-------
    02 09:38:47.170 I/ActivityManager( 2787): Starting activity: Intent { act=android.intent.action.VIEW dat=market://details?id=com.metago.astro&referrer=utm_source%3Dappbrain%26utm_medium%3Dapp%26utm_campaign%3Dreferral cmp=com.android.vending/.TabbedAssetInfoActivity }
    12-02 09:39:04.000 D/vending ( 3566): [19] AssetDownloader$DownloadManagerBroadcastReceiver.installFromUri(): Calling install uri=content://downloads/download/60 src=null asset=3521322703668947709 (com.metago.astro:0) [DOWNLOADING] name=ASTRO Datei-Manager last=TRUE
    12-02 09:39:05.200 D/vending ( 3566): [19] VendingNotificationManager.showNotification(): Showing notification: [AssetID=3521322703668947709, NotificationID=-1777258060, Title=ASTRO Datei-Manager, Message=Installation...]
    12-02 09:39:08.880 D/PackageManager( 2787): Scanning package com.metago.astro
    12-02 09:39:08.930 I/PackageManager( 2787): /data/app/com.metago.astro-1.apk changed; unpacking
    12-02 09:39:09.020 D/installd( 67): DexInv: --- BEGIN '/data/app/com.metago.astro-1.apk' ---
    12-02 09:39:16.502 W/installd( 67): DexInv: --- END '/data/app/com.metago.astro-1.apk' --- status=0xff00, process failed
    12-02 09:39:16.502 E/installd( 67): dexopt failed on '/data/dalvik-cache/data@app@com.metago.astro-1.apk@classes.dex' res = 65280
    12-02 09:39:16.712 W/PackageManager( 2787): Package couldn't be installed in /data/app/com.metago.astro-1.apk
    12-02 09:39:17.262 D/vending ( 3566): [6] VendingNotificationManager.showNotification(): Showing notification: [AssetID=3521322703668947709, NotificationID=-1777258060, Title=ASTRO Datei-Manager, Message=Installation fehlgeschlagen.]

    -------------

    Maybe someone an tell what's going on here? Or if not, is there another place where I could ask?
     

Share Our Site