Locked Tiffany bootloader, stucked in bootloop after flashed in edl mode

Oct 10, 2018
Hi all, I m fighting the last days trying to resurrect my mi 5x and I need any kind of tips, advice, inputs you can give

The whole story begun when my phone fell down a few days ago (not sure if it affected the whole situation). The phone after the fall was working normally(for a few hours) but later that day the battery depleted and it switched off. After I plugged it in the charger I tried to open it and it was in a weird mode. I could reach the white screen with the white logo of android and it stuck there for hours. I decided to flash it with a new rom and everything went south.
I will explain in steps all the attempts I have tried:

1) The bootloader was unlocked but it didn't leave me to flash the official Tissot rom that I had downloaded so I reboot my phone through fastboot cmb in edl mode and then with the Miflash tool I flashed the Tissot stock rom. v.
2) The phone hard bricked and I realized that I made a big mistake by flashing a rom from a different bootloader. ( I also realized at that point that I bought the phone with a custom A1 rom with a Tiffany bootloader).
3) I disassembled my phone and I put it in edl mode by using the test points and then I flashed it with a stock Tiffany rom by using Mi flash tools.
4) The phone was in a bootloop after the flash finished.
5) No actions could be made through fastboot and recovery because now the bootloader was locked.
6) After this, I tried several times flashing (in edl mode each time) all the stock Tiffany versions I could find online (stable or beta).
7) Every time after the flashing was done I was turning on the phone and it was again in bootloop.
8) At some point also I tried to side load an update of one of the tiffany's recovery rom (stable and beta) and I was getting an error that the rom is illegal and again bootloop.

The biggest problem is that I can' t unlock the bootloader through xiaomi unlock tool because the device was hardbricked and now my mi account is not bound with the device. If you can answer any of the following questions or if you have any idea you will save me!!!

1) Is there any way to unlock the bootloader?
2) Is there any reasonable explanation of why I am in a boot loop after flashing it with the proper tiffany fastboot rom?
3) Is by any chance the fall that the phone had before anything happen to affect the whole situation?
4) Is there any other way to flash a rom with locked bootloader?

Thank you very much!!!
Apr 22, 2017
With "9008 mode", you can bypass the bootloader even if it is locked. There are two ways to enter this mode:
1. When the mobile phone has power, insert the type-c data cable into the mobile phone, peel off the blue line and the black line, and touch it, the mobile phone will enter the "into 9008 mode".
2, open the back cover of the phone, use a wire or paper clip, tweezers, etc., contact two of the contacts, the phone will enter "9008 mode"
【This is the Xiaomi 5X, the same as the Xiaomi A1.】

Then plug the other end of the data cable into the computer. You can see "port(COM&LPT) - Qualcomm HS-USB QDLoader 9008" in the "Device Manager". At this time, you can use Miflash to flash the ROM.
If you see "cannot receive hello packet, MiFlash is trying to reset status", don't worry, this is a driver problem. In this mode, the driver provided by Xiaomi may not work. Search the Qualcomm phone driver on the web and try again.
Oct 10, 2018
Thank you very much for the reply! I already have tried to flash in EDL mode but when the flashing is done the phone keeps rebooting by itself and it stays stacked to the mi logo. I also have tried to flash a lot of different roms without any success.