Lydsto S1D Max vacuum cleaner connection issue


Feb 2, 2024
I apologize in advance if I am not supposed to post this here. I have a Lydsto S1D Max vacuum cleaner. I have been using it with Lydsto app but it's damn slow. The devices manual says that I can use the Mi Home app instead. It says in the manual: "Press the power and home button for 3 seconds until device says 'WiFi has been reset' and continue pressing them for another 5 seconds until you hear 'Entering Mijia distribution network mode'". I tried this several times but most of the time the app says "No devices found. Add from the list below". The app found the device once but it couldnt connect. It gave me a timeout error and after that the app couldn't see the device again. I tried to manually add the device, but the list on the app does not show the product i have. The closest match is "Lydsto S1". So I selected "Lydsto S1" and tried to manually connect to the devices WiFi network but it still failed. I don't know why it can't connect. I can even see the devices WiFi network reserved for the Mi Home app on my phones WiFi network list. I tried changing the region to Singapore and Chinese mainland too because i thought maybe they didnt add this product to my region yet, but it did not work. I sent a feedback from the app as well like a week ago but haven't received a response. As a last resort, i called Lydsto's customer support line but they said "Maybe they did not update the Mi Home app yet.". I would also be grateful if you can direct me to places where i can get help for this issue.


  • Screenshot 2024-02-02 163015.png
    Screenshot 2024-02-02 163015.png
    82.5 KB · Views: 53
Good afternoon!
I solved the problem, downloaded the latest version of MiHome from the Telegram channel .
I didn't change the region, I found the vacuum cleaner right away.
This Telegram channel solves problems related to HyperOS.
Hello, i was able to find more devices in the app you provided but not the one i own. I guess it's just not in the app yet, thanks for your interest though.