Major Problem, not receiving calls

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by kokotas, Mar 19, 2013.

  1. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Hello guys,

    Since I updated to v5, I have noticed that I cannot receive calls or messages. As soon as I make a call, then and only then, I receive all the calls and messages attempted in the past. I thought that going back to v4 would resolve the issue, but it didn't. I can still not receive calls or messages until I make one myself.

    Is it sleep related, or maybe something to do with the radio? Please advise because this is a vesy serious issue.

    Regards.

    edit: I can't be sure but maybe this is noticed only after a long period of sleep.
     
  2. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Anyone?:(

    I tried fixing permissions for both systems, but after an overnight charge, it did the same thing today. I called my number and it says my phone is probably turned off.

    Some more info: I tried enabling data. The phone re-established the connection with the apn and then I was able to call my phone. But still that didn't "unblock" it so that I could receive the past phone calls. Once I made a call from my phone, I received a message from my apn for my missed phone calls.

    Edit: WTF, more problems. Trying to move a folder from phone to pc, it only copies over a few files and then stops...
     
  3. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    As a last resort I tried miflash and flashing the JLB 12 stable, also wiping everything. Didn't work, after the overnight sleep the phone couldn't receive phone calls again. Now this is pretty much useless then... a phone that can't be called. So much for xiaomi's prestige...

    Unless someone suggests something I'm getting rid of it and will go back to my trustworthy HD2.
     
  4. dextructor

    dextructorMembers

    Feb 26, 2013
    347
    100
    65
    Male
    kokotas

    Let's take a minute to think about it. You said that after upgrade to V5 start the issues, that might be a radio problem or both radio and software problems. I'm assuming that you've done the standard procedures to wipe the data, cache etc to avoid issues from other versions. Did you try to flash again your radio with old version folowing the thread in this forum? Are you using ROM from this forum or chinease? Did you try other variants like Stock Android, WIUI or Lennox?
     
    kokotas likes this.
  5. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    dextructor, thanks for replying! I can only assume it started after I flashed V5 because that's when I noticed the problem. Of course I have tried wiping everything from cwm and going back to english final V4, didn't work. And now I'm on JLB12 from en.miui which again didn't fix the issue.

    I will try the old radio from the radio thread ( http://miuiandroid.com/community/threads/radio-all-xiaomi-mi2-radio-thread.19846/ ) as you suggested and get back to you. Unfortunately I can only test one thing per day, because it only happens during a long period of inactivity. Also it doesn't matter if the phone is charging during the night or not, it still happens on both cases.
     
  6. dextructor

    dextructorMembers

    Feb 26, 2013
    347
    100
    65
    Male

    kokotas

    Ok, let's do the tests with the radio from the thread and I will sugest the same radio that kekkojoker90 mention on his topic 3.2.8 and try different ROM's like WIUI or Lennox worth a shot and keep your system at stock configuration to eliminate other variants. I would start to think also in your carrier SIM card, maybe can be with some problem, mine was too some months ago
     
    kokotas likes this.
  7. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Dextructor, it seems flashing the jlb12 radio from that thread on top of jlb12 fixed my problem! I called my phone as soon as I woke up today and it rang :D
    I will keep an eye on it and maybe retry v5 with another radio, see how it goes. Thank you very much for your help, really appreciate it.
     
  8. dextructor

    dextructorMembers

    Feb 26, 2013
    347
    100
    65
    Male
    kokotas

    I'm glad that worked for you, sometimes the baseband fix am problem for one and makes a problem for other depending of carrier and other variables. Try later other ROMs with this baseband, they are doing a great improvement.
     
  9. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Thanks dextructor, I'm glad too. I just tested 3.2.22 with radio from 3.2.8 and it works very well :) I will now give V5 another shot, see if I get different results than the first time.
     
  10. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Ok, I just tested v3.3.22 with its default baseband and the problem came back! I'm now flashing 3.2.8 radio on top of 3.3.22, I'll let you know how it goes tomorrow.
     
  11. dextructor

    dextructorMembers

    Feb 26, 2013
    347
    100
    65
    Male
    kokotas

    Ok the problem appears to be on the baseband not in the system, because you already tested 3.3.22 with rhe other baseband and worked. Then test other roms like WIUI, Lenoxx or Stock Jellybean and use what you like more.
     
  12. kokotas

    kokotasMembers

    Feb 23, 2013
    40
    6
    18
    Male
    Hello dextructor,

    It was 3.2.22 I had tested, not 3.3.22, but in any case you are correct. Just tested this morning and 3.3.22 works fine for me with radio from 3.2.8 so the problem is indeed the baseband of v5! Case closed. Thanks for your advice :)
     
    dextructor likes this.
  13. martins66

    martins66Members

    Feb 19, 2013
    22
    6
    13
    Male
    Hi, I have ptoblemas with senyal since I'm in V5, I have lost coverage constant.
     

    Attached Files:

Share Our Site