Mi 11 speaker issue


dead4ngel

Members
Jul 19, 2022
5
5
Hi. So the other day out of the blue the speakers started doing what I've posted in the 2 videos attached.

It's very bizarre. At first I thought it might have been a software issue. I was running latest weekly mmx ROM at the time.

Since then I have done a clean flash of aosp ROM ricedroid. Issue is still there. So this suggests it's a hardware fault of sort.

I'm still a bit baffled with how's it come along as I've never dropped the phone nor has it ever gotten wet. Always been in a armour case from day 1. I've never messed with sound mods at all.

I did try installing viper4android after to see if it fixed it and nothing.

Anyone know what this may be? I really like the phone but I don't think it has any warranty left on it. Had it since the release of the mi 11.

Another weird thing is if I reboot the phone sometimes that solves it and speakers work fine. Then issue starts again at some point. Also if I open recents or start closing apps it then sorts itself out. Very weird. Anyway I hope someone on the forum can guide me to try and sort this or even find out what is the issue.

Update wise someone suggested it could be the audio ic or even somehow my persist could be corrupted?

I can't upload the videos as it says file size too large but I will link to my XDA thread so you can view them https://forum.xda-developers.com/t/mi-11-speaker-issue.4472153/
 

Tecalote

Members
Apr 17, 2022
50
30
@dead4ngel
I would still not rule out that it is a software error. Of course, it could also be a hardware defect. If this had happened to me, I would have done a clean-install first with the current Weekly or the Stable. To see if the issue has been resolved. Because I don't think you can fix a software error with a custom ROM like RiceDroid or a module like Viper4Android, but only with the native ROM. A custom ROM and Viper4Android only works properly if the native system worked properly beforehand. That's what I think.
 
  • Like
Reactions: dead4ngel

dead4ngel

Members
Jul 19, 2022
5
5
@dead4ngel
I would still not rule out that it is a software error. Of course, it could also be a hardware defect. If this had happened to me, I would have done a clean-install first with the current Weekly or the Stable. To see if the issue has been resolved. Because I don't think you can fix a software error with a custom ROM like RiceDroid or a module like Viper4Android, but only with the native ROM. A custom ROM and Viper4Android only works properly if the native system worked properly beforehand. That's what I think.
Thanks. I will try to clean flash latest weekly by eu. Don't want to risk flashing latest stable as I've heard it can cause WiFi issues even though my mi 11 isn't a Chinese variant.

In terms of clean flashing would you recommend just using a fastboot weekly and using the clean flash bat or would you said I should wipe all using recovery first (orange fox) then doing fastboot install?
 
  • Like
Reactions: Tecalote

Tecalote

Members
Apr 17, 2022
50
30
@dead4ngel Which model to you have? I looked on the website of OrangeFox and found there just a TWRP for Mi 11x (not Mi 11, not T, not Pro and not Ultra).
I would recommend to use the official TWRP matching your device.
https://dl.akr-developers.com/?dir=skkk/TWRP/A12/v3.8.3_A12

I am not familiar with the Weekly Rom (cause I use stable without any issues)
- you must look in the forum (I heard latest weekly for Mi 11 Ultra is installable with TWRP for A12).
In terms of clean flashing would you recommend just using a fastboot weekly and using the clean flash bat or would you said I should wipe all using recovery first (orange fox) then doing fastboot install
This is a good question. I can't say for sure, because MI 11 Ultra is my first Xiaomi device and I updated until yet only in Fastboot Mode.
(I have already original A12 TWRP and if the next Rom is compatible with TWRP installing, I will do it first time on the Xiaomi device).

I would think that the clean flash bat of a Fastboot Rom would overwrite everything.

But you are on a third party Custom Rom now and perhaps you should wait for another opinion for the procedure of going back to the native Xiaomi.EU Weekly Rom.
 
Last edited:
  • Like
Reactions: dead4ngel

dead4ngel

Members
Jul 19, 2022
5
5
So to get this right. I'm going to download eu stable ROM for mi 11. 13.0.8 . It's flashed via fastboot and I will select clean install in the bat file. Now I wanna know is this a full clean install and will it replace any corrupt files etc on install? Going from aosp ROM
 

dead4ngel

Members
Jul 19, 2022
5
5
@dead4ngel Which model to you have? I looked on the website of OrangeFox and found there just a TWRP for Mi 11x (not Mi 11, not T, not Pro and not Ultra).
I would recommend to use the official TWRP matching your device.
https://dl.akr-developers.com/?dir=skkk/TWRP/A12/v3.8.3_A12

I am not familiar with the Weekly Rom (cause I use stable without any issues)
- you must look in the forum (I heard latest weekly for Mi 11 Ultra is installable with TWRP for A12).

This is a good question. I can't say for sure, because MI 11 Ultra is my first Xiaomi device and I updated until yet only in Fastboot Mode.
(I have already original A12 TWRP and if the next Rom is compatible with TWRP installing, I will do it first time on the Xiaomi device).

I would think that the clean flash bat of a Fastboot Rom would overwrite everything.

But you are on a third party Custom Rom now and perhaps you should wait for another opinion for the procedure of going back to the native Xiaomi.EU Weekly Rom.
i did a clean install of eu fastboot rom. run the script with clean install. when phone booted up sound seemed ok. i didnt install anything or update anything. i just went to the borwser and went on youtube to test sound. it was working fine for abit then the issue started again. rebooted phone. was fine for a bit and issue started again. now im totally stumped as to what this is. a hard ware fault or software fault? i dont even think i got any warranty left :(
 

kearmau5

Members
Oct 19, 2019
146
30
i did a clean install of eu fastboot rom. run the script with clean install. when phone booted up sound seemed ok. i didnt install anything or update anything. i just went to the borwser and went on youtube to test sound. it was working fine for abit then the issue started again. rebooted phone. was fine for a bit and issue started again. now im totally stumped as to what this is. a hard ware fault or software fault? i dont even think i got any warranty left :(
hi i am sorry for your speaker issue i really have never seen anything like this before when i saw the first video i thaught that it was the loud speaker, and them comes the earpiece too, really weird :(:(:( i have a mi 11 too i don't have this issue. Is the problem also happening when you connect another source of sound (bluetooth earbuds or by aux to a speaker for eg ? did you find a solution so far ?
 

Tecalote

Members
Apr 17, 2022
50
30
@dead4ngel It appears to be a hardware defect. After it works for a while and stops working shortly after, it can hardly be a software defect after the clean-install.
 
  • Like
Reactions: kearmau5

Mensch

Members
May 6, 2022
8
13
Hi. So the other day out of the blue the speakers started doing what I've posted in the 2 videos attached.

It's very bizarre. At first I thought it might have been a software issue. I was running latest weekly mmx ROM at the time.

Since then I have done a clean flash of aosp ROM ricedroid. Issue is still there. So this suggests it's a hardware fault of sort.

I'm still a bit baffled with how's it come along as I've never dropped the phone nor has it ever gotten wet. Always been in a armour case from day 1. I've never messed with sound mods at all.

I did try installing viper4android after to see if it fixed it and nothing.

Anyone know what this may be? I really like the phone but I don't think it has any warranty left on it. Had it since the release of the mi 11.

Another weird thing is if I reboot the phone sometimes that solves it and speakers work fine. Then issue starts again at some point. Also if I open recents or start closing apps it then sorts itself out. Very weird. Anyway I hope someone on the forum can guide me to try and sort this or even find out what is the issue.

Update wise someone suggested it could be the audio ic or even somehow my persist could be corrupted?

I can't upload the videos as it says file size too large but I will link to my XDA thread so you can view them https://forum.xda-developers.com/t/mi-11-speaker-issue.4472153/
Hi @dead4ngel, my phone is having this same issue. Were you able to find a solution? It's quite upsetting.