Mi Smart Gateway Hub and Mi Temperature and Humidity Monitor 2


Alexanders

Members
Oct 27, 2020
12
5
Hi,
I have a Mi Smart Gateway Hub connect with MI Home under the Portuguese Region and also a Mi Temperature and Humidity Monitor 2.
For some time my Mi Temperature and Humidity Monitor 2 was detected on the child devices of Mi Smart Gateway Hub, and I could check the temperature and humidity even if i was out of home.
A few weeks ago the hub stopped detecting the sensor, I have tryed a lot of options, like delete the hub and the sensor, but i can't set them working again.
I also find strange that if i check the list of child devices to add at the hub, i only can see 6 devices available and not the one that i have (i supose thats because of the portuguese region?)
Any chance of xiaomi update the firmware of the hub removing the support of the device?
If i connect the the sensor direct by bluetooth to the Mi app I will be able to see the temperature, but cannot make automation works.
 

Attachments

  • 2.jpg
    2.jpg
    9.8 KB · Views: 702
  • 1.jpg
    1.jpg
    19.3 KB · Views: 746

N0xtrum

Members
Oct 28, 2020
3
5
Same problem here. I can't fix it downgrading/upgrading the app, i think is a problem of plugin or firmware of gateway :-(
 
  • Like
Reactions: Alexanders

Alexanders

Members
Oct 27, 2020
12
5
Well, i have changed the region to mainland China and the Hub detects the sensor, and stays connected, everything seems to work just fine.
So i think thats is not a problem of the Hub, but a limitation of the firmware device, that they have inserted a few weeks.

When i connected the hub and the sensor to the china region both had updates.

I couldn't keep this configuration because i also have a plugin switch wifi that is not detected in Mainland China nas i need to use it.

I think that i will try other temperature sensor, like this that is in the supported child devices and keep the region in Portugal.
32550
 

N0xtrum

Members
Oct 28, 2020
3
5
Well, i have changed the region to mainland China and the Hub detects the sensor, and stays connected, everything seems to work just fine.
So i think thats is not a problem of the Hub, but a limitation of the firmware device, that they have inserted a few weeks.

When i connected the hub and the sensor to the china region both had updates.

I couldn't keep this configuration because i also have a plugin switch wifi that is not detected in Mainland China nas i need to use it.

I think that i will try other temperature sensor, like this that is in the supported child devices and keep the region in Portugal.
View attachment 32550

My gateway firmware is 1.4.6_0012

The problem to changing to Mainland China is the big lag. Temperature sensors is not a big problem, but with the door sensors and alarm is a big issue for me.. some times didn't work
 
  • Like
Reactions: Alexanders

Alexanders

Members
Oct 27, 2020
12
5
I only have cameras and temperature sensors and plugin devices for temperature control of a baby room.

My gateway version is 1.4.7_0065 but the news where only for mainland China, 2 new features, auto update for the Hub on China, and redution of the consumation of battery on bluetooth connections, also for China.
This is a bullshit because this feature have worked in the past.
I have send some feedback about this problem to xiaomi.
Lets see if the make any update do fix this.
 

jalr99

Members
Nov 2, 2020
3
5
Hi,
I have a Mi Smart Gateway Hub connect with MI Home under the Portuguese Region and also a Mi Temperature and Humidity Monitor 2.
For some time my Mi Temperature and Humidity Monitor 2 was detected on the child devices of Mi Smart Gateway Hub, and I could check the temperature and humidity even if i was out of home.
A few weeks ago the hub stopped detecting the sensor, I have tryed a lot of options, like delete the hub and the sensor, but i can't set them working again.
I also find strange that if i check the list of child devices to add at the hub, i only can see 6 devices available and not the one that i have (i supose thats because of the portuguese region?)
Any chance of xiaomi update the firmware of the hub removing the support of the device?
If i connect the the sensor direct by bluetooth to the Mi app I will be able to see the temperature, but cannot make automation works.

Hi, I have the same problem.... did you find out a solution? I've Mi Home in Spain Region.

Thanks!!
 
  • Like
Reactions: Alexanders

Alexanders

Members
Oct 27, 2020
12
5
No solution, i guess thats a region limitation on the Hub. I have a new sensor of temperature without display and now i can check the temperature and humidity fine on mi home. I have another problem now, with the automation, i cant set it to work. Dont know why.
 

jalr99

Members
Nov 2, 2020
3
5
No solution, i guess thats a region limitation on the Hub. I have a new sensor of temperature without display and now i can check the temperature and humidity fine on mi home. I have another problem now, with the automation, i cant set it to work. Dont know why.

But, it's works 3 weeks ago... mmmm I hope in the next firmware it'll be ok..... for the other hand, could you explain anything else about the problem with automation??
 
  • Like
Reactions: Alexanders

Alexanders

Members
Oct 27, 2020
12
5
You are right, it was working... Lets see if they update the hub firmware, bucause its stupid, not to work.

My automation is very basic. I have a WIFI switch connect to a heater and also the temperature sensor and the hub.
When the temperature its above 22 degrees it turn off the wifi switch of the heater, when the temperature its below 21 degrees it turn on the wifi switch of the heater, to keep the temperature between the 21/22 degrees.
After i set up the automation nothing happened, but after a few hours it started to work, don't know why... Maybe the automation need to make any kind of "registration" on the xiaomi server?
 

jalr99

Members
Nov 2, 2020
3
5
Well, I couldn't tell you. However, if you see that it does not work for you, try to perform manual task programming ... that is, manually program the switch to turn on, and another manual command to turn it off. And then you already generate the automation, when it rises from 22º to execute the manual switch-off task, and when it drops from 21, it will execute the manual switch-on task ...

I have had a lot of trouble with automatic tasks with clock, and I have solved them all like this ...

Hope this can help you.
 
  • Like
Reactions: Alexanders

Alexanders

Members
Oct 27, 2020
12
5
Well, I couldn't tell you. However, if you see that it does not work for you, try to perform manual task programming ... that is, manually program the switch to turn on, and another manual command to turn it off. And then you already generate the automation, when it rises from 22º to execute the manual switch-off task, and when it drops from 21, it will execute the manual switch-on task ...

I have had a lot of trouble with automatic tasks with clock, and I have solved them all like this ...

Hope this can help you.

Thanks!!!
 

josemari

Members
Nov 13, 2020
2
3
Hi, I have the smae problem. I received my new Xiaomi gateway 3 last wednesday 11. My 4 units of "mi temperature and hygrometer monitor 2" received four weeks ago. On section Bluetooth mesh doesnt shows those 4 monitors.

I just tried to put on China region, but nothing new.

What can I do? What can we do! Xiaomi, please, fix it! :(

Best regards.
 

Alexanders

Members
Oct 27, 2020
12
5
Hi, I have the smae problem. I received my new Xiaomi gateway 3 last wednesday 11. My 4 units of "mi temperature and hygrometer monitor 2" received four weeks ago. On section Bluetooth mesh doesnt shows those 4 monitors.

I just tried to put on China region, but nothing new.

What can I do? What can we do! Xiaomi, please, fix it! :(

Best regards.

I tried on China Region and worked fine for me (i made the test 3 weeks ago).
But i need them to work with some plugins that doesnt work on China, because they are only for Europe.
Also i have read that with China region the delay on notifications is huge.
So i guess that for now, there is no solution with hub 3 and temperature monitor 2.
 

josemari

Members
Nov 13, 2020
2
3
I am going to reply in spanish...

la verdad es que me da rabia. Jo, acabo de comprar el gateway 3, llegó anteayer y por ahora solo era para leer los 4 termómetros... y ni aún cambiando a "China" me ha pillado en la sección mesh (o entrando desde BLE y luego ahí) los termómetros. Si quieres, hablamos en privado (en español) sobre cómo hacerlo.

Thanks.
 

PF847537

Members
Nov 13, 2020
3
5
Same problem here.
Both the Temperature and the Humidity Monitor and the Gateway (v3) are available in the Portuguese store but the sensor is not shown on the possible child devices list.

If botht products are sold in Portugal and my region is set to Portugal, Xiaomi must make this sensor available.
 

Attachments

  • Child devices.jpg
    Child devices.jpg
    131.2 KB · Views: 807
  • Like
Reactions: Alexanders

mamar59

Members
Nov 13, 2020
1
3
HI I am from France, I have 1 Mi Smart Gateway Hub and 4 Mi Temperature and Humidity Monitor 2 I have just succeeded in all connected seemingly after having searched well and all trying, to get there you have to put maindeland CHINA not the choice and then you must appear several times your sensor so that it appears in the hub, I believe that xiaomi has problems with our European version
 

Attachments

  • Screenshot_20201113-234248.jpg
    Screenshot_20201113-234248.jpg
    255 KB · Views: 1,229
  • Screenshot_20201113-234214.jpg
    Screenshot_20201113-234214.jpg
    303.7 KB · Views: 1,094

Alexanders

Members
Oct 27, 2020
12
5
HI I am from France, I have 1 Mi Smart Gateway Hub and 4 Mi Temperature and Humidity Monitor 2 I have just succeeded in all connected seemingly after having searched well and all trying, to get there you have to put maindeland CHINA not the choice and then you must appear several times your sensor so that it appears in the hub, I believe that xiaomi has problems with our European version

Hi,
Thats not a option for me, I have some devices that only works on European Server and need them connected with the sensores.
 

Alexanders

Members
Oct 27, 2020
12
5
Same problem here.
Both the Temperature and the Humidity Monitor and the Gateway (v3) are available in the Portuguese store but the sensor is not shown on the possible child devices list.

If botht products are sold in Portugal and my region is set to Portugal, Xiaomi must make this sensor available.

Bom dia,
Esses sensores em principio não deveriam aparecer nos child devices, pelo menos para já.
Mas deveriam ser detectados no bluetooth mesh gateway, e ai é que está atualmente o problema. Simplesmente não é detectado de forma nenhuma.
 
  • Like
Reactions: PF847537

Xodarap93

Members
Nov 20, 2020
4
5
I am facing the same issue. 2 bedside lamps as Gateways and 4 Sensors. Since a few weeks no sensor is recognized.
Server is Germany.

I Hope for a fast fix without changing the conclusion.
 
  • Like
Reactions: PF847537

PF847537

Members
Nov 13, 2020
3
5
Got a reply from Xiaomi global support: "I would like to inform you that every device is designed as per the basic requirement of a specific region. Hence, we are unable to assure you regarding the working."
 

SamPT

Members
Sep 18, 2018
3
15
+1 here with the same issue
Mi Gateway in China Mainland , can't add Humidity / Temp monitor 2. The device is not listed on the child devices, only the first version.
The only way I can add this device to my home automation is via home assistant which I don't want because it required BT active connection on the server side.
PLEASE XIAOMI FIX THIS