New Mi9 9.8.8 no bluetooth sound


kamaloo

Members
Jun 18, 2019
5
5
After updating to Android 10 I get no Bluetooth sound. I've tried re-pairing my headphones. Bluetooth settings shows that I'm connected to my WH-1000XM2 with LDAC (I've tried other codecs as well). Still, I get no sound from YouTube or Spotify app. Using built-in speakers everything works.
 

marcel112

Members
Jun 2, 2011
334
52
Did you dirty flash or full wipe?
Tried to wipe cache and dalvik or made new BT connections instead off use same

Verstuurd vanaf mijn MI 9 met Tapatalk
 

kamaloo

Members
Jun 18, 2019
5
5
It was a dirty flash. I've tried re-pairing (removing connection and adding it again). I'll try the cache/dalvik wipe.

EDIT: Wiping cache/dalvik haven't changed anything :(
EDIT2: Also I can see that controlling playback (prev/next/pause) works - only the sound is missing.

EDIT3: Disabling (was enabled by default) the "Disable Bluetooth A2DP hardware offload" in developer settings helped.
 
Last edited:

marcel112

Members
Jun 2, 2011
334
52
It was a dirty flash. I've tried re-pairing (removing connection and adding it again). I'll try the cache/dalvik wipe.

EDIT: Wiping cache/dalvik haven't changed anything :(
EDIT2: Also I can see that controlling playback (prev/next/pause) works - only the sound is missing.

EDIT3: Disabling (was enabled by default) the "Disable Bluetooth A2DP hardware offload" in developer settings helped.
So.. Yesterday I dirty flashed also.
I had sound on BT, but when I did your edit 3 switch I also didn't had sound. But for me it was off by default.
Turned it off again and there is the sound again

Verstuurd vanaf mijn MI 9 met Tapatalk
 

Ted presley

Members
May 8, 2018
42
20
It was a dirty flash. I've tried re-pairing (removing connection and adding it again). I'll try the cache/dalvik wipe.

EDIT: Wiping cache/dalvik haven't changed anything :(
EDIT2: Also I can see that controlling playback (prev/next/pause) works - only the sound is missing.

EDIT3: Disabling (was enabled by default) the "Disable Bluetooth A2DP hardware offload" in developer settings helped.
The last option works for me, tks.
 
Feb 21, 2017
2
13
I have problems with bluetooth too. On my Mi6 the audio power in very tiny... For hearing, i have to set max volume...
On my Mi6