New MIUI 11: config missing for VoWiFi on T-Mobile Austria


Bluebrain

Members
Oct 30, 2019
8
15
After several hours of testing, I came to the conclusion that there must be some configuration data be missing for VoWiFi on T-Mobile Austria.

mi 9T Pro
MIUI 11.0.5 (xiaomi.eu)

VoLTE works(! even though no icon is displayed)
VoWiFi does not work with my T-Mobile AT SIM-card, but works with an O2 prepaid card from Germany and VoWiFi works with my T-Mobile AT card in other devices, e.g. Galaxy S8 or Galaxy S10.

yes, both is activated by my provider
yes, I used the "activation" code (*#*#869434#*#*)
yes, I also tried modifying the build.prop with additional parameters for VoLTE and VoWiFi
yes, I changed the modem configuration file and tried several different
yes, I have the switches in settings for activating VoWiFi
yes, I restarted several times and tried several other things


As said, with an O2 DE card VoWiFi works on the 9T Pro, and my T-Mobile VoWiFi also works in a Galaxy S8 and S10.
So only the combination 9T Pro + T-Mobile AT does not work for VoWiFi.

That's what I found in a Galaxy S10 ROM and might be missing in the MIUI ROM:

/system/etc/epdg_apns_conf.xml (full file attached)

XML:
<!-- Austria : T-mobile : MAX,TRG -->
<vowifi mnoname="TMobile_AT"
    wifi_call_enable="1"
    wifi_call_preferred="2"
    wifi_call_when_roaming="0"
/>

<!-- Austria : T-Mobile : MAX,TRG -->
<apn mnoname="TMobile_AT"
    connname="imsApn"
    apnname="ims"
    authtype="EAP"
    subnettype="IPV4V6"
    userauthtype="false"
    pfs="false"
    ownuritype="USER_FQDN"
    ownidentity="023430123456701@nai.epc.mnc003.mcc232.3gppnetwork.org"
    remoteuritype="KEY_ID"
    remoteidentity="ims"
    tunneltype="IPSEC_RAC"
    ipsecencryption="IPSEC_ENCRYPTION_BASIC"
    ipsecintegrity="IPSEC_INTEGRITY_HMAC_SHA1_96"
    ipsecgroup="IPSEC_GROUP_MODP_1024"
    ipseclifetime="IPSEC_LIFE_TYPE_SECONDS"
    ipseclifevalue="28800"
    ikeversion="IKE_VERSION_2"
    ikeintegrity="IKE_INTEGRITY_HMAC_SHA1_96"
    ikeencryption="IKE_ENCRYPTION_BASIC"
    ikegroup="IKE_GROUP_MODP_1024"
    ikeeaptype="EAP_METHOD_AKA"
    ikelife="86400"
    ikewindowsize="1"
    ikedpdtimeout="60"
    ikeconnectiontimeout="10"
    ikenatvalue="30"
    ikevirtualadaptername="tap0"
    vendorattribute="P-CSCF-V4V6"
    periodicdpdtimer="120"
    mobike="false"
    imei="NONE"
    fastreauth="false"
/>
<!-- Austria : T-Mobile : MAX,TRG -->
<apn mnoname="TMobile_AT"
    connname="mmsApn"
    apnname="mms"
    authtype="EAP"
    subnettype="IPV4V6"
    userauthtype="false"
    pfs="false"
    ownuritype="USER_FQDN"
    ownidentity="023430123456701@nai.epc.mnc003.mcc232.3gppnetwork.org"
    remoteuritype="KEY_ID"
    remoteidentity="HOS"
    tunneltype="IPSEC_RAC"
    ipsecencryption="IPSEC_ENCRYPTION_BASIC"
    ipsecintegrity="IPSEC_INTEGRITY_HMAC_SHA1_96"
    ipsecgroup="IPSEC_GROUP_MODP_1024"
    ipseclifetime="IPSEC_LIFE_TYPE_SECONDS"
    ipseclifevalue="28800"
    ikeversion="IKE_VERSION_2"
    ikeintegrity="IKE_INTEGRITY_HMAC_SHA1_96"
    ikeencryption="IKE_ENCRYPTION_BASIC"
    ikegroup="IKE_GROUP_MODP_1024"
    ikeeaptype="EAP_METHOD_AKA"
    ikelife="86400"
    ikewindowsize="1"
    ikedpdtimeout="60"
    ikeconnectiontimeout="10"
    ikenatvalue="30"
    ikevirtualadaptername="tap0"
    vendorattribute="P-CSCF-V4V6"
    periodicdpdtimer="120"
    mobike="false"
    imei="NONE"
    fastreauth="false"
/>
<!-- Austria : T-Mobile : MAX,TRG -->
<apn mnoname="TMobile_AT"
    connname="xcapApn"
    apnname="xcap"
    authtype="EAP"
    subnettype="IPV4V6"
    userauthtype="false"
    pfs="false"
    ownuritype="USER_FQDN"
    ownidentity="023430123456701@nai.epc.mnc003.mcc232.3gppnetwork.org"
    remoteuritype="KEY_ID"
    remoteidentity="HOS"
    tunneltype="IPSEC_RAC"
    ipsecencryption="IPSEC_ENCRYPTION_BASIC"
    ipsecintegrity="IPSEC_INTEGRITY_HMAC_SHA1_96"
    ipsecgroup="IPSEC_GROUP_MODP_1024"
    ipseclifetime="IPSEC_LIFE_TYPE_SECONDS"
    ipseclifevalue="28800"
    ikeversion="IKE_VERSION_2"
    ikeintegrity="IKE_INTEGRITY_HMAC_SHA1_96"
    ikeencryption="IKE_ENCRYPTION_BASIC"
    ikegroup="IKE_GROUP_MODP_1024"
    ikeeaptype="EAP_METHOD_AKA"
    ikelife="86400"
    ikewindowsize="1"
    ikedpdtimeout="60"
    ikeconnectiontimeout="10"
    ikenatvalue="30"
    ikevirtualadaptername="tap0"
    vendorattribute="P-CSCF-V4V6"
    periodicdpdtimer="120"
    mobike="false"
    imei="NONE"
    fastreauth="false"
/>
I have searched in every .xml file on the device and many other files but could not find any similar configuration file with ...3gppnetwork.org in it.
Does anyone know where this config for different providers is stored in MIUI ROM?
 

Attachments

Last edited:

nmercy

Members
Dec 27, 2019
50
20
I'm not an expert but I did some research after having similar problems to yours. I can say that both VoLTE and VoWifi are carrier and manufacturer depending services.
Both need to had an homologation agreement. Carrier's must provide the configuration parameters for the device to work in their network and manufacturers must include that configuration in their ROM.

Of course there's a standard configuration for the services to work that came with any ROM and carriers are more or less restrictive providing them that's why you had VoWifi working with one provider but not the other.

What I have seen is that VoLTE service seems to be less restrictive in terms of compatibility and registration but apparently VoWifi has more conditions or specific parameters for the service to work.

The problem is that not all the brands manage the modem and carrier configuration on their Android ROMs in the same way so it's not just import a config file or a parameter from a working phone.

I didn't find either were this parameters are stored in MIUI, maybe the developers could provide any info...

Enviado desde mi MI 9 mediante Tapatalk
 

Bluebrain

Members
Oct 30, 2019
8
15
I totally agree with what you said.
There's a good chance, a specific certificate or similiar is needed.
As you said, VoWiFi is not that easy as there must be a "trusted connection" to the mobile provider as the SIM card is no longer connected to the network, so it must be confirmed that only approved clients can connect and make phone calls "on behalf" a certain phone number.
But perhaps all this is stored on the SIM card, even though it's not connected via GSM, it's still inside the device and it can communicate with it.

Sadly, there is little to no info regarding VoWifi in the web. I'm also only guessing.

It's just sad that my provider is not working. And T-Mobile Austria (now "Magenta Austria") is 100% owned by "Telekom / Magenta Germany", the biggest mobile provider in Europe.
 

nmercy

Members
Dec 27, 2019
50
20
Sadly I'm in the same boat as you with my provider, at least I had VoLTE working.

As you say I think too that must be some type of authentication needed for VoWifi to work but I don't think it's sim related I guess it's just an missing or wrong parameter in the ims registration process but as you say there's little to none information about it out there plus I couldn't find the files that store the process parameters..

I play a little with the APN config but with no luck

Enviado desde mi MI 9 mediante Tapatalk
 

Bluebrain

Members
Oct 30, 2019
8
15
I just invested a few hours more and flashed the official Xiaomi EEA ROM in hope for better EU provider specific support by Xiaomi itself.
But no luck. :( Still doesn't work with T-Mobile Austria.

I'll pick up a Galaxy Note 10 tomorrow!
 

HulleBulle

Members
Jun 13, 2019
31
20
I tried that before, but failed because of the Modemprofile. I just couldn't find that "DT-Greece". Today downloaded the latest Qualcomm Drivers plus the latest QPST-Tool. So I managed to get DT-Greece active. Done all the magic with activationcodes and so on.

Sadly that changed nothing, VoWiFi still not working on my Lavender (with german O2/Telefonica SIM). VoLTE was working properly before, just by disabling Carrier-Check (*#*#86583#*#* ).

So no luck for me...

27996
 

nmercy

Members
Dec 27, 2019
50
20
I couldn't try it yet but I see that you didn't activate the sub0 option. Other problem could be that the DT_Grece profile doesn't suit for your carrier so need to try with another of the profiles

Enviado desde mi MI 9 mediante Tapatalk
 

HulleBulle

Members
Jun 13, 2019
31
20
Yes, DT_Greece should be correct as mentioned in the linked XDA-Thread. Meanwhile I activated the profile on Sub0 too. What has, as expected, no effect. - Sim is placed in second (SUB1).
 

nmercy

Members
Dec 27, 2019
50
20
My mistake then.

I assume you enable VoWifi with *#*#869434#*#*

Enviado desde mi MI 9 mediante Tapatalk
 

color

Members
Jul 25, 2019
10
15
with dt_grece vowifi is working on my mi9 and a1 austria

Gesendet von meinem MI 9 mit Tapatalk
 

HulleBulle

Members
Jun 13, 2019
31
20
My mistake then.

I assume you enable VoWifi with *#*#869434#*#*

Enviado desde mi MI 9 mediante Tapatalk
That just disables VoWiFi Carrier-Check, respectively enables VoWiFi switch in settings. Switching that on, doesn't mean necessarily that VoWiFi is actually working.
 

nmercy

Members
Dec 27, 2019
50
20
That just disables VoWiFi Carrier-Check, respectively enables VoWiFi switch in settings. Switching that on, doesn't mean necessarily that VoWiFi is actually working.
I know I was just asking.

Well I tried but couldn't get the phone recognized by QPST tool

Enviado desde mi MI 9 mediante Tapatalk
 

Bluebrain

Members
Oct 30, 2019
8
15
As I wrote in the first post:
yes, I changed the modem configuration file and tried several different
I tried that too.

Btw. this can be done much easier directly on the device with the app "Activity Manager 3.0.0" (not on Google Play, search for the apk)
Install the app, search for "modem config", open it and select your desired modem configuration file.
 

Attachments

nmercy

Members
Dec 27, 2019
50
20
As I wrote in the first post:

Btw. this can be done much easier directly on the device with the app "Activity Manager 3.0.0".
Thanks for that info, you have saved me a lot of work .
I have tried the activity manager method without success.

Enviado desde mi MI 9 mediante Tapatalk
 

nmercy

Members
Dec 27, 2019
50
20
Well I decided to try again with the activity manager and playing with it I ended selecting a modem config and the VoWifi just got enable an working...

I will try it further but for now it works
Screenshot_2020-01-11-02-01-55-555_com.xiaomi.mbnloader.jpg


Enviado desde mi MI 9 mediante Tapatalk
 

Bluebrain

Members
Oct 30, 2019
8
15
No, just a working phone. ;)
In my office, reception is nearly zero. So without VoWiFi, I cannot make phone calls and my clients cannot call me!
So all the other features get irrelevant if I can't make PHONE CALLS with a PHONE!
 

HulleBulle

Members
Jun 13, 2019
31
20
As I wrote ...

... can be done much easier directly on the device with the app "Activity Manager 3.0.0" (not on Google Play, search for the apk)
Install the app, search for "modem config", open it and select your desired modem configuration file.
No luck with that. Within Activity Manager, I can't find/there is no "modem config". - Don't know why!

Igor, no VoWiFi with Lavender in general? My provider should support it.


28005

28006
 

Bluebrain

Members
Oct 30, 2019
8
15
Then you might have to go the way with the Qualcomm PDC tool.

Or, try the following:
Mein Gerät > Alle Spezifikationen > 5 x click on "Kernel"
CIT Tool opens.
Click on the 3 dots in the right top corner and select "weitere Tools".
Then "MODEM Testtools" and there (should be the last in the list) "MBN-Konfigurations-, Lade- und Aktivierungswerkzeug".
 

HulleBulle

Members
Jun 13, 2019
31
20
Or, try the following:
Mein Gerät > Alle Spezifikationen > 5 x click on "Kernel"
CIT Tool opens.
Click on the 3 dots in the right top corner and select "weitere Tools".
Then "MODEM Testtools" and there (should be the last in the list) "MBN-Konfigurations-, Lade- und Aktivierungswerkzeug".
Nope, nothing there in my Lavender. - Never mind!
28051


How should I know?
I don't even have VoWiFi supported in my country...
Just asking...