MIUI not falling back to mobile data


Entreri

Members
Aug 25, 2011
12
11
Well, I don't know to be honest... just hooked my phone to the computer and tried adb logcat. I can see the WIFI_STATE_CHANGED_ACTION but there's so much going on, I don't really know what to look for. :(

Is there any way to show only relevant data for the connection change?
 

Tr0jAn

Admin
Nov 28, 2011
52
18
Is there any way to show only relevant data for the connection change?
The problem then would be that only certain data would be there for us to look at, we really need ALL the data, to you it may not seem relevant, to us, it might be :)

TrOjAn
 

Entreri

Members
Aug 25, 2011
12
11
Alright, quick update from me which I hope helps even more than the logfile (which I can post later, if still needed).
I just found out about this tool: http://htcfanboys.com/download/xavierjohn22/?action=browse&folder=3130, which enables you to change some settings which are normally hidden.

I toyed with it a little and found a setting to set the prefered network type (Testing Settings -> Phone Information), which was set to WCDMA by default. I set this to "GSM Auto (PRL)" and it seems to be working fine now.
As far as I know, CDMA is US only.
At least, I disabled WiFi after waking up today, so the phone was connected the whole night. It switched instantly to my mobile data connection :).

Hope this info helps the developers. Don't know why with a GSM Desire it would be set to WCDMA prefered.
At least, this setting should not be hidden.
 

MarkHUK

Founder of Xiaomi.eu
Staff member
Nov 6, 2010
5,074
1,000,000
Alright, quick update from me which I hope helps even more than the logfile (which I can post later, if still needed).
I just found out about this tool: http://htcfanboys.com/download/xavierjohn22/?action=browse&folder=3130, which enables you to change some settings which are normally hidden.

I toyed with it a little and found a setting to set the prefered network type (Testing Settings -> Phone Information), which was set to WCDMA by default. I set this to "GSM Auto (PRL)" and it seems to be working fine now.
As far as I know, CDMA is US only.
At least, I disabled WiFi after waking up today, so the phone was connected the whole night. It switched instantly to my mobile data connection :).

Hope this info helps the developers. Don't know why with a GSM Desire it would be set to WCDMA prefered.
At least, this setting should not be hidden.
Thanks for this, i've just forwarded this to the development team for review.

Mark
 

Entreri

Members
Aug 25, 2011
12
11
Did you try the other possible settings for prefered network type?
On my first try I set it to "GSM only" and suddenly I only got an EDGE connection instead of HSDPA. So you might need to play around a little.
 

Sachet

Members
Feb 20, 2012
9
21
Of course, if you select GSM Only, you won' have access to HSDPA (unacceptable for me). I've tried different settings, still no luck!
What setting did you use to make it work?
 

Entreri

Members
Aug 25, 2011
12
11
I used "GSM Auto (PRL)" - no idea what PRL means, just tested all the settings.
This also gives me HSDPA though.
 

Sachet

Members
Feb 20, 2012
9
21
I've tried several settings including yours, Entreri, still no luck. Passing through plane mode is still mandatory to fall back to 3G... :(
 

miki007

Members
Feb 24, 2012
4
11
Hi, I'm on latest 2.3.7 MIUI XJ data2ext+ 2.6.37.6, build 2.3.30 with HTC Desire GSM. This problem is still present.
Is there perhaps any hotfix available? Thanks