Need help on creating custom ROM for version HM2014813 (Asian LTE band)

Discussion in 'Xiaomi Redmi 2 4G/LTE' started by Brian Nguyen, Jan 23, 2015.

  1. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    #1Brian Nguyen,Jan 23, 2015
    Last edited: Jan 23, 2015
    After one day of trying ROMs for Redmi 2 4g LTE. I realized that there're 2 versions, HM2014813 and another HM2014811. When I'm on HM2014813-6.2.8.0-4.4 version, flash any ROMs of HM2014811 is impossible.
    I tried to make a ROM based on HM2014813-6.2.8.0-4.4 stable with jBART v2a, then to include only one translation pack, and flash this custom ROM. Thing turns out that it's worked, but there's a problem when press menu button (the launcher is crashed, and I'm not enough skillful to debug those).

    So I hope someone can help me with the HM2014813 ROM: http://www.miui.com/download-273.html
    In our ROMs download, I only found the multi language ROM for HM2014811. I tried to flash so many times, except trying the custom Recovery, because I scare of the risk that it could brick my phone. Each times I think I near the line, it failed me with the error, and I just could say "Damn, should it be not that frustrated?".

    I really need some help. I'm so affraid to do experiments to this phone ...

    Updated:
    LTE having product number WT86047 -> HM2014813
    WCDMA having product number WT88047 -> HM2014811
    So I think some one might want to check the version before flashing ($flashboot -s <your device id> getvar product). The device-id is under Device information.
    I guess the version WT88047 is for international market, and will unlock for all network types. And LTE is limited in LTE, TD-SCDMA only, maybe?
     
  2. Acid

    AcidScripting Ninja
    Staff Member

    Aug 20, 2011
    2,726
    743
    245
    Male
    Well if you are flashing 811 on 813 device then... Its ok when it's not allowing you to do that. That's correct. You can't do that. That's all.

    You have Redmi 2 TD LTE with Asian LTE Bands. We support only Band 3 models which are Redmi 2 4G FDD LTE.

    Wysłane z MI4
     
  3. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    #3Brian Nguyen,Jan 23, 2015
    Last edited: Jan 25, 2015
    Yeah, there're a lot of obscure to user when you're not providing full information in such important place.
    Well, I'm very wrong when think this site is a room for dedicated multi-lang ROMs, and I'm very wrong when believe some users that saying WCDMA version of Redmi 2 and LTE Redmi 2 are the same. Um, right, in some point it can be unlocked, then it can lead user to think that, every Redmi 2 can just flash this ROM.
    Btw, even in this sub-forum, I think you could just change the title to Redmi 2 4G/LTE (Band 3 models).
    I'll check the translation guide, though.
    Thank you.
     
  4. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    #4Brian Nguyen,Jan 29, 2015
    Last edited: Jan 29, 2015
    Hi Acid,
    Is there any way that I can make another ROM for HM20140813 model base on 0811 model?
    In my country GSM/TD is used more than CDMA, that's why I chose TD version when ordering this phone.
    Thank you.
     
  5. Acid

    AcidScripting Ninja
    Staff Member

    Aug 20, 2011
    2,726
    743
    245
    Male
    Try just move only apps from 811 model to 813.

    Wysłane z MI4
     
  6. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    Can you provide more details on this please?
    I have already read translating documentation but it's outdated (for v6), so I'm hestitated to continue. However, I guess the ROM won't be much different between both models.
     
  7. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    I have tried to move and replace apps from 811 model to 813 model (the 2.8.0 version of stable branch), then use the jBart to sign again (if not, the updating will be failed, exception: zip file corrupted). The errors are still existed (only on recent application screen).
     
  8. Acid

    AcidScripting Ninja
    Staff Member

    Aug 20, 2011
    2,726
    743
    245
    Male
    What errors

    Wysłane z MI4
     
  9. Brian Nguyen

    Jan 23, 2015
    29
    1
    13
    Male
    Hi,
    Launcher is crashed and automatically restarted, then switched to lockscreen. I also tested with other languages and replace the framework-2.apk after checking both ROMs (using compare tool). And those errors are still appeared.
    I attached the logcat. The log_error_vi.txt is logged when I press the menu button on device after switching to vi/other lang.
    log_normal_en.txt is logged when I press the menu button on device after switching to en (no crashed).
     

    Attached Files:

Share Our Site