In Progress No 3G on Vodafone NL


w3rd

Members
Mar 25, 2012
11
0
11
#1
Hi all,

I'm having some issues getting my data working on my MI-ONE.
I've got this issue for a while now but the problem occured ever since i've updated to ICS.
I'm currently running 2.4.27.

At first I thought my SIM card was getting old so I went to my carrier's shop and asked them to check it out. They've provided me with a new SIM card but still it wouldn't work. So they've checked a couple of things with a technician but there's no sign there's something wrong at their side.

I've tried my SIM card in another phone and 3G works just fine there. I've also put several other SIM cards in my MI-ONE (even Vodafone NL Business, which uses a different APN - office.vodafone.nl instead of live.vodafone.com) and they all worked fine.

Is there anyone who can help me out? I'm a 100% sure I'm using the right APN settings.
Sometimes when I restart the phone or toggle the airplane mode I can see the 3g icon appear for a brief second but then it just disappears again.
 
Nov 26, 2011
78
6
18
#4
Got exactly the same issue but on another dutch mobile network ( telfort / KPN )
Also double checked the APN settings and they are ok.

Running on 2.3.5 here...
 
Nov 26, 2011
78
6
18
#6
Did so ; no difference ...

Will try the newest rom to see if that works...
Unsure how to install that tough...

UPDATE:

A couple of reboots later after installing 2.3.5S ( from 2.3.5R) 3g works ! :D
 
Nov 26, 2011
78
6
18
#13
This might work :

Open the dialer and give in this : *#*#4636#*#*

Select phone information.
In the list that comes up is the SET PREFERED NETWORK TYPE option.
Choose that one and test another option ( there is quite a list ;) )

I've used it to test on having 2g only , 3g pref. and 3g only
( a late miui GB only gave me 2g and 3g pref. with 3g not working ... )

Vodafone might need the gsm (prl) option but i'm not sure...
A friend of me is enigineer at vodafone , will ask him about this also...
 

w3rd

Members
Mar 25, 2012
11
0
11
#14
This might work :

Open the dialer and give in this : *#*#4636#*#*

Select phone information.
In the list that comes up is the SET PREFERED NETWORK TYPE option.
Choose that one and test another option ( there is quite a list ;) )

I've used it to test on having 2g only , 3g pref. and 3g only
( a late miui GB only gave me 2g and 3g pref. with 3g not working ... )

Vodafone might need the gsm (prl) option but i'm not sure...
A friend of me is enigineer at vodafone , will ask him about this also...
Thanks for your reply.
As I recall, we're on WCDMA, so GSM/WCDMA Auto is the right option to use.
This still allows us to switch to 2G networks so there's your 2G/3G Pref.

Like you've asked I've PM'ed you so your friend can take a look at it.
Still, I'm pretty sure it's a bug. Why should it work perfectly fine under GB and not under ICS?
 
Nov 26, 2011
78
6
18
#15
In NL we run gsm and wcdma if i'm right ;)
EDGE is no longer in use ( my provider have used it in the past ;) ) ; LTE is there in a couple of cities but not nationwide...
On KPN i'm on the gsm only setting but the PRL options might work .

Having seen that in at least one version of GB it also worked i'm also quite sure that it's a bug...

I noted somebody that also had the issue but on the htc desire ; he was on gsm/wcdma ( auto ) and solved the issue selecting the gsm only option.
 
Jul 19, 2012
2
0
11
#17
I have been doing some tests, and I think I figured out when the Network Type Selection works and when it fails.

There must be some part of the code that checks if 3G is available before switching to 3G, or to 2G.

You won't be able to switch if you THERE IS NO SERVICE (SIGNAL), this issue will be rather hard to recreate because most of our devs have very good service in their work places.

I think what needs to be done is to disable the checking of the service and simply allow the switch, of course I am in no position to actually say if this is even possible since I haven't even checked the code out.
 
May 19, 2012
228
40
50
#20
Yes, I couldn't find it too. Somebody at miui-au said it would work with their ROM, I will give it a try later this evening

Sent from my HTC One X using Tapatalk 2
 
May 19, 2012
228
40
50
#22
So the last few days I was busy with the Miui-Au rom. I don't know what's going wrong. With some help from Lennox (Miui-AU) we did some test etc. But still no 3g :( So if anyone has a good working Mi-One with 3g pleas tell me so maybe we can figure out what the problem is.
 
May 19, 2012
228
40
50
#23
is there somewhere a ppp protocol. I found someone with the same problem. (Don’t know which phone except it’s Android) He had to change the PPP protocol username/password. It didn’t use the same as APN (probably it should look for that??). Hope somebody understand what Im saying


WOW WOW It’s working
:D:D
So here is what changed everything. I had a chat with VodafoneNL, they changed my customer-account at Vodafone to a business-account and now it’s working fine. I don’t know what the difference between a business-account and a customer-account is. Wel at least now we are up and running