OpenVPN in MIUI / which Kernel to use?

Discussion in 'Question & Answers' started by nailz, Nov 27, 2010.

  1. nailz

    nailzMembers

    Nov 27, 2010
    3
    0
    11
    Hi,

    i was wondering if anyone was able to get OpenVPN working under MIUI.
    I looks like, that i am missing the Kernel Module for the Tap/Tun Device (tun.ko). Is there a Kernel available which provides this Module and is running well with MIUI on a Desire?

    Many Thanks in advance,

    nailz
     
  2. Rcocchiararo

    Rcocchiararo<b>Forum Donator</b>

    Nov 7, 2010
    202
    2
    40
    System Administrator
    Argentina
    buuu

    i was almost sure that i was using OpenVPN installer and OpenVPN settings from the market for this

    now i rechecked, and they don't work (i can install it, but conecting fails).

    it says:

    FATAL: linux ifconfig failed: could not execute external program

    this hapens in the "get config" stage of the connection.

    This worked 100% sure on enomether "the official" rom.
     
  3. an0therus3r

    Nov 27, 2010
    6
    0
    11
  4. Rcocchiararo

    Rcocchiararo<b>Forum Donator</b>

    Nov 7, 2010
    202
    2
    40
    System Administrator
    Argentina
    weird, i have those same versions, installed from market.

    i installed to:
    /system/xbin

    and ifconfig to:
    /system/xbin/bb

    EDIT:

    ok, for some reason on the other rom, i had or had created the /bb folder, that i can't create nor have here.
     
  5. nailz

    nailzMembers

    Nov 27, 2010
    3
    0
    11
    Thanks for your answers.

    i still can't get it to work, the openvpn installer fails while trying to create the target directory under /system/xbin/bb and the cp commands. It quits cp and mkdir commands with an Error: out of memory. Even if i try to create the directory manually in the shell, it quits with the same error.

    Any Idea what i am missing here? I tried it on two different Desires, both with Miui 11.19 deodexed eng. Same result here :-/
     
  6. Rcocchiararo

    Rcocchiararo<b>Forum Donator</b>

    Nov 7, 2010
    202
    2
    40
    System Administrator
    Argentina
    i could not create /bb either

    but installing/choosing /system/xbin on both questions worked.

    ps: i even tried crating /bb with root explorer, nothing happened.
     
  7. jbbandos

    jbbandosMembers

    Nov 23, 2010
    28
    0
    11
    I am having a strange problem with openvpn, even if I it seems to connect fine, I still have the same sites blocked, and checking my ip with a site shows that the ip doesn't change. The same config file works on my laptop.

    As route and ifconfig don't seem to work, and are linked to toolbox instead of busybox, I tried linking them to busybox, and got that no route was defined for tun0, and checking with ifconfig, there is no tun0 device. I am using wildmonks kernel, which is supposed to have tun complied into it and not as a module.
    Any idea?
     
  8. jbbandos

    jbbandosMembers

    Nov 23, 2010
    28
    0
    11
    Well, this now works. The secret is to link /usr/xbin/route to /usr/xbin/bb/route and /usr/xbin/ifconfig to /usr/xbin/bb/ifconfig, and tell openvpn installer to install in /usr/xbin/ and use ifconfig and route in /usr/xbin/bb.
     
  9. AdrM

    AdrMMembers

    Jul 10, 2013
    51
    4
    18
    Male
    #9AdrM,Oct 6, 2013
    Last edited: Oct 6, 2013
    Hi
    I have run openvpn installer
    I have run openvpn setting
    I have import profile. But I get always this error:

    ....
    /system/xbin/ifconfig tun0 172.27.xx.xx netmask 255.255.252.0 mtu 1500 broadcast 172.27.xx.xx

    Sun Oct 6 10:43:12 2013 /system/xbin/route add -net 198.252.xx.xx netmask 255.255.255.255 gw 192.168.xx.xx

    Sun Oct 6 10:43:12 2013 /system/xbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 172.27.0.1
    No such process

    Sun Oct 6 10:43:12 2013 ERROR: Linux route add command failed: external program exited with error status: 3
    ...

    How to run Openvpn ?
    Is there anybody who successfully run openvpn on Mi2s with Miui 5?

    Tnx
     
  10. MiKhan

    MiKhanMembers

    Sep 21, 2013
    201
    52
    50
    @AdrM: do you have Busybox installed? I used the one by Stephen from Google Play + its smart installer mode, which creates symbolic links only for the missing binaries.

    Sent from TapaPlaudern on Mi2S
     
  11. AdrM

    AdrMMembers

    Jul 10, 2013
    51
    4
    18
    Male
    No, because I think that miui 's busybox is Ok.

    I have installed it and now everything working fine. Great

    Tnx MiKhan!
     

Share Our Site