Poco X5 5G moonstone wierd bootloop and problems with magisk install


Nov 14, 2023
Hi, can somebody explain something about a/b partitions?

I have a Poco X5 5g, flashed the xiaomi EU 14.0.5 ROM and TWRP, set it all up, rebooted back into TWRP and flashed the magisk zip.

After that, after a few reboots the phone will end up in a bootloop and will not boot even after flashing the stock boot img, xiaomi EU ROM zip, or anything.
I then flashed the EEA ROM zip and the phone booted back into xiaomi EU ROM somehow.

Obviously, I messed up something with the a/b partitions and the phone somehow recovered.

I flashed the EEA fastboot rom using the miflasher and now I'm back to stock basically.

Or so I think lol phone is booting into EEA ROM now
Can anybody explain to me what I did wrong, while in the loop of getting the EU ROM to work I even tried the whole erase all including the data, set the phone up and then flash the magisk patched boot.img back to the EU ROM.
Same thing happens, bootloop after a few reboots.

Basically, I have no idea how tf the a/b partitions work or what trips them.
While in the loop of getting the EU ROM to work I even tried to set "fastboot –set-active=_a" and back again to it to b partition.
In the B partition it wouldn't even attempt to boot, only would restart into fastboot mode.

Thanks anyone in advance for help
Did you read the installation instructions in the very first post of the ROM thread?