Redmi 6 - installing a working rom


Jun 30, 2017
13
1
15
#1
Has Anybody succeeded in installing a working ROM on the Redmi 6?
using the TWRP from TWRP builder i was able to install 8.8.9, but it doesnt boot up. It keeps stuck at the loading screen with the logo and three dots.

Installing official Global rom 9.6.4 did work, but i cant get a simcard to work. and i get an error saying “Android System there's an internal problem with your device.Contact your manufacturer for details."

I also installed Magisk and DisableForceEncryption_Treble.zip on several tries...
 
Jun 30, 2017
13
1
15
#3
Did you wait for the first boot after installing? I had to wait more or less 20 minutes for the first boot after install!
yes, I let it go on for hours....
what exactly did you do? what TWRP version did you use, did you install magisk? and DisableforceEncryption? did you format and wipe etc?
 
Oct 26, 2016
33
6
20
#4
yes, I let it go on for hours....
what exactly did you do? what TWRP version did you use, did you install magisk? and DisableforceEncryption? did you format and wipe etc?
TWRP version: 3.2.1.0

Disable force encryption: I really don't remember :(

I wiped and formatted everything, yes. Made a fresh install from scratch. Didnt restore any data. As I remember, the first boot ended in TWRP again. Switched off (preesed the power button 30 sec.), reboot / first start took about 20 minutes.

You can try MI GLOBE ROM (https://********.com). It is based on this weekly eu ROM, but they have a ROM - builder where you can enable / disable some options / apps (for example some MI-apps which I dont use). Even root / Magisc you can enable/disable. Worked for me. OK, there are the same bugs like here in the 8.8.9 / 8.8.16 (camera app, System UI, language, ...).