SIM card goes random off/not detected


psaldanha

Members
Aug 15, 2016
16
15
Hi!

I have a redmi note 3 pro with rom xiaomi.eu 8.4.19. Till a few days didnt had a single problem at all.

But, my idea, is that since last two updates, the sim card (in position sim 1 or sim 2 - i just use one card), the sim card goes random off and then is not detect after or sometimes is detected.

If i handle the phone a little harder or knock the phone, the sim card disconnects.

Other times it just disconnects by it self.

Do you guys think its a software related problem or its a physical problem?

The sim card was tested on other phones and is ok!
Problems happens on either sim card position.

Didnt read nothing related like this on the forum.

Do you have some solution?

Thanks!
 

Pertti Kosunen

Members
Sep 2, 2014
732
82
Try to put thin tape on the wrong side of card, maybe it holds it better in place. You could also clean the metal side with alcohol etc..
 

psaldanha

Members
Aug 15, 2016
16
15
Try to put thin tape on the wrong side of card, maybe it holds it better in place. You could also clean the metal side with alcohol etc..
Thanks for the idea!

Installed the ROM 8.4.26 and the problem persists.
Done some tests and it seems to be a physical problem.

Either way, on other posts, some say to overwrite the persist.img. Some problems related to sim card were fixed that way...
 

Igor Poljansek

Members
Nov 17, 2017
2
13
The same problem. Yesterday upgraded Mi4c from Android 5.1.1 to 7 with xiaomi.eu 9.5.2.0. Today I had 3 times sim in off state and need to reboot. This never happen before with previous version. So I assume it is related to SW. SIM card was not touched during upgrade.

UPDATE after one day of use:
I wrote this post too early. SIM problem occured 3 times in first 6 hours after upgrade. Maybe this could also come from network provider, who knows. It is running stable since more than 30 hours for now. I am very satisfied with new look, added functionality and UI response:)
 
Last edited:

psaldanha

Members
Aug 15, 2016
16
15
The same problem. Yesterday upgraded Mi4c from Android 5.1.1 to 7 with xiaomi.eu 9.5.2.0. Today I had 3 times sim in off state and need to reboot. This never happen before with previous version. So I assume it is related to SW. SIM card was not touched during upgrade.
Hi!

I can not say that is bug with certain. I too didnt touch the sim card. And after anexo update, this problem with sim card started.

So today i placed a bit of thin foil behind sim card. Will see if the problem persists.

Next options is to downgrade the rom.

Next option is fastboot persist.img.
 

Gunmoule

Members
May 10, 2016
11
15
Same problem here guys. Don't bother flashing persist.img, tried that with persist.img from Global Dev fastboot ROM, no luck.
Let us know if you had luck with your thin foil trick.

However, seeing it popping in every forums lately points to a software problem in latest builds... Or maybe it's hardware failure that is likely to happen after a few years of use... Hope not.
 

psaldanha

Members
Aug 15, 2016
16
15
Yes, i saw several posts about the same problem on other sections. I believe too its a software relate.

The problem is that, if i tap the phone, the sim goes off... I dont need to reboot. Just the pin.

I will try to fastboot a dev rom from a few months ago...
 

giovfrondella

Members
Dec 28, 2019
2
3
Hello. So how to fix this issue?
Do I need some update?
Thanks

Giovanni

Inviato dal mio Redmi 3S utilizzando Tapatalk