SMS/DATA Working fine - Calls don't


Ahamedos

Members
Mar 25, 2021
6
3
Dears,
I'm having an issue with my phone. Mi 10 Ultra. I got it second hand.

It's connected to the network 4g/5g tested.
SMS are working fine, so is Data.

reset all settings, and tried multiple roms versions also reverted back to original Chinese rom as well.
In all roms, phone calls were not working, can't receive or make calls.

I also checked with Service Provider, and they confirmed SIM Card is fine. the phone also supports all signal in my country (Saudi Arabia - Mobily)
I'm not sure what's the issue. please help~!
 

Mark F

Members
Aug 15, 2020
546
82
I have just replied to your XDA post but if you are now using an EU ROM, then please post reply here.
 

Ahamedos

Members
Mar 25, 2021
6
3
I have just replied to your XDA post but if you are now using an EU ROM, then please post reply here.

Thanks for your reply. I've spent days changing roms and posted my issue without more details.

I've tried Original stock rom, and latest weekly builds. and then back to the stable eu rom. MIUI by xiaomi.eu 12.1.1 Stable (RJJCNXM) (Screenshot attached)

when i try to make calls, it takes a while, and then throws an error msg "Mobile Network not available" (Screenshot attached)
when checking waiting calls configuration or calls forwarding settings it shows error msg "Network or SIM card error" (Screenshot attached)

I've tried changing APNs, reconfiguring them and different SIM providers. also tried the phone in other locations ,
still same issue


*#*#4636#*#* Phone Info (Screenshot attached)
SIM Status (Screenshot attached)


I suspected the cellular anteena having issues, but not sure of that and how to verify it.
I've run Cellular Z and noticed one thing different from other phones. (Screenshot attached)
in other Phones it shows ICCID (where it is SIM Number), but on this phone it dosen't show it.

So, my suspection is either the antenna, or reading the sim and obtaining the ISSID.


however for both issues, shouldn't it affect the network registration and SMS sending/receiving.
 

Attachments

  • 1616352850228.jpg
    1616352850228.jpg
    88.6 KB · Views: 60
  • 1616352850231.jpg
    1616352850231.jpg
    131 KB · Views: 60
  • 1616383102415.jpg
    1616383102415.jpg
    120.2 KB · Views: 60
  • 1616383102421.jpg
    1616383102421.jpg
    562.7 KB · Views: 61
  • 1616756915267.jpg
    1616756915267.jpg
    233.8 KB · Views: 61
  • 1616756915268.jpg
    1616756915268.jpg
    167 KB · Views: 60
  • 1616756915270.jpg
    1616756915270.jpg
    541.1 KB · Views: 59
  • 1616756915271.jpg
    1616756915271.jpg
    162.6 KB · Views: 57

Mark F

Members
Aug 15, 2020
546
82
Check inside the phone info page again, and select the network type. I'm not sure where you bought the phone from or where your SIM is from but I think you should not be using cdma, I'm sure that is for China and the tdscdma same. Look at both my Sims for here in the UK in the 2 screenshots. Might be a simple change here to the right settings may get you sorted.
 

Attachments

  • IMG_20210326_151240.jpg
    IMG_20210326_151240.jpg
    235.6 KB · Views: 55
  • IMG_20210326_151612.jpg
    IMG_20210326_151612.jpg
    250 KB · Views: 57

Ahamedos

Members
Mar 25, 2021
6
3
Check inside the phone info page again, and select the network type. I'm not sure where you bought the phone from or where your SIM is from but I think you should not be using cdma, I'm sure that is for China and the tdscdma same. Look at both my Sims for here in the UK in the 2 screenshots. Might be a simple change here to the right settings may get you sorted.

I've tried all of them before. with no luck.

I've set the preferred network to the one you have mentioned. signal is fine, DATA/SMS are fine.
but calls still not working. =
 

Mark F

Members
Aug 15, 2020
546
82
So it can't be your antenna, signal is there ok, it uses same for data and voice. Can you borrow another SIM and try it in yours and yours in theirs? At least it will prove your SIM is ok and working in another phone and if another works or not in yours.
As I am using both Sims and you are using one, I think that second SIM doesn't show on tours but you could swap it to SIM 2 slot and try.
Lets us know how you get on with a SIM slot swap and with another SIM if you can.
 

Ahamedos

Members
Mar 25, 2021
6
3
So it can't be your antenna, signal is there ok, it uses same for data and voice. Can you borrow another SIM and try it in yours and yours in theirs? At least it will prove your SIM is ok and working in another phone and if another works or not in yours.
As I am using both Sims and you are using one, I think that second SIM doesn't show on tours but you could swap it to SIM 2 slot and try.
Lets us know how you get on with a SIM slot swap and with another SIM if you can.

thanks for the reply.
I've tried another SIM from another company service provider, it was the same. total 3 SIMS I've tested.

also tried dual SIMs (2 at a time) and both were not able to make calls.

all 3 SIMs are working perfectly on other phones. i'm having the issue with this phone only.
 

Mark F

Members
Aug 15, 2020
546
82
I only have one other test and you may have done this anyway but have you tried a different network providers SIM. If that fails, then I'm afraid I'm out of ideas. May be take it to your network providers shop if they have one and see if they can help. It's a shame you can't find someone else near you who have a 10 ultra working or someone with your network providers SIM in an ultra.
Or contact the previous owner to try and get it returned if you have exhausted all options for a refund.
 

Ahamedos

Members
Mar 25, 2021
6
3
I only have one other test and you may have done this anyway but have you tried a different network providers SIM. If that fails, then I'm afraid I'm out of ideas. May be take it to your network providers shop if they have one and see if they can help. It's a shame you can't find someone else near you who have a 10 ultra working or someone with your network providers SIM in an ultra.
Or contact the previous owner to try and get it returned if you have exhausted all options for a refund.

I've already tried that, as well went to the service provider shop with no luck.

now, I'm going to try QCN . it seems able to backup/restore and fix NV related issues like baseband, IMEI, Network Detection. as per its description.
but that requires a rooted device. and when I try to root mine with Magik or supersu. it goes into boot loop issue.
 

Mark F

Members
Aug 15, 2020
546
82
Try going back to A10. Mine rooted ok then but had troubles with 11. May be do a search for A11 root issues with magisk?
 

marcel112

Members
Jun 2, 2011
524
67
I've already tried that, as well went to the service provider shop with no luck.

now, I'm going to try QCN . it seems able to backup/restore and fix NV related issues like baseband, IMEI, Network Detection. as per its description.
but that requires a rooted device. and when I try to root mine with Magik or supersu. it goes into boot loop issue.
depends on twrp. Once you flashed .eu rom, reboot back to twrp before booting to system, and flash magisk.
Bootlooping can also be solved by format data after flashing rom.
Hope this will help
 

Ahamedos

Members
Mar 25, 2021
6
3
thanks, I've flashed ver 10 android rom, and I'm able to root it.
I've gone through the QCN Tool. didn't know what to do with it. to fix this issue.

is it possible because of Modem or Baseband Firmware version ? is there something region specific?
 

Mark F

Members
Aug 15, 2020
546
82
Nothing region specific as these were only released in China, hence why some network bands are missing O2 4G in UK, band 20, so I can only use 3G on one sim but EE 4G in other SIM works fine on 4G. This can't be your problem as you have 4G 8n your screenshot and you have tried a different network providers SIM.
As far as I know, no one has managed to change anything in the modem on this phone yet, I follow the conversation on telegram. Any that have tried hard have only made thing worse than they were.
I think you need to contact who you bought it from, find out what SIM and network they were using. Of course, they may have been messing with the modem and corrupted it some how? At least they have a responsibility to sell you a working phone.
 

Delucid

Members
Apr 27, 2021
9
13
i am using mi 10 ultra in saudi arabia jubail region and not facing any such issue. Using zain n stc both. Only issue im facing after flashing eu rom 12.5 that 5g is no more working before on china rom 5g was working m blazing fast