(Solved) I think I bricked my Mi 10


IronIsh

Members
Nov 19, 2020
7
15
Hi all,

I have a problem with my Mi 10 and I think I bricked it, I'll try to make it short.

I was using the Weekly ROM 22.6.15 if I'm not mistaken, and my phone stared acting a little weird last Saturday, I was caught in a storm and I think a little bit of water might have gone into the USB port.

Anyways the phone stop charging for two days and was behaving weird, slow software and the fingerprint sensor wasn't reacting well, I turned it off used a hair dryer and cleaned the port with contact cleaner spray (the same you use for compurter parts) after that he phone started charging and I all seemed to be working right for a day and a half or so.

Then it came the new update which you have to install from TWRP again, when I rebooted and went to TWRP it just loaded to the screen logo and started blinking and never entered to the Menu, then I checked on internet, downloaded the new version for my phone and installed it, and the problems began.

After I flashed TWRP and send the reboot comand through ADB the phone got stuck on a fastboot loop.

To be honest I wasn't happy after the update to Android 12 and MIUI 13, my phone was a little buggy so I decided to install the official Global ROM and sell the phone and buy a native dual SIM one, since the main reason for me switching to Xiaomi EU was the dual SIM support.

THEN I MADE THE MOST STUPID MISTAKE OF MY LIFE!

I missclicked and downloaded the ROM for Apollo which I think is the Redmi K30 and installed it on my device (yes I'm stupid and bypassed the missmatching device and ROM error, don't ask that question please)

After that the phone start but only to fast boot or Mi Recovery, I can't install TWRP because fastboot doesn't detect the device but weirdly it does when is connected via MI recovery but shows Unauthorized next to the device number.

When I try to install the ROM for my phone it shows me the following error (Check the screenshot) I already tried the Global and the EEA. I also tried reinstalling ADB, drivers and all the stuff.

Any help ist most welcome even if it is telling me the honest truth that I'm an Idiot and I bricked it.

Thanks in advance!

miflash.JPG


device admin.JPG


ADB in fastboot
adb devices.JPG


ADB in recovery
adb recovery.JPG
IMG_20220702_124423.jpg
IMG_20220702_124459.jpg
 

Attachments

  • adb devices.JPG
    adb devices.JPG
    37.7 KB · Views: 35

stathis95194

Members
Sep 7, 2018
281
67
Hi all,

I have a problem with my Mi 10 and I think I bricked it, I'll try to make it short.

I was using the Weekly ROM 22.6.15 if I'm not mistaken, and my phone stared acting a little weird last Saturday, I was caught in a storm and I think a little bit of water might have gone into the USB port.

Anyways the phone stop charging for two days and was behaving weird, slow software and the fingerprint sensor wasn't reacting well, I turned it off used a hair dryer and cleaned the port with contact cleaner spray (the same you use for compurter parts) after that he phone started charging and I all seemed to be working right for a day and a half or so.

Then it came the new update which you have to install from TWRP again, when I rebooted and went to TWRP it just loaded to the screen logo and started blinking and never entered to the Menu, then I checked on internet, downloaded the new version for my phone and installed it, and the problems began.

After I flashed TWRP and send the reboot comand through ADB the phone got stuck on a fastboot loop.

To be honest I wasn't happy after the update to Android 12 and MIUI 13, my phone was a little buggy so I decided to install the official Global ROM and sell the phone and buy a native dual SIM one, since the main reason for me switching to Xiaomi EU was the dual SIM support.

THEN I MADE THE MOST STUPID MISTAKE OF MY LIFE!

I missclicked and downloaded the ROM for Apollo which I think is the Redmi K30 and installed it on my device (yes I'm stupid and bypassed the missmatching device and ROM error, don't ask that question please)

After that the phone start but only to fast boot or Mi Recovery, I can't install TWRP because fastboot doesn't detect the device but weirdly it does when is connected via MI recovery but shows Unauthorized next to the device number.

When I try to install the ROM for my phone it shows me the following error (Check the screenshot) I already tried the Global and the EEA. I also tried reinstalling ADB, drivers and all the stuff.

Any help ist most welcome even if it is telling me the honest truth that I'm an Idiot and I bricked it.

Thanks in advance!

View attachment 42907

View attachment 42908

ADB in fastboot
View attachment 42910

ADB in recovery
View attachment 42911View attachment 42912View attachment 42913
Did you try to install stock ROM with MiFlash Tool? I believe it does the proper partitioning before flashing.
Worth a try

Sent from my M2007J1SC using Tapatalk
 

Andreasgbr

Members
May 30, 2022
67
10
Hi,can you enter in fastboot menu?If yes,you need to run "fasboot devices" here you need to see ur device name.If your device nam will appear you can try to install twrp or install latest Xiaomi.eu Stable ROM which it's a fastboot one....
If you need some assistance,you can give me you discord or telegram:)
 
  • Like
Reactions: katerpanne

xMarvin732

Members
Aug 10, 2019
331
67
Hi all,

I have a problem with my Mi 10 and I think I bricked it, I'll try to make it short.

I was using the Weekly ROM 22.6.15 if I'm not mistaken, and my phone stared acting a little weird last Saturday, I was caught in a storm and I think a little bit of water might have gone into the USB port.

Anyways the phone stop charging for two days and was behaving weird, slow software and the fingerprint sensor wasn't reacting well, I turned it off used a hair dryer and cleaned the port with contact cleaner spray (the same you use for compurter parts) after that he phone started charging and I all seemed to be working right for a day and a half or so.

Then it came the new update which you have to install from TWRP again, when I rebooted and went to TWRP it just loaded to the screen logo and started blinking and never entered to the Menu, then I checked on internet, downloaded the new version for my phone and installed it, and the problems began.

After I flashed TWRP and send the reboot comand through ADB the phone got stuck on a fastboot loop.

To be honest I wasn't happy after the update to Android 12 and MIUI 13, my phone was a little buggy so I decided to install the official Global ROM and sell the phone and buy a native dual SIM one, since the main reason for me switching to Xiaomi EU was the dual SIM support.

THEN I MADE THE MOST STUPID MISTAKE OF MY LIFE!

I missclicked and downloaded the ROM for Apollo which I think is the Redmi K30 and installed it on my device (yes I'm stupid and bypassed the missmatching device and ROM error, don't ask that question please)

After that the phone start but only to fast boot or Mi Recovery, I can't install TWRP because fastboot doesn't detect the device but weirdly it does when is connected via MI recovery but shows Unauthorized next to the device number.

When I try to install the ROM for my phone it shows me the following error (Check the screenshot) I already tried the Global and the EEA. I also tried reinstalling ADB, drivers and all the stuff.

Any help ist most welcome even if it is telling me the honest truth that I'm an Idiot and I bricked it.

Thanks in advance!

View attachment 42907

View attachment 42908

ADB in fastboot
View attachment 42910

ADB in recovery
View attachment 42911View attachment 42912View attachment 42913
try using the newest mi flash tool

also looking at the first picture, it looks like the folder name is called "gauguin" which is for mi10t lite

if you have a mi10, get the umi rom
 
  • Like
Reactions: IronIsh

IronIsh

Members
Nov 19, 2020
7
15
Did you try to install stock ROM with MiFlash Tool? I believe it does the proper partitioning before flashing.
Worth a try

Sent from my M2007J1SC using Tapatalk
Hey Mister you're the man! I was able to flash the Stock ROM and then update it via OTA. Now it's working flawlessly and I'm selling a MI 10 in Germany ;)

Thank you very much for your help!

IMG_20220704_111905.jpg