Unable To Turn Off Spell Checker In Settings

Discussion in 'Bugs' started by sunbriel, Sep 26, 2015.

  1. sunbriel

    sunbrielMembers

    Sep 11, 2015
    24
    4
    13
    Female
    Croatia
    MIUI is missing an on/off switch in Spell Checker settings, which is supposed to be located in the upper right corner. So the only way to turn the checker off is via adb. Pretty inconvenient.

    [​IMG]

    Sent from my Redmi Note 2
     
    MareleVlad and Heydte like this.
  2. Creshaw

    CreshawMembers

    Jan 27, 2013
    16
    11
    13
    Male
    I have the same issue on my Mi2 :(

    I just found this workaround, I haven't tried it yet, but I believe it will work:
    - turn on developer options
    - turn on usb debugging
    - on your PC downlolad and install minimal adb and fastboot ( http://forum.xda-developers.com/showthread.php?t=2317790 )
    - connect your device via usb to your PC, wait 2 minutes until adb drivers have been installed
    - run the installed adb link in your start menu, a cmd window opens op
    - enter: adb shell
    - enter: settings put secure spell_checker_enabled 0
    - close cmd, disconnect phone, spell checking is disabled
     
    bkarpuz, Kedor, MareleVlad and 3 others like this.
  3. lubemark

    lubemarkMembers

    Oct 27, 2015
    13
    2
    13
    Male
    there's definitly an easy way : Keyboard and inputs metod, select google keyboard, then text correction

    then check " auto correction" and show correction suggesting" ;)
     
  4. Creshaw

    CreshawMembers

    Jan 27, 2013
    16
    11
    13
    Male
    The issue is that this apply only if you use Google keyboard. If you use any other keyboard (e.g. I use SlideIT), Google spell checker needs to be turned off via the setting mentioned below, however apparently in some ROMs this doesn't work.
     
  5. sunbriel

    sunbrielMembers

    Sep 11, 2015
    24
    4
    13
    Female
    Croatia
    You don't need PC for that, though. Just download Terminal Emulator from Play Store, open it, type su, grant root permission and type settings put secure spell_checker_enabled 0.
     
    Creshaw likes this.
  6. polve91

    polve91Members

    Feb 20, 2016
    113
    24
    28
    I'm reading now this thread. I'm searching the cleaner and lighter way to uninstall or disable the Google spell checker. Which is the best solution? Is it valid also through a terminal emulator or is it better as has said Creshaw into second post?
     
  7. Creshaw

    CreshawMembers

    Jan 27, 2013
    16
    11
    13
    Male
    Both ways are with the same result - they both will process the same command. Sunbriel's method is just more straightforward. If you don't plan to play access your phone via ADB more often, I'd suggest to just install the terminal emulator.
     
    polve91 likes this.
  8. Addamas

    AddamasMembers

    Jun 2, 2015
    281
    82
    50
    Male
    If you use other keyboard and will not be using Google Keyboard then you should go to All Apps and disable Google Keyboard.

    Short way:
    Press recent apps button / hold X and go to All (setting on the most left)


    Xiaomi Mi2S with sMIUI
     
    teo8028 and polve91 like this.
  9. polve91

    polve91Members

    Feb 20, 2016
    113
    24
    28
    Yes mate, it is working!
    Thank you guys
     
  10. luisfcvieira

    Mar 30, 2016
    1
    0
    11
    Male
    Hi, to disable do you need root? I am with the Global dev Miui8 and i cant disable it.

    Thanks for your help
     
  11. daanvanpoll

    Oct 29, 2016
    1
    0
    11
    Male
    Just wondering if anyone has tried this:

    Settings - Additional settings - Language & input:
    1. Set "Current Keyboard" to "Alfabet (QWERTY)"
    2. Set "Google-keyboard" to "Alfabet (QWERTY)"
    3. enjoy no more spellchecker-agony

    Works perfectly for me
     
  12. bruno1024

    bruno1024Members

    May 25, 2016
    2
    2
    13
    Male
    in google keyboard properties, under language select alfabet(qwerty). works for me. no more idiotic underlining.
     
  13. KcNirvana

    KcNirvanaMembers

    May 19, 2015
    453
    235
    67
    Male
    Newer xiaomi.eu roms have a toggle to deactivate that
     
    iamme729 likes this.
  14. Dang Khoa

    Dang KhoaMembers

    Mar 3, 2017
    1
    0
    1
    I am sorry for necroing this post, but I am having the same issue although having updated to MIUI 8.2.1.0. I have done what @Creshaw are instructing but I have "permission denial: writing to settings requires: android.permission.WRITE_SECURE_SETTINGS when I enter the second command. Please help! Thank you!
     
  15. jesuslg123

    jesuslg123Members

    Apr 11, 2016
    73
    23
    20
    #15jesuslg123,Apr 11, 2017
    Last edited: Apr 11, 2017
    I have been using this method for a long time, but now it does not work...

    FIXED: You need to setup your mi account and enabled the second debugger option on developer options. (stupid thing...)
     
    Kedor likes this.
  16. Heydte

    HeydteMembers

    Apr 21, 2017
    2
    0
    1
  17. Heydte

    HeydteMembers

    Apr 21, 2017
    2
    0
    1

    Thank you so much, it works like a charm. If it does work for you, try changing to another computer. I was failed a first few times but then I succeed in another laptop.
     
  18. bkarpuz

    bkarpuzMembers

    Jul 7, 2017
    1
    0
    1
    Male
    Thank you Creshaw, I just came to thank you for your very helpfull comment above!
     
  19. charisk123

    charisk123Members

    Jul 14, 2017
    1
    0
    3
    Male
    WORKS for me with minor adjustment: in SPELL CHECK I checked the system language (instead of having the English as before).
     
  20. Pertti Kosunen

    Sep 2, 2014
    585
    152
    82
    Male
    This switch depends on Android version, IIRC it is in Marshmallow and newer.
     
  21. Raphaelo

    RaphaeloMembers

    Oct 24, 2017
    1
    0
    1
    Male
    Hello everybody. My name is Raphaelo and I'm using Redmi Note 4, Android version 6.0 MRA58K.
    I'm having the same problem (unnecessary Google auto Correct) which I cannot eliminate.
    As I am using the AnySoftKeyboard, none of the above suggestions seem to work.
    Not being too much of a computer expert, could anyone please asdvise me as to simple procedure to cut off the Auto Correct?
    Thanks, Raphaelo.
     
  22. Romy4444

    Romy4444Members

    Oct 30, 2017
    1
    0
    1
    Male
    I have finally found the solution, please watch the video carefully and do exactly as shown, it's easy and I was surprised that the app that supposedly only creates shortcuts in this case add the ability to disable system apps on miui 8.
     

Share Our Site