Very Basic Question- Redmi 3s Prime Not Working Properly In London


Framm

Members
Feb 12, 2017
8
11
Hi everyone,

I'm sorry if this seems like a really basic question but I'm not familiar with the more techy side of android phones.

I bought a Redmi 3S Prime in India and brought it to London.

He put his local sim into it and it seemed to connect okay but then stopped connecting to the network. Wifi works fine.

It will connect periodically and receive all the outstanding sms messages and during this time it is even able to receive a call. Within a few seconds it will no longer be connected.

Is this a common problem? Is it something to do with needing the Europe ROM (I have no idea what that is, sorry!). Is it hardware related?

Thanks,

Framm
 

Hitardo

Members
Jun 21, 2014
203
52
Have you tried to:
- Clean Cache?
- Placing the SIM-card on the other SIM slot?
- Forcing Automatic / Manual selection of the ISP / Network?
 

MarkyO

Members
Oct 5, 2016
85
18
Try this:
1. Dial *#*#4636#*#*
2. Select Phone Information for the slot where your SIM is located
3. Scroll down to preferred network type and select LTE/GSM auto (PRL)
4. Enter settings, SIM cards & mobile networks, access point names. Tap Reset at the bottom. Delete every other APN except the newly created.
 
Last edited:

Framm

Members
Feb 12, 2017
8
11
Have you tried to:
- Clean Cache?
- Placing the SIM-card on the other SIM slot?
- Forcing Automatic / Manual selection of the ISP / Network?
Thanks! I tried this already but no joy. Also tried a different sim from a different provider, same issue.

Try this:
1. Dial *#*#4636#*#*
2. Select Phone Information for the slot where your SIM is located
3. Scroll down to preferred network type and select LTE/GSM auto (PRL)
4. Enter settings, SIM cards & mobile networks, access point names. Tap Reset at the bottom. Delete every other APN except the newly created.
Thanks for this advice. Did as you suggested but no change. Although it shows full signal strength, when I try to make a call it ends and says 'did not connect'. It then shows no signal. Signal may come back but won't receive texts etc. If it helps, the 'send / receive' logo (I hope that makes sense?) flashes as send but not as receive.

Right now it is showing no signal and 'emergency calls only'.

Any ideas? I can't solve this myself as I don't know enough BUT I am perfectly capable of following any instructions you give me to try out!


I appreciate the help
 

MarkyO

Members
Oct 5, 2016
85
18
You will have to unlock your bootloader.
Before that, you'll have to upgrade to the most recent official ROM. Download global stable ROM V8.1.1.0.MALMIDI (MIUI8) from http://en.miui.com/download-303.html to the root of your internal storage.
Run Updater, tap the three dots in the upper right corner and select "Choose update package". Select the downloaded file and tap "OK". If you get an error message, try developer ROM 7.2.24 (MIUI8). If neither of these work, you'll have to use fastboot method (download ROM from http://en.miui.com/forum.php?mod=viewthread&tid=418112 , instructions http://en.miui.com/forum.php?mod=viewthread&tid=327861 ).
If you're on an official ROM and the problem persists, you're able to apply for bootloader unlock permission at http://en.miui.com/unlock/.
After unlocking you're able to flash TWRP recovery. From TWRP you will be able to flash a new QCN file to your phone (look at http://en.miui.com/forum.php?mod=viewthread&tid=315019). This might fix your issue.
 
  • Like
Reactions: Framm

Framm

Members
Feb 12, 2017
8
11
You will have to unlock your bootloader.
Before that, you'll have to upgrade to the most recent official ROM. Download global stable ROM V8.1.1.0.MALMIDI (MIUI8) from http://en.miui.com/download-303.html to the root of your internal storage.
Run Updater, tap the three dots in the upper right corner and select "Choose update package". Select the downloaded file and tap "OK". If you get an error message, try developer ROM 7.2.24 (MIUI8). If neither of these work, you'll have to use fastboot method (download ROM from http://en.miui.com/forum.php?mod=viewthread&tid=418112 , instructions http://en.miui.com/forum.php?mod=viewthread&tid=327861 ).
If you're on an official ROM and the problem persists, you're able to apply for bootloader unlock permission at http://en.miui.com/unlock/.
After unlocking you're able to flash TWRP recovery. From TWRP you will be able to flash a new QCN file to your phone (look at http://en.miui.com/forum.php?mod=viewthread&tid=315019). This might fix your issue.
Many thanks for this information. I was out of the country and have returned and tried this.

I downloaded the most recent official ROM as you suggested and have installed it.

The problem is still there- it says that I am connected to T-Mobile but I can't actually make or receive any calls.

I tried to unlock- I received permission but when I run the tool on my computer, although it verifies fine, it gives me an error message:

"Current account is not bound to this device"

When I go to the phone and try to add the phone for unlocking, I get a message in Chinese (image below) that my Chinese friend translated to "Equipment / Coverage does not exist"



I have attached a video of the root issue


What do you suggest that I do? Am I doing something wrong?

Thanks so much for your help

Framm
 

MarkyO

Members
Oct 5, 2016
85
18
When did you receive the unlock permission? Some users had to wait up to ten days to be able to unlock.
Did you enter your Mi account detsils in Settings - Mi account? You'll have to use the same account as in the unlock tool.
 

gkent

Members
Mar 26, 2017
17
13
I tried to unlock- I received permission but when I run the tool on my computer, although it verifies fine, it gives me an error message:

"Current account is not bound to this device"

When I go to the phone and try to add the phone for unlocking, I get a message in Chinese (image below) that my Chinese friend translated to "Equipment / Coverage does not exist"
Most likely you did not wait long enough before trying to unlock your bootloader. Most people have to wait at least 5-7 days after receiving permission, before they can unlock their bootloader. Don't keep trying to unlock otherwise it would look like you are spamming. Just give it a rest then try again after waiting for the suggested period.
 

Framm

Members
Feb 12, 2017
8
11
Thanks for the advice. I received the sms saying that my request was approved only 12 hours ago- I assumed it would be instant so what you're suggesting makes a lot of sense.

The accounts on device and unlock tool are the same

Thanks so much for responses!
 

Framm

Members
Feb 12, 2017
8
11
An update:

I just unlocked the phone, re-booted and it showed

Emergency calls only

THEN it showed full signal

I tried calling my own number and it worked! It rang! Hurrah!

Short-lived however as now it is back to saying did not connect.

By the little bit of what I've read that I've understood, it seems that I need to flash some sort of EU file of some sort that will allow the phone to make calls in the UK? Have I got that right? Where would I find such a file and how does one go about flashing it?

Many thanks,

Framm