Where are the system (wifi) logs?

Discussion in 'Question & Answers' started by mblenton, Mar 26, 2012.

  1. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Hello,

    Recently I've noticed that wifi on my HTC Desire is acting very strangely - it connects just the first time after reboot, every other time I get "Error" message in Wifi settings. Where I can check what actually went wrong?

    After looking in the logs, I hope to have more information on this issue, but for now I believe it's hardware related, since the same problem appears even with the fresh install of the latest MIUI or after restoring a backup.

    Thanks.
     
  2. Pele

    PeleGuest

    You can use the MIUI Android Logcat http://miuiandroid.com/community/link-forums/logcat.82/

    Or you could try a fresh download install again : reboot into cwm, factory reset > wipe dalvik > clear cache partition install rom

    But try the logcat and also check you router etc and other things that may influence.

    Regards

    If you require more help speak to ibotpeaches as he is a HTC expert : join the miui irc chat :)
     
  3. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Hello Pele,

    Thanks for the reply.

    I've tried already clean install with wiping everything, even restored an old bkp which for sure is correct, but all without luck. I don't think it's a router thing, since the same problem appears regardless of my location (at home, at work... all the same). I'll join the miui irc chat, good idea, thanks!

    Regarding the logcat - the link you sent is just a form for pasting logs - am I seeing it correctly?. Is there some specific miui logcal app? I've installed 'aLogcat' which seems good, but I couldn't find anything on *wifi* or *wpa* which could indicate some sort of error in any of the logs aLogcat is displaying.

    Cheers,
    mblenton
     
  4. Pele

    PeleGuest

    Hi,

    Try to restore your back up without wifi settings. Failing that yes come to irc chat for about 12pm GMT+0 and chat with ibotpeaches

    Regards
     
  5. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Hello Pele,

    I've tried several combinations of rom/backup flashing, titanium backup restore etc. but the problem persists, even on a clean installation with just one accesspoint defined.
     
  6. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Update: I've updated to the newest radio, but the problems are still there.
     
  7. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,115
    335
    Kansas
  8. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Hello iBotPeaches, thanks for the link, I didn't realize Pele's refering to that logcat. I'll have to set up abd, though.

    In the mean time, I've tried the following (plus the actions described earlier):
    - Format system and boot partitions (since Wipe Data/Factory Reset doesn't do that) and clean latest miui install
    - Clean Cyanogenmod install

    Nothing's changed, I still can connect to wifi network the first time after power up, and then all I get is 'Error' msg. Interesting, but reboot doesn't actually help, just power off/power on.
     
  9. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Hello again,

    I've installed adb and used logcat to generate this file: http://ge.tt/9UkgUaF/v/0?c

    I'm not quite sure what would be interesting for debugging purposes, so I performed the following procedure:
    0. Wifi is enabled, but not working; power down the device; start adb logcat - waiting for device -
    1. Power on (wifi will be enabled and connected to SSID Hotspot)
    2. Open browser, open google (everything works)
    3. Close browser, turn off wifi (via status bar, but it doesn't make any difference)
    4. Open settings, try to turn on wifi
    5. Wifi couldn't be turned on, 'Error' message is displayed
    6. Power down the phone

    Thanks in advance!
     
  10. mblenton

    mblentonMembers

    Mar 1, 2011
    7
    0
    11
    Yet another update, not I'm pretty sure this issue is not miui related.

    I've installed Gingerbread RUU and performed the power-on/wifi-on--works/wifi-off--won't-start-anymore procedure with the same results. Here are the logs: http://ge.tt/9sOVXbF/v/0?c

    Where I should look for help?
     

Share Our Site