WiFi 2.4GHz issue with 10.2.1.0.OAHCNFK (stable) on Mi Mix


Dec 3, 2017
31
4
20
#1
Hi all
after upgrading my MiMix from 10.1.1 to 10.2.1 the Wifi only sees 5GHz WiFi networks, no longer 2.4GHz ones...
I've done an upgrade (dirty flash) over the perfectly working 10.1.1
Is it just my Mix, or a common problem?
thanks
 
Dec 2, 2017
649
175
82
#4
Xiaomi seems to have used different NON-HLOS.bin files in the weekly resp. stable roms.

That is the file in the firmware with all the cell radio and wifi hardware info, if I have understood correctly.

I have been trying to figure out which weekly they made the latest stable from, but things don't match up anywhere.
 
Dec 16, 2016
7
5
15
#5
I am on the latest update as well and I noticed that in my office wifi is on Channel Width 20 (2.4) and Channel Width 80 (5) and the mobile is not seeing the 2.4 GHz on HT20. Whereas the 2nd WiFi is on both Channel Width 40 and its showing so mean in the latest update Channel Width 20 is having issues.
 

Attachments

Likes: TakoMix
Dec 2, 2017
649
175
82
#6
You have channel 1 on 2.4GHz and channel 42 on 5Ghz I think. (4th picture)

The "width" 20Mhx - 80Mhz indicates the capacity.

You can use an app like "Wifi analyzer" (farproc) to check which channels your phone can "see".
 
Last edited:

Igor Eisberg

Patch/Mod Developer
Staff member
Oct 6, 2016
1,152
893
222
#7
If you live in the EU, you can try to manually edit build.prop and change ro.miui.wifi.region from GB to your country code. That might prevent you from using 5GHz hotspot (or might not), but other than that you should be able to see all supported channels in your country.
 
Dec 2, 2017
649
175
82
#8
The 5Ghz wifi is going to be basically unusable if everyone implements the new rules correctly, like Huawei seems to have done.
There is an article on MIUI forum about how 5GHz wifi has interfered with European weather radar.

My pocket router will spend a whole minute checking frequencies every time it thinks it has seen a weather radar signal, before it starts working again.
This is what every hotspot is supposed to do, apparently.

However, the 2.4Ghz wifi should work as before, as far as I have seen.
 
Likes: TakoMix
Dec 3, 2017
31
4
20
#9
Thanks everyone, problem solved!
My 2.4GHz band was forced to channel 13, and apparently the new stable ROM can't use ch. 13 (it was supported until the previous stable, 10.1.1)
As soon as I've set the access point to auto channel the Mix saw the 2.4GHz band again.