Xiaomi.eu Android 10 + Magisk 20.1 = fastboot stuck


KaKi87

Members
Nov 26, 2018
20
15
Hello,

I've just installed Xiaomi.eu Android 10 weekly build for dipper but it doesn't work with Magisk :

When I install Magisk, system won't boot and I get stuck on fastboot.

The recovery is still there though, and if I remove Magisk using the uninstaller, system will boot.

I absolutely need Magisk.

How do I fix this ?

Thanks !
 

Karpfenhai

Members
Jul 17, 2016
470
67
Hello,

I've just installed Xiaomi.eu Android 10 weekly build for dipper but it doesn't work with Magisk :

When I install Magisk, system won't boot and I get stuck on fastboot.

The recovery is still there though, and if I remove Magisk using the uninstaller, system will boot.

I absolutely need Magisk.

How do I fix this ?

Thanks !
Not a general issue but yours, remove all mods prior flashing magisk (Viber / substratum, eeg) then start fresh, magisk works fine.

Sent from my MI 8 Explorer Edition using Tapatalk
 

KaKi87

Members
Nov 26, 2018
20
15
I didn't flashed anything else than Xiaomi.eu and Magisk, in this order, and I made all wipes before.
 

mymihov

Members
Apr 7, 2019
5
13
I didn't flashed anything else than Xiaomi.eu and Magisk, in this order, and I made all wipes before.
Mi 8, the same problem. With Android 10 Magisk 19.3 and 20.1 ends in bootloops or "SU not installed". With Android 9 Magisk 20.1 not work, v19.3 do it.
What worked for me - after update to Android 10(the last OTA, ~10.12.2019), flash Magisk uninstaller then install Magisk 20.1 adding the 2 files to TWRP install queue.
 
Last edited: