Xiaomi Note 11S Can't enable NFC - Read Card test: failed


Feb 26, 2023
Hi, 2 weeks ago I bought a Redmi 11S. The first time I tried tp pay via google pay I couldn't pay and I thought it was the case. Today, I tried to open a website via NFC and it did nothing. So, firstly I run the CIT and it showed "there is no NFC compononet". Then I run an update (the global one via my phone, not a custom rom) and run the CIT again. Now it says cann't enable NFC - read card test: failed.

Apart from that, now and before the NFC icon have been apeared on the status bar on top right of the screen. Apart from that, the NFC icon isalways grey when I slide the bar down (even if I touche it and turn it into blue it turns automaticaly into grey) and I cannot also find it into the connectivity settings.

And of course Google pay crashes when I get into and tap the "turn on NFC".

Is it a software bug or it is probably a hardware malfunction? Before I buy the phone, I cheched the specs and NFC was supposed to be YES.