HyperOS 1.0 24.3.18


Status
Not open for further replies.
Xiaomi 12 cupid with TWRP. Not showing the taste on youtube when wireless dispaly is activated. No possibility to write anything
 
Hi, i have a problem and don`t know what to do.
My phone is Xiaomi 13 pro. I used it for a whole year with Android miui 14. I did the updates through TWRP. That's how I installed the first version of Hyper OS. However, now I can no longer install the new updates either through TWRP or Fastboot. TWRP doesn't read the data on the phone and I can't get to the folder where the update was downloaded. Fastoob says "waiting to device" and nothing else happens.
What should I do?
Thanks in advance to those who responded!
 
Hi, i have a problem and don`t know what to do.
My phone is Xiaomi 13 pro. I used it for a whole year with Android miui 14. I did the updates through TWRP. That's how I installed the first version of Hyper OS. However, now I can no longer install the new updates either through TWRP or Fastboot. TWRP doesn't read the data on the phone and I can't get to the folder where the update was downloaded. Fastoob says "waiting to device" and nothing else happens.
What should I do?
Thanks in advance to those who responded!
Update your TWRP version.
 
Is there a site where specifically says about the complete changelog about every china hyperos weekly update? Just for my information.. DM me if you like and have the time . Thanks a lot.
 
  • Like
Reactions: Devis234
already unlock and eu rom work great but if im trying to flash twrp or magisk i stuck on fastboot.
update.exe fixing the problem but how can i falsh twrp and magisk without beigng stuck on fb ?

* mi14 global

thanks.
 
Last edited:
you don't need to flash twrp, the rom already has twrp preinstalled
good to know and you right it is XD
so many years with miui im doing things like machine :)

and idea how to install the patched_boot.img
it making the phone stuck in fastboot

* done it via twrp and its working.
thanks for the help
 
Last edited:
Hello everybody!

Xiaomi 12S Pro owner here currently on with the 24.3.18 DEV build. As other people have already mentioned i also have issues with lock screen notifications.
Lock screen Notifications works fine for sometime and then randomlly the screen light-up but no text notification pops up but with no sound , sometimes it even doesn't light-up with no sound. Then after some time everything works fine.

I have tried to clear cache and data; stop/ restart apps; reinstall app... "Background Autostart" and "No restrictions battery saver" settings are enabled, Pause app activity if unused is disabled.
I also tinkered around with apps permissions, changed battery mode to "Performance Mode", turned off all battery saving settings, disabled face unlock, locked apps and set the clear cache when device is locked to "never" in boost speed settings, enabled unrestricted data. Lastly as i am rooted i even froze the "Battery and Performance" app but the issue still persists.

Issue persists since latest stable rom (xiaomi.eu_multi_UNICORN_OS1.0.3.0.ULECNXM_os1-14). This was the first rom i installed to the phone with clean installation. Then i dirty flashed 24.3.4 DEV and then dirty flashed 24.3.18 DEV which is the one i currently use. Problem exists to all 3 roms.

Has this issue been identified within the DEV team for a future fix?
Is there anybody that has managed to resolve this issue? Any help will be much appreciated.
 
Xiaomi 13 (fuxi) first flash did not work!
Now bootloop to Mi Logo

Edit: I ran the flash again, this time it went through.

Cable breakage would be a possibility, if I bend it extremely I briefly lose the connection. However, the device was lying on the table during the first flash without touching it.
 

Attachments

  • Zwischenablage_03-29-2024_03.jpg
    Zwischenablage_03-29-2024_03.jpg
    267.4 KB · Views: 80
Last edited:
Xiaomi 13 (fuxi) first flash did not work!
Now bootloop to Mi Logo
Could it be that the connection (cable) broke - 'no link'?
Have you tried pressing the Power + Vol+ keys (for Recovery);
or Power + Vol- for Fastboot.
You should be able to check the connection by entering the command from Fastboot: fastboot devices from the Command prompt. This should give you a code and 'fastboot'.
or adb devices from within Recovery. The result should be a code and 'recovery'.
Once you have a proper connection, you could try the Fastboot update again.
 
Setting dark mode for individual apps (forcing dark mode) doesn't work consistently, it would be nice to have this fixed.

Sometimes after a reboot apps don't launch with dark mode applied (even if the setting is on), and you need to reboot app and switch the dark mode switch on and off for it to finally assume dark mode when opening the app.

running xiaomi.eu on Xiaomi 14 (houji) btw
 
  • Like
Reactions: hewlett2008
@Pheinte What is written here?
 
  • Like
Reactions: KGVER and Iain_B
Edit: I ran the flash again, this time it went through.

Cable breakage would be a possibility, if I bend it extremely I briefly lose the connection. However, the device was lying on the table during the first flash without touching it.
Strange things happen! I'm glad that it was successful.

I use the original phone cable, which I am careful not to damage. I use this for everything - charging, file transfer, ROM updates, etc. I have not yet had any problems with it.
 
  • Like
Reactions: Mario1944
Status
Not open for further replies.

Similar threads

  • Locked
HyperOS 1.0 24.5.13
Replies
198
Views
39K
  • Locked
HyperOS 1.0 24.4.22
Replies
205
Views
68K
  • Locked
HyperOS 1.0 24.5.6/7
Replies
119
Views
34K
  • Locked
HyperOS 1.0 24.3.25
Replies
169
Views
71K
  • Locked
HyperOS 1.0 24.4.15/16
Replies
168
Views
44K