HyperOS 1.0 24.4.8/15


Status
Not open for further replies.
I offer you a tool with which you can install recovery without typing a command. Just click and burn the recovery to the device.
NOTE:Before starting the installation, replace the appropriate recovery file for your device with the recovery.img.
 
Last edited:
  • Like
Reactions: KGVER
I offer you a tool with which you can install recovery without typing a command. Just click and burn the recovery to the device.
NOTE:Before starting the installation, replace the appropriate recovery file for your device with the recovery.img.
The link was not working and has been updated
 
  • Like
Reactions: KGVER
Is there a way to turn off update notifications? It keeps popping up every 10 minutes and it's annoying, the reason I don't update is because I don't think the app crash and play login is fixed on mondrain after read some comments and I don't want to try install it first then dirty flash back to 24.3.11 cuz I did that several times already and the last time almost turn my phone into a brick
I have no issues on my Mondrian.
 
"Fixed the problem of poor signal and no service in some scenarios", according to Xiaomi.
Updated in Xiaomi 14 (Huoji).
I commented the line:
#$fastboot flash modemfirmware_ab images/modemfirmware.img
This way I don't need to take care of another flashing afterwards. I have signal and both cameras work.
BTW, something weird I've noticed, with this and with previous weeklies... When I first use the mobile, I did enable the SA switch in the SIM options (with a code #*xxx*# or similar). I have no network with that SA option enabled, but if I disable 5G SA, then I do get network. Of course I also have network if I force 4G. After some hours or days, I do eventually get network no matter which position the SA switch is set to when using 5G.
I'm using Orange Spain network, and to be honest, all this tests are at home, in the outskirts of a city (so I assume not the best 5G SA coverage, even if the city is in the list of cities with 5G SA), so not really sure what could be going on. All in all, minor issue as it seems to get solved on its own, but any info to understand what's going on would be appreciated. I'm interested in 5G SA because 5G NSA seems to use more battery than 4G, and 5G SA in theory should use even less than 4G (or that's what they brag about).
 
  • Like
Reactions: Catarsi
Optimized charging doesn’t work for Ishtar, which reading the forums I believe is well known. But someone said a month ago that “it isn’t supposed to work like it does on other brands” — what does this mean? It was probably a joke, but being relatively new to Xiaomi, I thought maybe I missed something.

Jokes on me regardless. Cheers.
 
Updated in Xiaomi 14 (Huoji).
I commented the line:

This way I don't need to take care of another flashing afterwards. I have signal and both cameras work.
BTW, something weird I've noticed, with this and with previous weeklies... When I first use the mobile, I did enable the SA switch in the SIM options (with a code #*xxx*# or similar). I have no network with that SA option enabled, but if I disable 5G SA, then I do get network. Of course I also have network if I force 4G. After some hours or days, I do eventually get network no matter which position the SA switch is set to when using 5G.
I'm using Orange Spain network, and to be honest, all this tests are at home, in the outskirts of a city (so I assume not the best 5G SA coverage, even if the city is in the list of cities with 5G SA), so not really sure what could be going on. All in all, minor issue as it seems to get solved on its own, but any info to understand what's going on would be appreciated. I'm interested in 5G SA because 5G NSA seems to use more battery than 4G, and 5G SA in theory should use even less than 4G (or that's what they brag about).
What do you exactly mean? Did you use the command: #$fastboot flash modemfirmware_ab images/modemfirmware.img after flashing the newest houji rom ?
 
What do you exactly mean? Did you use the command: #$fastboot flash modemfirmware_ab images/modemfirmware.img after flashing the newest houji rom ?
I think it is pretty clear in my message. I edited the script that does the flashing, which has a lot of lines flashing each "part", and told it to ignore that line (hence the # sign, which means "ignore this line", at least in Linux bash scripts, which is where I'm updating from, a Linux system). When you flash modemfirmware in European models (sorry, I meant global models), you have no signal and have to run the other file provided here. That files only reflashes modemfirmware with the right image, which is the one that was already on the phone. So if you comment that part in the rom script, you don't need to flash two files.
If you don't know what you're doing, just follow the original procedure and flash both files in the right order.
 
  • Like
Reactions: Eclipse1991
So again after updating to 24.4.15 I still haven't needed to flash the modem. Although I have been getting what looks like write errors every time I've been updating via double clicking the script. I thought it was normal but maybe not when I think about it?

It gets to a certain point and then the rest of the files are successful. I'll try running it in a separate window or adding a pause so I can get the full list of what actually succeeds/fails. Still looks weird to see so many files fail to write and have it work perfectly fine, but I fear that might change at some point?
 

Attachments

  • Screenshot 2024-04-17 110848.png
    Screenshot 2024-04-17 110848.png
    98 KB · Views: 90
Last edited:
Optimized charging doesn’t work for Ishtar, which reading the forums I believe is well known. But someone said a month ago that “it isn’t supposed to work like it does on other brands” — what does this mean? It was probably a joke, but being relatively new to Xiaomi, I thought maybe I missed something.

Jokes on me regardless. Cheers.
Optimized charging never worked for me on Ishtar.
 
  • Like
Reactions: spoonroom
I managed to run Shizuku with an external keyboard but it's just impossible to operate in the Pengeek app because there is no way to open it; the app is installed, it appears in settings, but it's not physically anywhere, and it cannot be interacted with from LSpatch, despite being active.
Screenshot_2024-04-17-15-59-07-029_org.lsposed.lspatch.jpg
Can someone please help?

If this is not the place to post about this issue, please erase and I humbly apologize for it. Kind regards.
 
Last edited:
anybody knows how to fix this font in the Vietnamese, the character : "o^" is wrong, right is "ô"
 

Attachments

  • 2024-04-18 3.18.58 PM.jpg
    2024-04-18 3.18.58 PM.jpg
    146.8 KB · Views: 47
Hello!

Xiaomi 13 pro (nuwa) is not stable in terms of mobile internet. While driving, the stream of all video or music platforms stops at short intervals! The amount of field strength is also constantly low!

It takes 10-15 seconds for it to start ringing!

What can I do to fix it?

Thanks!
 
Last edited:
Guys, does anyone have problems with the Intesa Sanpaolo Mastercard? I can't make phone top-up purchases or anything else. the bank operator blocked and unblocked my gold card to make it work and initially it worked, but after a day it didn't work again. I think it may depend on the ROM blocking my card but I'm not sure.
 
Will there be support for this weekly builds for Sapphiren ?
( Since we already have xiaomieu hyperos stable )

Thanks
 
If you have problems with Google on Xiaomi 14, just repeat the firmware procedure, it helped me. There are no more mistakes.
 
So far on my 11 ultra
Here is my full assesment
Battery seems okay , same with charging, I don't use my device without superwallpapers
So this is the very first time since Superwallpapers became a thing , that I am using a device without it
And this is because there a lot of delightful options in the wallet & personalization options
Charging is fast and in 67watts,
Battery drain seems slightly better , I have a whole lot of apps as this is my daily driver
The issue I have is with ram management, there are stutters and lags continuously ,.I felt maybe it was because I was setting up so many apps
So maybe I can give that a pass, but there is lags , stutters , somewhat better once you enable 120hrx refresh rate
I think there is an issue with the messages app, awfully hard to receive messages
Finally I wish there was an option to customise the dynamic island popup that shows when your charging
There are a lot of possibilities
So far , no bootloops and no unexpected shutdowns
 
Last edited by a moderator:
Hello and sorry if this is not the right place to ask the question, just today I reviewed the connection types that the device (Xiaomi 14 pro) comes with, I was surprised to see that 5G does not even appear. I saw problems with the connection on the forum, I don't know if they were referring to this or that it can't even be enabled.
 
Hello and sorry if this is not the right place to ask the question, just today I reviewed the connection types that the device (Xiaomi 14 pro) comes with, I was surprised to see that 5G does not even appear. I saw problems with the connection on the forum, I don't know if they were referring to this or that it can't even be enabled.
Check 5g bands for your phone on gsmarena and check band of your local operators
 
Status
Not open for further replies.

Similar threads

  • Locked
HyperOS 1.0 24.4.22
Replies
205
Views
68K
  • Locked
HyperOS 1.0 24.5.6/7
Replies
119
Views
34K
  • Locked
HyperOS 1.0 24.3.25
Replies
169
Views
71K
  • Locked
HyperOS 1.0 24.3.18
Replies
115
Views
46K
  • Locked
HyperOS 1.0 24.4.15/16
Replies
168
Views
44K