50% Fail On Bootloader Unlock... Now What? :(

Discussion in 'Xiaomi Redmi 3S / 3X' started by Raj M, Dec 27, 2016.

  1. Raj M

    Raj MMembers

    Aug 30, 2016
    21
    2
    15
    Male
    Hi everyone, I have previously unlocked boot loaders of x2 RN3P. I've ordered x2 R3S Prime. I've set up accounts for each new owner. Sought and received unlock permissions. Followed and read hundreds of pages of unlocking advice but both phones refuse to unlock. They are updated to latest global stable. Logging in with mobile. Find device OK. Latest mi flash unlock software. I'm tearing my hair out, trying for Week straight. Tried edl mode to go to China developer, can't access edl. I'm so close to giving up bit thought I'd ask here just in case. I just want to put EU ROM on :(

    Here's hoping.

    Raj
     
  2. DudeRM3

    DudeRM3Members

    Dec 27, 2016
    3
    0
    13
    For me, this video greatly helped. I don't think waiting 3-4 days is necessary, for me it worked right away.

    Search for this on Youtbe:

    How to Unlock Bootloader of Redmi Note 3! Detailed steps for all Xiaomi Phones! OFFICIAL METHOD

    Youtubers Name: Dhananjay Bhosale

    MUST STEPS!!!

    Download Global Developer ROM from- official miui website & flash it through Updater application on your Stable MIUI! If global developer ROM isn't available for your device then flash China Developer!

    Flash Global developer ROM & sign in to the ROM , wait for 3-4 days & then try again!

    EXTRA STEPS-
    Download & install this-
    1- link in youtube description
    2-link in youtube description
    Now Enable USB debugging from developer options & then on command wondow type ADB devices !! Allow USB debugging permission on phone & the follow the steps on the video & everything should work :)
    -------------------------------------------------------
    If the method is stuck at 50% then DISABLE ALL SECURITY LOCK SCREEN FEATURES INCLUDING PIN PASSWORD FINGERPRINT & TRY !

    Also, make sure you log into your MI-Account with the same login name as in the Unlocktool. When you used email in phone, use email in unlocktool, when you used MI-Account number as login, use MI-Account number in tool.

    Hopefully it helps.
     
  3. JimPanse

    JimPanseMembers

    Sep 30, 2016
    10
    2
    13
    Male
    You have to flash a dev Rom first.

    Then according to the official unlocking thread (http://en.miui.com/thread-202290-1-1.html) especially this part solved the 50% problem for me:

    Kedacom USB device problem (new)

    For those who received permission to unlock but still stuck, please check out this section. You might be facing problem due to kedacom USB problem especially for those who are using Windows 10 which causes your PC fail to detect device in fastboot mode. Download Mi Flash Here.


    1. Boot into fastboot mode (Hold Volume Down+Power), a Mi bunny image will be shown. Plug your device into the computer.

    2. Open Device Manager and search for Kedacom USB Device, double click on Android Bootloader Interface, then click Uninstall, tick Delete Driver Software for this device then OK

    3. Unplug and reconnect your phone (phone state is still in fastboot mode)

    In this stage, you will see that driver is reinstalling and show Android Device as Android Bootloader Interface, once the driver finished updating it will revert back to Kedacom. The Kedacom driver won't allow you to unlock or perform any kind of fastboot commands. To solve this,


    4. Double click on Android Bootloader Interface again under Kedacom again

    5. Under 'Driver' tab, click Roll Back Driver, press OK

    Since the driver is all right now, head towards Mi Unlock Tool and you should be able to unlock without problem now.


    I hope this helps.

    Cheers
     
    goth06 likes this.
  4. Raj M

    Raj MMembers

    Aug 30, 2016
    21
    2
    15
    Male
    Thanks guys for your quick response!
    I tried all of the above and tried through the updated app to move to a developer ROM but it failed repeatedly - this morning when I pulled down the global developer ROM it seems to have installed - so maybe I am getting somewhere - it is all so random :(
    Will keep you posted and I appreciate the assistance. I really have tried everything, watched every video, read every instruction but still no go - I only asked when I was at the end of all of the options (I even write a bug report to Xiaomi).
    I had tried all of the recommendations above, but even the transition to developer had failed. Hopefully it will unlock on global developer ROM.
    Then there is bliss :)
    Raj
     
  5. Raj M

    Raj MMembers

    Aug 30, 2016
    21
    2
    15
    Male
    OK guys, it was the issue of the ROM.
    Once the phone was able to be updated to latest developer ROM, it passed.
    Note to all - if yours fails at 50% make sure you put developer ROM on.
    I had tried this first up but the phone wouldn't take that ROM, perhaps a bad download - anyway, thank so much for your assistance.
    Cheers,
    Raj
     
    DudeRM3 likes this.
  6. Raj M

    Raj MMembers

    Aug 30, 2016
    21
    2
    15
    Male
    Hi all,

    Some further reflections and comments on the process - I have had these issues on both the Redmi 3S phones so it is certainly consistent in my experience.
    You must be on a developer ROM - I found that I had to update the phone to the latest stable (global) ROM before the updater app accepted the update to the latest developer ROM.
    When you install TWRP - please make sure you follow/input the next command in the sequence, namely fastboot boot twrp.img - without doing this I could not get into TWRP.
    The next strange hurdle is that flashing the EU ROM caused a bootloop - it would install; start to load then when appeared to be finished, revert to installing again (the bar across the bottom of the screen filling), then loading (MI with three dots) and so on.
    I believe the solution (in my experience) is that you ought to reboot to TWRP at least once to ensure it is installed (it is said that the default recovery can be installed if you do not).
    I've done this (by powering down when the system is loading (3 dots) and forcing TWRP to boot through fastboot) and wiped the cache. Then upon reboot, it has continued to finish the install.
    So in conclusion - it certainly can be done - unlocking the BL is a confusing bit, especially as there are many sites saying that the ROM you are currently on is irrelevant - this has not been my experience - you must be on the latest developer ROM, using the latest MiFlaskUnlock tool.
    Then follow the TWRP instructions exactly.
    Then when flashed, well for me anyway, force it back into TWRP, wipe the dav/cache and it should install.
    Goodluck!
    Raj
     

Share Our Site