Android Pay On 7.2.13 Not Working


Android pay is not working, will this be fixed?

  • yes

    Votes: 2 66.7%
  • no

    Votes: 1 33.3%

  • Total voters
    3
May 12, 2016
4
0
13
#1
Hi,

I am using the latest Xiaomi.eu Multilang/Global ROM 7.2.13 and so far really pleased with it!

Today, Android Pay has just been launched in the UK. Installed the app but when I tried to add a new card I am presented with

"Android pay can't be used - Google is unable to verify that your device or the software running on it is Android Compatible"

Is this something that can be fixed? Would be great if the Mi5 can use this feature considering it has fingerprint and NFC.
 
Apr 1, 2016
249
28
52
#3
Yes if u have rooted yor device or you have unlocked bootloader it wont work. Not sure about bootloader but sure about rooted device
 
May 12, 2016
4
0
13
#4
Yes if u have rooted yor device or you have unlocked bootloader it wont work. Not sure about bootloader but sure about rooted device
I have not rooted as I don't have any need to, but the bootloader is unlocked to put the EU multilang ROM on. Didnt think that would be a problem. My oneplus one has an unlocked and works fine with Android Pay.
 
May 12, 2016
4
0
13
#5
Just installed "SafetyNet helper" and ran a check. It seems that it fails on the Compatibility Testing Suite (CTS) profile test.

Seems this might be down to not being able to verify the ROM against the device.

I hope there is a way around this, would be great to get this functionality working on the Mi5. :)
 
May 12, 2016
4
0
13
#7
yes but you have unlocked bootloader so u cant use anymore android pay. u can relock it i think
just tried using fastboot to relock my Mi5 and it totally screwed the boot. Looks like it went into some type of boot loop, just flashes the Mi logo for a second then goes blank again.

Fortunately the unlock process using the mi unlock tool still works so managed to get the phone unlocked and booting again.

Is there any way to re-lock the phone with the xiaomi.eu multilang ROM? Is this a limitation of having TWRP on there?

I am currently running the phone with encryption so not sure if that is messing with it?