Bricked Redmi 2 2014813

Discussion in 'Xiaomi Redmi 2 4G/LTE' started by chapdis, Nov 27, 2016.

  1. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Hello,

    I've been trying different method to get my redmi2 back....no chance

    twrp method
    deep flash cable
    test point... etc

    BUT i am able to boot twrp, only when i flashtwrp.bat using my laptop
    after if I try installing rom or recover, it says Failed to mount '/ cache '/system '/data '/ persist (Invalid Argumen)

    Is there any way to remount partition using adb command or command shell in the twrp interface of the phone
     

    Attached Files:

  2. severica25

    severica25Members

    May 31, 2016
    611
    310
    102
    Male
    Try to flash latest twrp for wt86047 then in twrp wipe internal partition/factory reset device.

    If doesn't help then you could try to flash official rom by Miflash through fastboot EDL mode. Then after flash again twrp.

    Sent from my 2014813 using Tapatalk
     
  3. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Thanks. Can you give some directions how to do it? Flash through EDL,?
     
  4. severica25

    severica25Members

    May 31, 2016
    611
    310
    102
    Male
    Check eu rom section, look for twrp link, download twrp for wt86047 lolipop version. On same thread you havve command for flashing through adb with pc.
    For Miflash flashing official roms you'll need to check official forum or check this link but be very sure that you have hm 2014813 aka wt86047 device before. https://xiaomi.eu/community/index.php?threads/36138/

    Sent from my 2014813 using Tapatalk
     
  5. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    attached are the prt screen and screen shot of the devices
     

    Attached Files:

  6. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    another try with this zip Untitled2.pngUntitled2.png

    same thing but says on the adb console (phone) it's a 88047 image and you have HM20148013
     
  7. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    #7chapdis,Nov 27, 2016
    Last edited: Nov 27, 2016
    another try.....

    same

    question : not sure about the phone ID, attached is the pic of the actual redmi
     

    Attached Files:

  8. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    anyone would like to receive the phone for undbricking operation ?
     
  9. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Still stuck with my problem, Help me If You can !
     
  10. stonemax

    stonemaxMembers

    Dec 6, 2016
    1
    0
    11
    Male
    Hi,

    I share the same problem with the same devicetype. I tried different roms with TWRP 3.0.2 and Miflash in the lastest version with recommended roms. But with TWRP I also get the notification that TWRP is unable to mount system/data and cache (invalid argument).

    Does anybody have a solution for this probem?

    Thanks in advance.
     
  11. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    I gave up as I followed many tutorials without success. I am looking for somebody to fix it and send the device to.
     
  12. Bzidroglio

    BzidroglioMembers

    Oct 9, 2016
    17
    8
    13
    Male
    Hi.
    Where are you from? There maybe some forum user near you and can help.

    Enviado do meu Nexus 7 através de Tapatalk
     
  13. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    I am in France and can post locally or within Europe. If someone feels like he can do it....
     
  14. remcie

    remcieMembers

    Jan 22, 2017
    1
    1
    15
    Male
    So apparently there is no solution for this issue right?
    I also have the exact error, I have searched the internet for hours and followed at least 10 different guides/tutorials but none solved the issue. It seems I'll need to give up and buy a new phone.... :(
     
    chapdis likes this.
  15. Jan54

    Jan54Members

    Jan 22, 2017
    5
    0
    11
    Male
    Hi chapdis,
    Ik have many times flashed my phone by fastboot. Maybe i can help you. I am from Holland
     
  16. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Unfortunately I gave up. I managed to buy locally the same phone (water damnaged) for €20 changed the board from, reinstall eu. Xiaomi rom and I am happy man now. Anyway I am sure this issue can be resolved with good experience in programming and patience (which I don't have)
     
  17. chapdis

    chapdisMembers

    Aug 24, 2016
    19
    1
    15
    Thanks... See my reply in the post. Very much appreciated your support though.
     
  18. maurix

    maurixMembers

    Jul 20, 2015
    1
    0
    11
    Male
    Same problem here.
    It possible is hardware problem? i think it's strange becasue i read many similar case around. So if it's soft problem, really we can't fix this?!?!
     
  19. eddie_2k

    eddie_2kMembers

    Dec 11, 2016
    9
    2
    13
    According to english miui.com forum, Xiaomi is replacing defective devices, but only in china. It really looks like a "software" issue (I tried to write files into the storage using the shell and it works), but maybe is so low level issue that nobody have found how to fix it.

    Have a look there, any update is welcome.

    P.S.: it might be a good idea to write a post and pin it, advising people to get back to.... MIUI7? I am unsure about that, but it seems to be risky to stay at MIUI8. I don't know as well if the only affected device is 2014813 under MIUI.8.2/5.1. Maybe if you guys tell which version are were running we could clarify that.
     
  20. lingazu

    lingazuMembers

    Jan 4, 2016
    1
    0
    13
    Male
    Here ... same problem!
    @eddie_2k ...you "write files into the storage " and works ?
    I tried change recovery and not work...
    Thanks
     
  21. eddie_2k

    eddie_2kMembers

    Dec 11, 2016
    9
    2
    13
    I could create/change/delete files using the shell (connected via fastboot), but failed when recreating the partitions. I got any progress and had to find a new one.
     
    lingazu likes this.
  22. Adrian53

    Adrian53Members

    May 3, 2017
    8
    2
    3
    Hey guys,

    Today my phone was acting super weird so I restarted it. Now is stuck in the MI logo loading screen. I managed to boot TWRP and got the same errors like you when trying to flash the same ROM again (xiaomi.eu_multi_HM2XTDPro_V8.2.1.0.LHJCNDL_v8-5.1).

    Any ideas how to fix it?

    PS: i attached a pic with the errors
     

    Attached Files:

  23. eddie_2k

    eddie_2kMembers

    Dec 11, 2016
    9
    2
    13
    I haven't heard about anyone fixing it for sure (here or in any other forum). I tried many things by myself (and a friend of mine as well), and never got it back to life. AFAIK, xiaomi is replacing them in China, but apparently there's nothing to do. I simply got a new one, too much time waste on that.
     
  24. Adrian53

    Adrian53Members

    May 3, 2017
    8
    2
    3
    So far I did all the fastboot commands by hand and I find out 2 commands give errors: flashing partition gpt_both0.bin and sec sec.dat

    The rest...flash system,boot,etc.....all give OKAY and after reboot, TWRP still says there's no OS installed.

    Such a pitty no one figure it out how to fix this.

    I do have back-ups made with TWRP but on Kitkat...and now i can't restore it....do you know how I can restore those back-ups? previous version of TWRP I can't use to boot, it give an error dtb not found
     
  25. eddie_2k

    eddie_2kMembers

    Dec 11, 2016
    9
    2
    13
    I already tried that, no luck as well. Don't waste your time :D