[BUG 1.7.1] Samsung Captivate

Discussion in 'Bugs' started by askpcguy, Jul 8, 2011.

  1. askpcguy

    askpcguyMembers

    May 19, 2011
    15
    0
    11
    Reposting from [1.6.17]:
    When headphones with a mic are plugged in and a notification sound is played, the music player will begin to play a song. Also happens with 3rd party music player apps.

    This does not happen when normal headphones are used.

    Tried clearing data for Miui Music app, tried to re-apply the notification and ringtone sounds but the problem still exists. Also happens when using a custom kernel.

    Sent from my I897 using the miuiandroid.com forum app

    Additionally, I cannot get the Android SDK's debugger (DDMS.bat) to work, it says /dev/log/main not found. I saw a post on XDA which indicates /system/lib/liblog.so is missing, I checked and had the file on my device. Any ideas?
     
  2. askpcguy

    askpcguyMembers

    May 19, 2011
    15
    0
    11
    Looks like nobody cares. I cannot ignore this problem.

    Here is a pastebin logcat. First in the log, I plug in normal headphones with no mic and play a notification sound. No problem. Next I plug in my headset (with mic) and play a sound, the music player began to play a song.

    http://pastebin.com/iGw9qucR
     
  3. askpcguy

    askpcguyMembers

    May 19, 2011
    15
    0
    11
    Still a problem on 1.7.15 but nobody seems to care.

    In fact, with a wired headset plugged in, the system sends a PLAY/PAUSE command to the music player.

    That is, if a song is playing, then a notification sound is played; the song pauses.
     

Share Our Site