Call dropping or caller does not hear me anymore


steve1712

Members
Dec 5, 2010
53
20
Hey there, since a few weeks i've huge issues with my mix2s... when driving home from work i call a lot with the same person for 30min and since a few weeks having a call is nearly inpossible…

the caller doesn't hear me anymore after a few minutes, then the call drops… in the beginning rebooting the phone did helped.. in the last few days even directly after rebooting the same issues starts to happen...

what i does see is that the signal bar sometimes drops, i guess the phone roams from one cell tower to another and this looks like to be the issue where the calls starts to getting trouble...

i tried different sim cards allready... also i tried a different phone with the sims where i didn't have the issues, also tried using it without Bluetooth (whats normall inside my car is the case) but still the same issues when using freespeak
i've tried to completely reset the phone and start from scratch..
normally i where on the weekly Xiaomi.eu ROM i did flashed also back to the 10.2 Stable Release for mix2s allready, still the same issue!

also also once tried to use WhatsApp to call, but also there i had a call drop as the dataconnection looks like is loosing to the signal, of course when even the normal call looses connectivity...

any hints what i can try? is the reception part somewhat faulty? but when not in motion with the phone it looks like a can have a stable phone call.. i don't know what to do anymore :(
 

Maidu Uusen

Members
May 12, 2016
82
30
Hi, i have exactly the same problem. Last 4-5 roms are somehow faulty to the call quality. Did you found the solution for this problem?
 

steve1712

Members
Dec 5, 2010
53
20
i did not...
read a few things, that it could propably be from an case thats blocking one of the mics...
also dust or dirt inside the mic holes… i tried cleaning.. what i found is that on the top mic i can go deep in.. on the bottom mic i can enter the phone white some way in.. i thing the bottom mic is faulty… broken of or something


what i found is a way to disable the mic array in the build.prop with some settings but didn't tested this right now... as i only have the issues when driving and using the BT Connection from the car.. but i ruled out everything else.. tried different SIM Cards, also with another phone i do not have any issues in my car… so basically its with the mix2S...

i'm search the parameters now and try that, else i don't know what todo… propably open the phone and check the bottom mic?
 

Maidu Uusen

Members
May 12, 2016
82
30
I had call quality problems all the time and it seems, those instructions are helping me:

/system/build.prop replace those two line :

ro.qc.sdk.audio.fluencetype=none
persist.audio.fluence.voicecall=true

With this:

ro.qc.sdk.audio.fluencetype=fluence
persist.audio.fluence.mode=endfire
persist.audio.handset.mic=digital
persist.audio.voicecall.mic=0
persist.audio.voice.clarity=none
persist.audio.aanc.enable=false
persist.audio.handset_rx_type=DEFAULT
persist.audio.nsenabled=ON
persist.speaker.prot.enable=false
persist.audio.spkcall_2mic=OFF

I have to test it more, but call quality is much better now, there are no echoes and no lost words or speech stuttering anymore.
Maybe xiaomi.eu developers can explain, what all the lines are doing, maybe they can use something from there to put it in the ROM, so we don't need to replace build.prop file every week with new weekly ROM.
 
  • Like
Reactions: Solmer

cobben

Members
Dec 2, 2017
840
82
. . . as i only have the issues when driving and using the BT Connection from the car..
This might not be the same in Mix2s, but have you checked in:
Settings/Bluetooth/Paired devices
for the BT connection with the car, if you have "Phone audio" enabled?
 

steve1712

Members
Dec 5, 2010
53
20
My latest guess is that the board with the mic and charging port is faulty... I red this issue on other Xiaomi phones too...

And It would explain a couple of other issues .. like that headphones with ah usb-c to 3,5mm headphone jack does only work one way around. Also charging yesterday didn't worked after flipping the charging cable it started charging...

Gesendet von meinem MIX 2S mit Tapatalk
 

steve1712

Members
Dec 5, 2010
53
20
I had call quality problems all the time and it seems, those instructions are helping me:

/system/build.prop replace those two line :

ro.qc.sdk.audio.fluencetype=none
persist.audio.fluence.voicecall=true

With this:

ro.qc.sdk.audio.fluencetype=fluence
persist.audio.fluence.mode=endfire
persist.audio.handset.mic=digital
persist.audio.voicecall.mic=0
persist.audio.voice.clarity=none
persist.audio.aanc.enable=false
persist.audio.handset_rx_type=DEFAULT
persist.audio.nsenabled=ON
persist.speaker.prot.enable=false
persist.audio.spkcall_2mic=OFF

I have to test it more, but call quality is much better now, there are no echoes and no lost words or speech stuttering anymore.
Maybe xiaomi.eu developers can explain, what all the lines are doing, maybe they can use something from there to put it in the ROM, so we don't need to replace build.prop file every week with new weekly ROM.
How to edit build prop?! All tools tell me that the changes couldn't be saved...

Rootet with magisk 18.1, tested.with mixexplorer and buildpropnapp
 

steve1712

Members
Dec 5, 2010
53
20
Ok, chmod the build prop file in TWRP...

Anyway I think I don't have mic issues... It looks like I loose signal all the time...

Would also the explanation why the call drops! The callpartner See's an call aborted message...

But I've tested with different SIM cards.. also tried between sim 1 and sim 2 no.. doesnt matter... So probably the antenna has some issues on the phone or I don't know what to do now..

Gesendet von meinem MIX 2S mit Tapatalk
 

Phurya

Members
Dec 19, 2016
18
15
I have the same problem, it's not about the audio, it's about the cell signal... It helps if you choose on Preferred network LTE/CDWDMA. I live in Portugal, in a zone where the 4g and 3g signal is not that strong, and the phone tends to go GSM mode on calls, and as far as I could understand, this phone does not handle GSM cell much good. Since I have choosed only the two mentioned above, I stopped having call dropping and bad signal. Hope it helps
 

steve1712

Members
Dec 5, 2010
53
20
I have the same problem, it's not about the audio, it's about the cell signal... It helps if you choose on Preferred network LTE/CDWDMA. I live in Portugal, in a zone where the 4g and 3g signal is not that strong, and the phone tends to go GSM mode on calls, and as far as I could understand, this phone does not handle GSM cell much good. Since I have choosed only the two mentioned above, I stopped having call dropping and bad signal. Hope it helps
i noticed this also yesterday.... had a few calls where the caller didn't heard me... if tested it than with ah 2nd phone calling me, to hear that by my self... then i changed to 2G tested again, then there where no issues.. than switched back to 4g... and also no issues...

so it looks like the phone handels switchen between cell towers somehow not very well...

i also change back to offical global rom with a fastboot flash... so fully get rid of .eu rom and unlock etc.. bit still the same issues :( interesstingly this started months ago, but hadn't any issues before, propably i'm gonna sell it and grab an galaxy s10 or huawei p30 pro instead, i'm pretty done with xiaomi phones right now as the support from xiaomi just lacks of anything ...
 

cobben

Members
Dec 2, 2017
840
82
... Well, and now what? Any idea how to fix it?
1. Try changing operators.

Or wait a few months to see if the operator fixes the problem for you.

Some operators don't seem to know what they are doing - I had a somewhat similar problem a year or two ago in Latvia, it disappeared after 3-4 months without me doing anything.

2. Try changing phones.
 

Phurya

Members
Dec 19, 2016
18
15
This is non related to any operator, and if you buy me a new phone, I'll accept it, because I have spent my money buying this one 3 months ago.
 

steve1712

Members
Dec 5, 2010
53
20
I've switched to Huawei p30 pro right now....

But propaply someone can test just flashing the radio firmware from Chinese stable rom?

Or even try flashing radio rom from release before 10.2.1.0 something where the Sar limit were implemented!?



Gesendet von meinem VOG-L29 mit Tapatalk
 
Last edited:

steve1712

Members
Dec 5, 2010
53
20
i'm on miui global Stable 10.3.2.0 right now... got baseband-Version: AT4.0.c2.6-197-1106_1939_4304554

tried flashing modem.img from 10.0.7.0 xiaomi.eu rom, but looks like baseband version does not change at all..even when opening the modem.img there is a folder called verinfo and ver_info.txt... i checked the "modem" part in different modem.img files.. they all have the same version number in these txt files... and they differ from whats installed on the device?!.

{
"Image_Build_IDs": {
"adsp": "ADSP.HT.4.1-00088-SDM845-1",
"aop": "AOP.HO.1.0-00137-SDM845AAAAANAZO-1",
"apps": "LA.UM.7.3.r1-04500-sdm845.0-1",
"boot": "BOOT.XF.2.0-00364-SDM845LZB-1",
"btfm": "BTFM.CHE.2.1.4-00364-QCACHROMZ-1",
"cdsp": "CDSP.HT.1.1-00068-SDM845-1",
"common": "SDM845.LA.2.0-00096-STD.PROD-1",
"glue": "GLUE.SDM845_LA.1.0-00297-NOOP_TEST-1",
"modem": "MPSS.AT.4.0.c2.6-00144-SDM845_GEN_PACK-1",
"slpi": "SLPI.HY.1.0-00311-SDM845AZL-1",
"slpi_br": "SLPI.HY.1.2-00060-SDM845AZL-1",
"slpi_dp": "SLPI.HY.1.0-00311-SDM845AZL-1",
"slpi_ps": "SLPI.HY.1.2-00026-SDM845AZL-1",
"slpi_us": "SLPI.HY.1.0-00311-SDM845AZL-1",
"tz": "TZ.XF.5.0.1.c5-00017-S845AAAAANAZT-1",
"video": "VIDEO.VE.5.2-00024-PROD-1",
"wapi": "WLAN_ADDON.HL.1.0-00030-CNSS_RMZ_WAPI-1",
"wdsp": "WDSP.9340.1.0-00277-W9340AAAAAAAZQ-1",
"wgig": "WIGIG.SPR.5.3-00025-WIGIGSWZ-1",
"wlan": "WLAN.HL.2.0.c3-00043-QCAHLSWMTPLZ-1"
},
"Metabuild_Info": {
"Meta_Build_ID": "SDM845.LA.2.0-00096-STD.PROD-1",
"Product_Flavor": "asic",
"Time_Stamp": "2018-11-06 20:29:03"
},
"Version": "1.0"
}
 
Last edited:

steve1712

Members
Dec 5, 2010
53
20
i flashed modem.img from chinese rom now.. and i got a differen baseband-version displayed in phone... same informations in the txt file.. so looks like that is not reliable nor helpfull (the txt ver_info.txt file..)

i gonna test this baseband ...
 

Solmer

Members
Mar 24, 2019
15
3
Hi there! The echo is driving me nuts... I'll try your fix but need a little help. Should I replace the two lines with the other lines? Could I copy the file to an USB OTG un the twrp then edit then replace it?

Thanks in advance
I had call quality problems all the time and it seems, those instructions are helping me:

/system/build.prop replace those two line :

ro.qc.sdk.audio.fluencetype=none
persist.audio.fluence.voicecall=true

With this:

ro.qc.sdk.audio.fluencetype=fluence
persist.audio.fluence.mode=endfire
persist.audio.handset.mic=digital
persist.audio.voicecall.mic=0
persist.audio.voice.clarity=none
persist.audio.aanc.enable=false
persist.audio.handset_rx_type=DEFAULT
persist.audio.nsenabled=ON
persist.speaker.prot.enable=false
persist.audio.spkcall_2mic=OFF

I have to test it more, but call quality is much better now, there are no echoes and no lost words or speech stuttering anymore.
Maybe xiaomi.eu developers can explain, what all the lines are doing, maybe they can use something from there to put it in the ROM, so we don't need to replace build.prop file every week with new weekly ROM.
 

V3n0m

Members
Apr 14, 2019
7
3
Ok, so we have no solution for this problem right?
I have a Chinese Mi MIX 2S 128GB, bootloader unlocked and we know Xiaomi does not really like that. I think they won't fix that in the nearest future.
Some say it was helpful to switch to LTE/CDMA/UMTS auto (PRL). You can access change it with *#*#4636#*#* via you dialer.
I don't know, this did not work for me.
 

Solmer

Members
Mar 24, 2019
15
3
Ok, so we have no solution for this problem right?
I have a Chinese Mi MIX 2S 128GB, bootloader unlocked and we know Xiaomi does not really like that. I think they won't fix that in the nearest future.
Some say it was helpful to switch to LTE/CDMA/UMTS auto (PRL). You can access change it with *#*#4636#*#* via you dialer.
I don't know, this did not work for me.
Hi there, doesn't works for me neither, I'll try miroom but I need to wait til Sunday, I'm leaving for holidays right now and don't want to have problems...
 

Lars.B

Members
Feb 16, 2019
33
10
Well, I recommended changing the preferred default network settings to LTE/CDMA/UMTS auto (PRL). By now I think this just initiated a restart (?) of the phone's modem hardware which then enabled a reconnect to the available 4G/LTE network (in my case).

Being totally frustrated led me to reverting my Mi MIX 2S (M1803D5XA, 8/256GB model) back to the Chinese Beta ROM 9.4.12 yesterday evening, completely wiping the phone and locking the bootloader in the process.

Today, I've tested the "reconnectivity" a few times and surprisingly (?) the phone now works as expected, or at least much better. After completely losing the 4G/LTE connection inside a building (this was also expected) the phone immediately reconnected to the available 2G network and then to the available 4G network upon leaving the building with almost zero lag.

Chinese Beta 9.4.12 comes with baseband version AT4.0.c2.6-303-0409_2210_8fadd5d. Is this baseband version also part of the latest xiaomi.eu ROM for the Mi MIX 2S?
 
Last edited:

Lars.B

Members
Feb 16, 2019
33
10
i flashed modem.img from chinese rom now.. and i got a differen baseband-version displayed in phone... same informations in the txt file.. so looks like that is not reliable nor helpfull (the txt ver_info.txt file..)

i gonna test this baseband ...
Hi, have you been able to test your Mi MIX 2S with the modem.img from a chinese ROM? There is a thread over on XDA dev forums where someone said this was helpful! (link)

Again, I have no connectivity issues (4G/3G/2G) with the Chinese Beta 9.4.12 which comes with baseband version AT4.0.c2.6-303-0409_2210_8fadd5d, so you might want to try this version as well?

Thanks!
Lars
 

Lars.B

Members
Feb 16, 2019
33
10
Chinese Beta ROM 9.4.18 comes with baseband version AT4.0.c2.6-303-0416_1014_8fadd5d, no LTE issues so far.
 

Solmer

Members
Mar 24, 2019
15
3
Hi there! I'm out of my country right now and I've not a PC to extract the modem.img..... Could someone extract it and post here or send it to a clue service? Thanks in advance