Call dropping or caller does not hear me anymore


V3n0m

Members
Apr 14, 2019
10
13
Yes, it's really so frustrating. I hate it. I'm so angry that I didn't buy a Huawei. I would never recommend anymore Xiaomi. Never ever.
It's so strange that there is no official statement or a solution to the problem.
 

steve1712

Members
Dec 5, 2010
62
20
Yes, it's really so frustrating. I hate it. I'm so angry that I didn't buy a Huawei. I would never recommend anymore Xiaomi. Never ever.
It's so strange that there is no official statement or a solution to the problem.
i've moved to a p30 pro...
and i also do not recommend or buy an xiaomi device anymore...

its just the lack of interessted in a company thats creates new devices every month... (of course there is no other real company that won't handle this the same... check Samsung or Huawei.. the all have the same issues... the best would be Apple.. with atleast some support to "older" Phones too...)

There won't be any offical statement at all, as the phone is old... Mix3 is here... and i guess in a few Weeks there will be an Mix3S or Mix4.... i even didn't noticed the SAR Change/Limit that happend, whats most propably causing the issues... or at least the have built some bug into the system when limiting the output...
 

Lars.B

Members
Feb 16, 2019
49
20
Well, we went out for dinner tonight and I had to reboot my Mi MIX 2S with 9.5.9 to have mobile data. ☹ So, obviously Xiaomi is not interested in or capable of fixing the issue for us. ☹☹☹
 

LOLO9393

Members
Feb 8, 2016
603
82
Exactly the same behaviour. Loss of mobile data/internet access despite the 4G/LTE connection. I have to restart the phone...
I see your network setting are LTTE/CDMA/UMTS and that can explain the connexion lost; because when you loose LTE '(for wathever reason) the modem is looking and searching for CDMA channels that don't exist here.
Find a better setting like LTE/3G/2G auto . This can solve your issue.
 
Last edited:

Lars.B

Members
Feb 16, 2019
49
20
I see your are network setting are LTTE/CDMA/UMTS and that can explain the connexion lost; because when you loose LTE '(for wathever reason) the modem is looking and searching for CDMA channels that don't exists here.
Find a better setting like LTE/3G/2G auto . This can solve your issue.
Thanks, however I have exactly the same behaviour also with the default LTE/UMTS auto (PRL) setting.
 

dmc84

Members
Apr 23, 2019
10
13
I have that sometimes too, this seems to occur when You are connected Internet and moving, sometimes it can't connect to Internet at new location. Either restart phone or switch data connection to second card.
 

V3n0m

Members
Apr 14, 2019
10
13
Same here. There is no fixing with the new update... I will install as soon as possible the ASOP rom. It doesn't make sense to go with that ****** crap.
 

Lars.B

Members
Feb 16, 2019
49
20
I see your network setting are LTTE/CDMA/UMTS and that can explain the connexion lost; because when you loose LTE '(for wathever reason) the modem is looking and searching for CDMA channels that don't exist here.
Find a better setting like LTE/3G/2G auto . This can solve your issue.
Same behaviour this morning with the default setting.
 

Attachments

Feb 28, 2018
20
15
Same here. There is no fixing with the new update... I will install as soon as possible the ASOP rom. It doesn't make sense to go with that ****** crap.
Because of above issues with Xiaomi EU ROM, I tried to install Arrow and ASOP ROM according to flashing guide on their own web page, but i had not been succesfull that unknow the causes???
 

steve1712

Members
Dec 5, 2010
62
20
after bootloop on 9.5.16/17 now i need to reset everything again and i go to asop rom now..
is there anyone you guys can recommend??

what i really would like to have is the same fullscreen gestures/ui that i know from miui... everything else doesn't really matter...
 

Lars.B

Members
Feb 16, 2019
49
20
I will be able to test Xiaomi.eu ROM 9.5.17 tomorrow, so far it looks like Xiaomi has improved "something"...
 

Lars.B

Members
Feb 16, 2019
49
20
... I'm quite skeptical, but... How did it go?
No issues at all, honestly. My Mi MIX 2S lost the network as expected when I walked from one side to the other side of our workshop, office and social buildings but when I took the phone out of my pocket, it immediately connected to the available 2G network (E) or was already connected. When leaving the buildings or staying close to a window in one of the offices it also upgraded the connection to the 4G network. So, no issues today.

By the way, Xiaomi Mi 9 and Mi 9SE are now officially available through O2 in Germany. Maybe Xiaomi now has implemented the correct network settings for the O2 network in their database/modem.img.
 

V3n0m

Members
Apr 14, 2019
10
13
No issues at all, honestly. My Mi MIX 2S lost the network as expected when I walked from one side to the other side of our workshop, office and social buildings but when I took the phone out of my pocket, it immediately connected to the available 2G network (E) or was already connected. When leaving the buildings or staying close to a window in one of the offices it also upgraded the connection to the 4G network. So, no issues today.

By the way, Xiaomi Mi 9 and Mi 9SE are now officially available through O2 in Germany. Maybe Xiaomi now has implemented the correct network settings for the O2 network in their database/modem.img.
I'm also on 9.15.7. I have still the same problem. No improvement. Not even a little...
What are your network settings?
 

Phurya

Members
Dec 19, 2016
24
15
No issues at all, honestly. My Mi MIX 2S lost the network as expected when I walked from one side to the other side of our workshop, office and social buildings but when I took the phone out of my pocket, it immediately connected to the available 2G network (E) or was already connected. When leaving the buildings or staying close to a window in one of the offices it also upgraded the connection to the 4G network. So, no issues today.

By the way, Xiaomi Mi 9 and Mi 9SE are now officially available through O2 in Germany. Maybe Xiaomi now has implemented the correct network settings for the O2 network in their database/modem.img.
... Well, my problem was not 4g, it was the signal dropping and lost while calling, call ended suddenly, not being reachable, even with strong signal... Any of these?
 

Lars.B

Members
Feb 16, 2019
49
20
I'm also on 9.15.7. I have still the same problem. No improvement. Not even a little...
What are your network settings?
Please have a look at the screenshots below.
 

Attachments

Lars.B

Members
Feb 16, 2019
49
20
... Well, my problem was not 4g, it was the signal dropping and lost while calling, call ended suddenly, not being reachable, even with strong signal... Any of these?
I will try that today while driving to work! I will drive through areas with 2G, 2G/3G, 2G/4G and 2G/3G/4G coverage.
 

Lars.B

Members
Feb 16, 2019
49
20
I stand corrected. Almost immediately after I wrote the above posts (here and on c.mi.com) I encountered the same problems with my Mi MIX 2S. What the hell...
 
Last edited: