Can I unroot my MI 11 Ultra using images from MIUI 13 EU?

I am capable of not knowing what I am doing.
The download you suggest is underway
Congratulations, you have understood that a rom for the 12s Ultra (thor) cannot be installed on the Mix4 (Odin).;)
but where do I select the correct ROM?
also Why is it that I have only recently understood that rooting is the grant of root privileges, if indeed I have correctly surmised that. I should point out my fisrt processor was an MC6800 1MHz.
That did not load either. This is not what it claims be a MIX4.

Time to get a proper phone.
This has been an educational exercise. Thank you

for the root install the rom to begin

"That did not load either. This is not what it claims be a MIX4.
Time to get a proper phone."
What do you mean, exactly?

Post your phone model:
Settings/my phone/characteristics/model.
Last edited:
I ran a device scan on the Phone. It reported that it is an ALPSv7 4core not the Qualcomm 888+ 8core.
It reports the software as Android 8.1.0reo MR1
Also fastboot reports that it is a K80HD_BSP_FWV_512M. The internet describes this as the ALPs7 MT6580.
My guess is that this is a cheap copy and there is no update possible.
So. Time to get a proper phone.
No it was very cheap but I do not need a fancy Phone:
I have a "Proper" camera.

I deleted all my social media accounts because of miss information.
I do not approve of shoot-up games.
and android runs on the laptop these days anyway for any application I do need.
But the phone was poor as well.
As for the bank. The less I do on line the more security.

I have a Sony Experia I can use as a phone that in not a brick.
I ran windows_fastboot_first_install_with_data_format.bat and received this respponse:-

Pressing return closes the cmd window.

The device reported has an ARMv7 Processor not the Qualcomm 888+ claimed in the settings.
It is a custom build version
This would explain why it is so slow.
Anyone know how to get a ROM for it?
Did you run cmd in Admin mode ?

Maybe a stupid question !

Sent from my M2102K1G
i have the same problem too on my mi11 ultra...

google wallet not work beacuse of secure problems...

i use 14 emui...