Can't Flash Stable Rom

Discussion in 'Xiaomi Mi 3' started by Chazy Chaz, Apr 14, 2016.

  1. Chazy Chaz

    Chazy ChazMembers

    Apr 14, 2016
    2
    0
    13
    Male
    #1Chazy Chaz,Apr 14, 2016
    Last edited: Apr 14, 2016
    Hi, I'm trying to flash the new marshmallow rom but I keep getting the following error:

    replace /file_contexts with file_contexts in package: No such file or directory
    mount: failed to mount /dev/block/platform/msm_sdcc.1/by-name/userdata at /data: Device or resource busy
    Target: Xiaomi/cancro/cancro 6.0.1/MMB29M/V7.2.11.0.MXDCNDB user/release-keys
    mount: failed to mount /dev/block/platform/msm_sdcc.1/by-name/system at /system: Device or resource busy
    minzip: Can't create containing directory for "/system/app/AnalyticsCore/AnalyticsCore.apk": I/O error
    minzip: Extracted 0 file(s)
    script aborted: Failed to extract dir from "system" to "/system".
    Failed to extract dir from "system" to "/system".

    I've already flashed the chinise version using fastboot (with the mi pc suite) and I've checked the system partitions are merged.

    What can I do to fix this?
     
  2. Sajal Hossain

    Nov 12, 2013
    12
    0
    11
    Male
    Dhaka, Bangladesh
  3. whitemoon

    whitemoonMembers

    Oct 26, 2014
    14
    3
    15
    I have had a similar problem a while ago with my mi4... first time I fixed it fastboot-ing the stock mi recovery (no flash only "fastboot boot /pathto/recovery.img") and flashed the update.zip with it, you could try fastboo-ting twrp 2.x too, I've read it's more stable than 3.x, didn't personally try this one, or you could try to flash the miui.stable.zip from within the chinese miui updater app, remember to factory reset the phone after it, this one also worked for me a couple of time...
     
  4. Abussabah

    AbussabahMembers

    Jun 29, 2016
    16
    0
    11
    Male
    what is the error
     
  5. Chazy Chaz

    Chazy ChazMembers

    Apr 14, 2016
    2
    0
    13
    Male
    Sorry guys, forgot to share the solution (anyways, it seems some else did):

    First of all, I don't know who said (and why) that we have to use a custom recovery. I spent hours trying to figure out why I couldn't flash with TWRP, but then I just tried with the stock recovery and it worked, just like whitemoon says.

    No errors, no lag, just put the xiaomi.eu rom in root folder renamed as update.zip and flash it.

    Hope it helps.
     

Share Our Site