TWRP Bootloop / Can't flash to V12.5.2


Dec 20, 2022
[What I want] I want to flash my beloved MI 9T (with the popup-camera) from Stock-Rom MIUI 12.1.1 to 12.5.2.
My phone has an unlocked bootloader, but is not rooted.

[the problem] After flashing TWRP and xiaomi.eu_multi_HMK20MI9T_V12.5.2.0.RFJCNXM_v12-11.img, I am always caught in a TWRP bootloop.

[What I already tried] On the TWRP-terminal I tried the command "dd if=/dev/zero of=/dev/block/platform/soc/1d84000.ufshc/by-name/misc", but to no avail.
I tried using TWRP without flashing by "fastboot boot [name_of_twrp].img", but this just lead to a permanent black screen.
I tried all of the above with twrp-3.7.0_9-0-davinci.img and twrp-3.6.0_9-0-davinci.img - both lead to the same result.
With "XiaoMiTool V2" I managed to go back to Stock-Rom MIUI 12.1.1.
I tried to flash xiaomi.eu_multi_HMK20MI9T_V12.5.2.0.RFJCNXM_v12-11.img with XiaoMiTool V2, but got this error:
/sdcard/ adb: error: failed to copy 'D:\Handies\MI9T\platform-tools\' to '/sdcard/': remote couldn't create file: Required key not available

I would be so grateful if anyone could help me get Xiami.EU on my phone.