Google Pay not working anymore


Feb 28, 2019
32
2
10
#26
When I was on 10.2.2.0 Global Stable Rom with unlocked boottloader i had to install Magisk to be able to use Google Pay to shops via contactless
Btw I'm on Xiaomi EU 10.2.2.0 Stable ROM and not on 10.2.2.0 Global Stable Rom. Afaik GPay will definitely not work with the combination of Global Stable ROM and unlocked Bootloader due to failed SafetyNet
 
Dec 2, 2017
692
182
82
#32
If you uninstall an app, and then reinstall it, Google will helpfully restore your previous data for you from the cloud backup.

So you have to clear all data anyway.

Unless you tell Google not to restore your app data in the settings.

Settings/Additional settings/backup & restore/ Automatic restore
 
Dec 2, 2017
692
182
82
#36
Just one question. I'm running EU Stabile 10.2.2.0 and can't find Google Play Services App. I can only See Google Play Store App in my list. Is this the App you mean actually?

Thx
You have to enable "show all apps" in Settings/ manage apps, 3 dots top left right.
 
Last edited:
Jul 17, 2016
145
19
30
#41
I paid successfully today with gpay and my German Banking app on 9.2.21, the issue just vanished, maybe a background play service upgrade did it.
Magisk 18.1

Regards

Sent from my MI 8 Explorer Edition using Tapatalk
 
Mar 2, 2019
6
2
5
#42
After many unsuccessful attempts, I was able to add new cards to Google Pay. I don`t understand if it helped to me, but last time I have changed phone language from my native Russian to English.
 
Oct 12, 2018
9
1
15
#43
I paid successfully today with gpay and my German Banking app on 9.2.21, the issue just vanished, maybe a background play service upgrade did it.
Magisk 18.1

Regards

Sent from my MI 8 Explorer Edition using Tapatalk
Hi, I am also in Germany. Same problem came up yesterday suddenly. I have tried to clean the cache of google play service und reinstall Google pay, still doesn't work. Do you have any idea?
 
Jul 17, 2016
145
19
30
#44
Unfortunately not, im using not the latest version of gpay, it stopped working after 9.2.21, terminal didn't “see“ the phone anymore..

I did not do anything, no clean cache no reinstall..

Yesterday i just thought, let's try again and boom, gpay with rossmann did work, 20 mins later “mobiles bezahlen“ @rewe started working again too..

Weird but it's not the Rom, nor magisk.

Try to fiddle with play services, maybe this will do the trick , sorry for not being able to help more :(

This gpay I'm using:


Sent from my MI 8 Explorer Edition using Tapatalk
 
Oct 24, 2018
4
4
15
#45
Settings/Additional settings/backup & restore/ Automatic restore
clean data of Google Pay and Google Play Services app..
Got it!
Thanks to cobben and ingbrzy.

After two steps:
1. Settings/Additional settings/backup & restore/ Automatic restore. Turned if off.
2. Cleared all data pf GPay and GPlay Services

Then I reinstall the GPay and added contactless payment option. Didn't check it in a store yet but there is no doubt that it will work!

Thanks again guys.
 
Jan 9, 2019
1
1
5
#48
[QUOTE = "dznybr, post: 474928, member: 212774"] Понял!
Благодаря Коббену и Ингбрзи.

После двух шагов:
1. Настройки / Дополнительные настройки / Резервное копирование и восстановление / Автоматическое восстановление. Выключил если выключен.
2. Очистил все данные сервисов GPay и GPlay

Затем я переустановил GPay и добавил опцию бесконтактных платежей. Еще не проверял в магазине, но нет никаких сомнений, что он будет работать!

Еще раз спасибо, ребята. [/ QUOTE]
И в правду помагло!!! Спасибо!
 
Likes: blindmaze