New Google Play Services Error After Update


Sakat

Members
Feb 1, 2013
67
20
=====》 Solution found, see below 《=====


Hey guys!


I open this topic because I'm having issue with Google Services. Here are the details:

Today I updated my Xiaomi 5 to the last official version of Chinese MIUI (developer version 6.12.29, Android 7.0). After rebooting the phone started to show:"Google Play services keeps stopping" when I opened Playstore. Altough this message kept coming every 2-3 seconds. I was still able to do the update of my apps. Then it got on my nerve so I tried to update it but this didn't solve the problem so I tried to delete my account, cache and data. After rebooting, the problem became even worse because the error keeps on showing and I'm not able to add my account again. When I open Playstore or try to add my account through the account section in MIUI settings, it shows "Google Play services has stopped" and the page is stuck to "Checking info..." (the page before adding your Google account).

I installed the following versions of Google APK:

- Google Play Store 7.3.07.K (0)
- Google Play services 10.0.84 (440)
- Google Services Framework 7.0 (24 - nodpi)
- Google Account Manager 7.0 (24 - nodpi)

I also tried to clean dalvik-cache folder but it didn't help.


Any idea how to solve that issue?



Thanks in advance!



Sakat



ps. Apart from that problem, I also noticed that there is no recovery mode anymore. Am I correct? I say that because instead of the classical menu, it shows an icon of my phone with pcsuite.mi.com. That's all.


#Edit solution:
I solved the problem by doing the following:

1) Deactivate the developer options

2) Backup Google Apps in my other Xiaomi phone (Hongmi 3 which isn't on Android 7 but 5.1.1, Chinese Developer 6.12.22):

  • Google Account Manager(com.google.android.gsf.login)
  • Google Play services(com.google.android.gms)
  • Google Play Store(com.android.vending)
  • Google Services Framework(com.google.android.gsf)

3) Tranfer that backup to the MIUI/backup/AllBackup folder of my Mi5

4) Restore that backup

5) Run Playstore and add my Google account. At this point Playstore worked but it didn't show the apps already installed on the phone.

6) Update Google Apps to the last versions (you can download them here):

  • Google Account Manager(com.google.android.gsf.login) 7.0
  • Google Play services(com.google.android.gms) 10.0.84 (440)
  • Google Play Store(com.android.vending) 7.3.07.K (0)
  • Google Services Framework(com.google.android.gsf) 7.0

7) Reboot

8) Delete my Google account

9) Run Playstore, add my account again.

Play Store worked again fully but Youtube app (11.47.57) wasn't
. It showed "An error has occured“. To fix it just open the permission manager of Youtube and allow it to access accounts on device. Done!
 
Last edited: