GPS Not Working

Discussion in 'Xiaomi Mi One/Mi One S' started by Sere83, Jul 10, 2012.

  1. Sere83

    Sere83Members

    Mar 20, 2012
    172
    9
    28
    Male
    Hi I upgraded to V4 recently and man is this a HUGE improvement over 2.3 which was casuing me all sorts of issues.

    Only problem is my GPS now doesn't work. Everything is turned on in location services but when I go into maps and try and pin point my location it says 'current location unavailable'. Flicking the toggle does nothing either, icon doesn't even appear in top right. Any ideas?
     
  2. Sere83

    Sere83Members

    Mar 20, 2012
    172
    9
    28
    Male
    Thanks for this. Will this work for Mi-One? How do i swap system files? I got root explorer and have allowed root permission, but it says system folder is read only? Also as soon as I turn wifi on gps works again
     
  3. boxcarracer81

    Mar 20, 2012
    551
    63
    75
    Male
    the Netherlands
    I use Android commander on win7, navigate to system/app. There I deleted the original file and replaced (pushed) the other file. :D
     
  4. Sere83

    Sere83Members

    Mar 20, 2012
    172
    9
    28
    Male
    Yes I found this app too and installed but won't let me access system partition. Says 'Root access: NO' at bottom. I have got the android sdk installed. Any ideas?
     
  5. blackstones

    Mar 29, 2012
    519
    49
    67
    Try root explorer and see if that helps it will give you acess to the system of the phone and the sd card gives you read and write acess.
     
  6. Sere83

    Sere83Members

    Mar 20, 2012
    172
    9
    28
    Male
    Thanks Managed to do it through root explorer, makes no difference though. Open maps, try and get location and it says 'location temporarily unavailable'. Turn on wifi though and it gets a lock straight away.
     
  7. blackstones

    Mar 29, 2012
    519
    49
    67
    you have turned data traffick on so you can visit website with the browser and get mail?
    you can try turning 3G on but should work fine without.
    You havent done anything in the network assistant app so gps/maps are not allowed to use the data traffic?

    Network assistant --> traffic ranking see anything here for those apps? if not --> batch network control.
     
  8. Sere83

    Sere83Members

    Mar 20, 2012
    172
    9
    28
    Male
    Thanks a alot. Yeah data was on and everything was enabled, had a look in permissions though and a couple of setting we're disabled, so I enabled them, seems to be working now :). Just upgraded to 2.7.13. Battery is not great though on v4, only get about 12 hrs of light to moderate use.
     
  9. Fruitgull

    FruitgullMembers

    Apr 26, 2012
    36
    2
    18
    Male
    IT
    Sweden
    Replacing NetworkLocation.apk solved it for me. I hope permanently.
     
  10. blackstones

    Mar 29, 2012
    519
    49
    67
    Just tried it this week didnt have any problems using 2.8.3 but if you have battery issues go true the phone and check if you have 3g and other things that drains battery on :)
     
  11. Fruitgull

    FruitgullMembers

    Apr 26, 2012
    36
    2
    18
    Male
    IT
    Sweden
    My gps works after replacing NetworkLocation.apk. But sometimes it's not measuring correctly. One time a one hour walk resulted in 500 km :( Any ideas?
     
  12. blackstones

    Mar 29, 2012
    519
    49
    67
    impressive walk i must say and what a speed :) but sucks that it didnt work :(
    Have you tried just re-flashing it using it fastboot? i never had any gps issues but havent really used it that much to be sure if its really that off just slow sometimes and that might be other things.
     
  13. Fruitgull

    FruitgullMembers

    Apr 26, 2012
    36
    2
    18
    Male
    IT
    Sweden
    I've not tried flashing rom again in fastboot mode. Only through recovery mode. Will try that.
    Thx
     
  14. Fruitgull

    FruitgullMembers

    Apr 26, 2012
    36
    2
    18
    Male
    IT
    Sweden
    Thanks again good sir (or lady) :)
     
    blackstones likes this.
  15. blackstones

    Mar 29, 2012
    519
    49
    67
    Not a problem hope it works out for you :) Just remember that when you flash it using fastboot its like a factory new phone so take backup and download the new 2.8.10 fastboot
     
  16. Fruitgull

    FruitgullMembers

    Apr 26, 2012
    36
    2
    18
    Male
    IT
    Sweden
    Have flashed now using your excellent tutorial. GPS seems to work now using the default NetworkLocation.apk (but haven't tried it out really that much). I hope it's accurate and reliable now (it wasn't with last Miui installation, even if I tried both the default apk as well as the older one from the other thread). Only time will tell.
     
  17. blackstones

    Mar 29, 2012
    519
    49
    67
    Yeah really hope it works for you now :)
     

Share Our Site