[GUIDE] Flashing rom Using Miflash Mi2/3


Aug 8, 2012
125
4
30
#26
Hi,

I have a driver problem in my screen, sometimes the screen shows a 2cm x 3cm rectangle at the top left side of the screen with something it takes from another place in the same screen.

I've tried flashing JLB versions and did a full wipe but it still happens.

Do you think that this process may work to fix the screen driver? as this flashing is in a lower level?

or it it possible to get the screen driver and flash it through this software?

I don't want to send it back as it seems that this can be fixed easily.

Thanks for your answer.
 
Jul 24, 2011
465
234
65
#27
what version of MIUI are you running. I think this was a bug in the last version. I have also experienced this but not since flashing 3.2.1. I do not think that flashing this way would do anything different. But in the end it would not hurt either.
 
Aug 8, 2012
125
4
30
#28
I have tried the last version, version 3.2.1 now. JBL 7 and JBL10. 3.2.1 with MiFlash and the same problem appears. BTW, the screen test of Xiaomi with the dialer code works fine in RGB, only sometimes after a couple of seconds/immediately I see the rectangle, it becomes normal after I move the screen a little bit.
I marked it in black in the 'dropbox' screen shot. Screenshot_2013-01-30-10-42-14.png Screenshot_2013-01-30-10-42-43.jpg
I marke
Screenshot_2013-01-30-10-42-14.png
Screenshot_2013-01-30-10-42-43.jpg
 
Aug 8, 2012
125
4
30
#29
@grondinm

Currently I believe that my device has a bad screen driver. although everything looks great when the rectangle does not appear.

It is comforting when you say you saw this in the last versions, but the last update (with full wipe) did not help.

Can you recommend of a version that you know that doesn't have this issue? maybe old versions? I just want to be sure what's going on here...

Thank you.
 
Jul 24, 2011
465
234
65
#30
i think if you go back to the last version of 2012 or prior. I'm not 100% sure the first version i saw it in but it was present for a few versions.
 
Jan 9, 2013
313
112
65
#31
I've seen that glitch too. Also, when Avast antivirus is scanning, its notification is blacked out. Not sure if the two are related. It isn't a big deal, but it's there and worth noting.
 
Aug 8, 2012
125
4
30
#32
I tried to falsh JBL 11 and saw this problem again!, it usually happens when I go into a text field such as Gmail and calendar and wait for several seconds.
Sometimes it happens and sometimes doesn't.
Can someone confirm that it happens in his device as well? before returning the device...
Thanks.
 
Dec 27, 2011
245
216
65
#35
op updated to update version of Miflash. Medina can you try this new version and see if it works with windows 8?
Thank you, but it did not succeed to install the drivers .
fortunately I mange to make it work manually so if someone have the same problem I can help.

Thank you grondinm :)
 
Mar 10, 2013
3
0
11
#36
not sure what im doing wrong but i got miflash, installed it while the fastboot.exe (QCS99) is still downloading. when the file is done, i started the miflash program, set the right script, put phone into fastboot mode, connected it to the laptop and it's detected by miflash. however, flashing took forever and i close the program (no other way to do so). So what could i be doing wrong?
 
Mar 10, 2013
3
0
11
#38
yeah i do, copied the log since it's short:

504858050.00start flash C:\Program Files (x86)\Xiaomi\MiPhone
504858050.08'"C:\Program Files (x86)\Xiaomi\MiPhone\flash_all_except_storage.bat"' is not recognized as an internal or external command,

504858050.09operable program or batch file.

504858050.01start flash C:\Users\xxx\Desktop\XM\miui_MiTwo_QCS99_fastboot_4.1
504858050.14

504858050.14$fastboot -s 50485805 getvar soc-id 2>C:\Users\xxx~1\AppData\Local\Temp\soc-id-17395.log
xxx is just the laptop's name. i tried to copy the flash_all_except_storage.bat into the advanced setting window to no avail, then i tried to browse to the .bat file in the fastboot folder which is the log above. both ways gave me the same results.

doing this as i was going to flash JLB to the device. I did a wipe all data and installed it to system one but i was not able to use the touchscreen (was using the QCS89 file which was buggy). Wanted to boot into MIUI on system two but it was stuck on boot animation. trying to use miflash to salvage the phone.
 
Jul 24, 2011
465
234
65
#39
can you find this C:\Users\xxx~1\AppData\Local\Temp\soc-id-17395.log file and see what it says.

could you also provide screenshots of you miflash main screen and advanced settings as they where when this was failing?
 
Mar 18, 2013
102
35
38
#40
Guys my device is stuck at boot. It can't even go in recovery! I tried to flash the jlb12 with miflash but nothing, it's stuck and can't go in recovery. Please, help me! I don't know what to do!
 
Jul 24, 2011
465
234
65
#41
When you say that you tried with miflash "but nothing" does that mean miflash failed or that it flashed and your phone is still stuck?

Sent from my MI 2 using Tapatalk 2
 

jmp

Members
Apr 2, 2013
72
5
18
#43
Even the recovery is not working? If not are you sure you completed the procedure properly? If it is working how about deleting cache and data?
 

jmp

Members
Apr 2, 2013
72
5
18
#47
Is it possible to flash cwm using fastboot? In that case you could flash it and see if the problem is the recovery not being installed.
 
Mar 18, 2013
102
35
38
#50
well...i have no idea unfortunately. Miflash gives no errors...could you upload Miflash log here.
Fortunately i've read your hopeless messagge when i managed to get it working :D
So, that's what i've done.
-I've flashed the stock mi2's recovery image through fastboot (fastboot flash recovery recoveryname.img)
-Flashed 3.3.29 with miflash and all is good now. I think that miflash isn't compatible with cwm with truedualboot enabled