Resolved mi2 wifi bug (fixed)

Discussion in 'Bugs' started by qbert456, Apr 8, 2013.

  1. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    I've got an ongoing bug with Wi-Fi.
    Connecting or re connecting to a know Wi-Fi network after a while it fails to connect.it can see the network but fails to get an ip, the Wi-Fi symbol on the toggle bar gets a small exclamation mark.
    So far, clearing media storage app, and airplane mode on then off fails to fix.
    Only fix for me is reboot.
    It didn't happen on 3.3.8

    I can't find the log cat app using the link above I'm afraid
     
  2. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    Ok i have installed logcat extreme, have a logcat captured during the fail wifi log in - but its rather big!
    anyone know what one might look for in it? or shall i post it and pray an expert casts a look!?
    cheers
     
  3. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    I found a fix btw.
     
  4. moonbugz

    moonbugzMembers

    Feb 19, 2013
    108
    9
    28
    Male
    what's the fix?! o_O
     
  5. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    the free app from the market (google play in new speak) wifi fixer works for me, needs no reboot no airplane mode and no wifi on/off required.
     
  6. Vladimir2k9

    Apr 21, 2012
    44
    13
    28
    Male
    Russia, Ufa
    Please give link. I have this bug too, and what to do then.

    Отправлено с моего HTC Vision через Tapatalk
     
  7. qbert456

    qbert456Members

    Feb 20, 2013
    517
    36
    65
    I can't remember what I do when Wifi breaks, next time I'll pay attention.
    It may be automatic with this app or just a button to press.
     
  8. Vladimir2k9

    Apr 21, 2012
    44
    13
    28
    Male
    Russia, Ufa
    I will try it later, thanks.
    Developers of our rom have found some solution, too.
     
  9. moonbugz

    moonbugzMembers

    Feb 19, 2013
    108
    9
    28
    Male
    really? which release?
     
  10. Vladimir2k9

    Apr 21, 2012
    44
    13
    28
    Male
    Russia, Ufa
    but it is not on miui
    on aosp 4.2.2 and cm10.1
    still waiting miui based on 4.2.2, it more fast and smooth
     
  11. Meiga442

    Meiga442Members

    Jul 8, 2013
    3
    0
    11
    Male
    Hi all,

    I have the same/a similar problem, except that my wifi stops working just about all the time and works just about 5% of the time. I installed that wifi fixer (although i must say that my play store stops working too before i can download anything, i won't even start actually) and that app is now 95% of the time busy fixing my internet, which results in the loss of connection 95% of the time to fix the problem using "four way handshake". The difference is also that the wifi symbol has this small "spades" looking sign (see pictures). Anybody have any idea how to solve this?
     

    Attached Files:

Share Our Site