[Mi2s] bad in-call mic quality, no problem when on loudspeaker

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by Rataplan626, Mar 17, 2014.

  1. Rataplan626

    Jan 30, 2014
    8
    2
    13
    Male
    Well, the subject says it al. My Mi2s has bad sound quality when calling, people can hear me pretty bad and their voice is echoed back to them. My Call noise suppression is set to single mic, on dual-mic it gets even worse with even more echo. When I switch to handsfree / loudspeaker though everything is crisp clear, meaning my mic is not the issue. My radio is M9615A-CEFWMAZM-2.0.128017. I tried covering the back mic as I read that in a Mi2 thread, but that didn't help either. I am running the latest (as of yet) (4.3.14) multilanguage rom.

    Anyone familiar?
     
  2. Pablo3d

    Pablo3dMembers

    Apr 17, 2014
    8
    1
    13
    Male
    Hey,
    I have that same problem, I'l tried diffirent baseband version and nothing changes.
    Mi2s is great phone but why all ppl have problem with call voice quality? it is harwdare problem or software?
    any issue?

    Pawel
     
  3. Mmatt

    MmattMembers

    Apr 9, 2014
    25
    0
    11
    Male
    I dont have any problems with sound quality.

    I have the some radio, only rom is 4.4.25
    Maybe is hardwer problem?
     
  4. Pablo3d

    Pablo3dMembers

    Apr 17, 2014
    8
    1
    13
    Male
    Hardware?
    too many people have same problem ;/
     
  5. Pablo3d

    Pablo3dMembers

    Apr 17, 2014
    8
    1
    13
    Male
    Ok I made the test. I just installed cm 11 with kitkat 4.4 and still have problem so it isn't the software problem?

    People on other site when we call hear also my fingers scratching on the cover or when I try to change vol (buttons sound). It looks like the microphone has too high sensitive with recording .
    Can anyone make a test and try use recorder and make some finger moves on the cover and check for any sounds recording.

    Pawel

    Wysłane z mojego MI 2S przy użyciu Tapatalka
     
  6. Piko House

    Piko HouseMembers

    Feb 5, 2014
    17
    3
    15
    the bad sound was due to the holes in the back cover that does not fit perfectly with the holes in the microphone. I realized here I've tried to talk without the back cover and the sound appeared excellent. I finally slightly enlarged the holes of the two microphones solving the problem. the first microphone is the holes next the camera and the second is to place next to the slot will recharge.
     
    SkaldfraNorden and Pablo3d like this.
  7. Pablo3d

    Pablo3dMembers

    Apr 17, 2014
    8
    1
    13
    Male
    Piko you are my hero!
    Thank you now all sounds are perfect

    Wysłane z mojego MI 2S przy użyciu Tapatalka
     
    Piko House likes this.
  8. Dmqeaz

    DmqeazMembers

    Nov 22, 2013
    39
    3
    28
    Male
    can you provide some photo please?
     
  9. walker73

    walker73Members

    May 21, 2014
    2
    0
    11
    Male
    in wich way you enlareged holes?? with a drill? thanks
     
  10. Iriske

    IriskeMembers

    Apr 16, 2014
    2
    0
    11
    Female
    I have the same problem. Can anyone post a photo and tell me how to fix this? Thank you guys!
     

Share Our Site