Mi4i Bricked - Fastboot Flash Never Completes

Discussion in 'Question & Answers' started by Nico W., Aug 26, 2015.

  1. Nico W.

    Nico W.Members

    Dec 16, 2012
    34
    6
    18
    Male
    Hi people,
    I have some serious issues going on right now. I'll elaborate as clearly as possible below.
    As everyone knows it took forever for the servers to keep up with is downloading MIUI 7.
    Eventually I went for a proposal by a German stating a clean German/English lightning fast MIUI 7 ROM was waiting on a german forum.
    I downloaded it and first downloaded and used Mi4i toolkit v3 to first install twrp and then root. Both seemed succesfull, only after I checked to confirm twrp didn't work after all. Although root might still have.
    This time downloaded Mi4i toolkit v4 and redid the twrp recovery flash. This time it worked. I placed the downloaded ROM on my phone storage from my PC and performed a nandroid backup as well.
    As I couldn't find anything anywhere on anyone proposing a clean install for this ROM (v7 dev) coming from stock v6 stable, I started flashing the ROM through TWRP and all hell broke loose.
    TWRP froze up and only thing that worked was vol up+power. Phone rebooted straight back into twrp without my wanting, second time the same.
    I saw no other option than to wipe factory reset, without touching storage containing backup.
    Retried to flash the ROM without success.
    After some reading decided to use Fastboot as a last resort. Followed everything exactly (i tried to save my nandroid to my pc, but i believe cyclic redundance witheld me from doing that. Not specifically mentioned but the behavior of the malfunction sure reminded me a lot of my mi2) as described in all the guides. Flash_all.bat is present in the v7 unstable tgz I first managed to get downloaded. Started up the flashing process and it seems to work fluently just up until the point where it gets stuck on fastboot.blablabla.FLASH SYSTEM.blablabla, below it says device is busy...
    I tried that 3 times. one time I rebooted PC to press f8 and disable signature verification for drive installations. That didn't help.
    Today I redid the Fastboot flashing process with the finally acquired tgz for v6 stable as this is what everybody is proposing (although I belive it isn't the latest version I found), and you guessed it: it didn't work.
    I seem to be screwed no matter what here.
    Can someone PLEASE PLEASE PLEASE help me? You could save a MIbro and he will remember your name in eternity... :)

    Forgot to mention that I effectively used the Miflashtool for the fastboot job and i used the correct adb package. And it's inside the flashing process in the miflashtool that it gets stuck on the afore mentioned point for over 3000 seconds and it just stays there not moving...
     
  2. Nico W.

    Nico W.Members

    Dec 16, 2012
    34
    6
    18
    Male
    Forgot to mention as well that within these several attempts my mirecovery has come back, but that's it really....
     
  3. BoardDWorld

    Feb 27, 2015
    104
    27
    38
    I'm not German.. And so far their ROM is the only one worth using, Chinese ROM has serious WIFI issues and no performance improvements which is fixed in the German version.

    Unfortunately I have not had any experience with failed fastboot recoveries. I do suggest going over to en.miui.com with your problem. At this thread they're performing a manual flash after resizing system partitions:

    http://en.miui.com/thread-93248-1-1.html

    Sent from my MI NOTE Pro using Tapatalk
     

Share Our Site