Missing Lte Band 20 Support

Discussion in 'Xiaomi Mi Note 2' started by hblek, Mar 16, 2018.

  1. hblek

    hblekMembers

    Dec 10, 2017
    14
    0
    13
    Is the global LTE band support missing in the Miui 9.5.1.0 stable rom version?

    I do not have 4G support for band 20 in the Netherlands. I have a confirmed global version 6gb/128gb version. The version is checked and confirmed on the Xiaomi website, based on the serial number of my phone.

    Does anybody a remedy to get 4G support?
     
  2. NeoMod

    NeoModMembers

    Aug 1, 2016
    56
    11
    20
    Male
    Italy
    From my personal knowledge (and I've researched/tried/tampered a lot) It all depends on your Mobile Operator.

    I have a non-global model (so called china version) which is missing the aforementioned band, and yet I'm able to obtain LTE/LTE+ with my provider in Italy.

    Only problem I have, I can't use VoLTE simply because my operator wonìt recognize Xiaomi as a "valid" device and thus won't activate the service on my SIM. :mad:
     
    hblek likes this.
  3. hblek

    hblekMembers

    Dec 10, 2017
    14
    0
    13
    I have mi note 2 only 10 weeks. I am on 9.5.1.0 eu stable rom since a week. On my phone a vernee apollo I had at least 4g. I do not know whether I had 4 g on this phone. I have a lokale provider via the voda phone network an need band 20 for 4g. Volte is not supported.
    I verified my phone via xiaomi.com via my serial number and got confirmation that my phone is a 6_128 gb global version. As it should be.
    I do not know where it went wrong. Is it a phone issue or a software issue.
     
  4. qiuas

    qiuasMembers

    Mar 17, 2018
    14
    2
    3
    You can always try contacting xiaomi support. They should now what the problem may be and they could fix it for you (or give you a new phone).
     
    hblek likes this.
  5. hblek

    hblekMembers

    Dec 10, 2017
    14
    0
    13
    My problem is solved. I was depended of band 20 support for LTE support. The actual problem was that the sim add has to bee in slot 2 for LTE support. Now LTE works as a charm.

    Hope this answer also helps others.