Not booting - Not showing the MI logo


Nov 21, 2019
Hello, I have a Redmi Note 6 Pro (Global version). Yesterday I attempted to update the phone to MIUI 11, I had 95% battery and everything seemed to be ok. I was kinda tired so I closed my eyes to rest, last time I checked the phone it was at 89.95%, I opened my eyes about 15 minutes later, and the phone was off. I found it weird because as I remember the phone boots up after the update is finished. Anyway, I attempted to turn the phone on, it showed to MI logo and turn off again, tried again, same thing happened, power off + volume up didn't work but power + volume down , for fastboot worked. Though, my phone is locked and I haven't applied to unlock it. I was very sad and started research to see what can I do, since the phone is locked, i cannot flash it threw fastboot. I finally came across a page talking about EDL. I removed the backcover, found the two pins, made them do contact and connected the USB. Then I installed MiFlashTool and I found a fastboot ROM online for my device. I started Flashing it, finally, it said "success", I unplugged the phone, attempted to fire it up and it didn't work. This time it didn't even show the MI logo. Please help, I donnot wanna spent money to buy a new phone, since I'm not doing great with economy right now. Any help would be appriciated!

PS, it wont even go to fastboot mode now.