New XiaomiEU Module 23, May - No NFC Payments


I'm using the default TWRP SKKK for Poco F3 that came with MIUI14.0.8.0 by XiaomiEU
Currently Play Integrity certified with Play Integrity Fork module.
Hmm Im on HyperOS. I just tried Play Integrity Fix + AutoPIF (PlayCurl) to get latest Fingerprints, althought Gwallet says all good and it's play certified, wallet still fails.

I'm not sure how to implement Play integrity Fork, as I think it needs your own custom fingerprints? I tried installing the module but it left me with Basic Integrity (guessing because the FP that came with the module was already expired). Unsure whether AutoPIF(Playcurl) works with Play integrity Fork
 
Hmm Im on HyperOS. I just tried Play Integrity Fix + AutoPIF (PlayCurl) to get latest Fingerprints, althought Gwallet says all good and it's play certified, wallet still fails.

I'm not sure how to implement Play integrity Fork, as I think it needs your own custom fingerprints? I tried installing the module but it left me with Basic Integrity (guessing because the FP that came with the module was already expired). Unsure whether AutoPIF(Playcurl) works with Play integrity Fork

Read the notes


 
Read the notes


ah thanks man. Not sure if i executed it correctly, could you check my log? Also, with this, im only on Basic, however Gwallet reporting all security requirements. At this point i'm just gonna try payment later.
 

Attachments

  • 1716947209248.jpg
    1716947209248.jpg
    354.9 KB · Views: 56
  • Like
Reactions: Jacometto
ah thanks man. Not sure if i executed it correctly, could you check my log? Also, with this, im only on Basic, however Gwallet reporting all security requirements. At this point i'm just gonna try payment later.

Yeah, the log screenshot is correct (delete it from your post).
Now you have to copy the created custom.pif.json file to the data/adb/modules/playintegrtyfix, then reboot... You must be BASIC and DEVICE certified after that.

(*) Check if no other Play Integrity related module installed in your system... Keep only the Play Integrity Fork and nothing else.
 
  • Like
Reactions: austinjklim
Had you BASIC and DEVICE integrity before?

EDITED: How did you UNLOCKED your Mi 13 Ultra?
I was good before. Mine is global and I use official Xiaomi Community to unlock my phone.
Edit: Just update with latest Xiaomi EU module 22.05. Purge the Play store app cache. Let me check back again til tmr on GPay app.
 
Last edited:
  • Like
Reactions: Jacometto
Yeah, the log screenshot is correct (delete it from your post).
Now you have to copy the created custom.pif.json file to the data/adb/modules/playintegrtyfix, then reboot... You must be BASIC and DEVICE certified after that.

(*) Check if no other Play Integrity related module installed in your system... Keep only the Play Integrity Fork and nothing else.
Thanks man. Appreciate it. I did not copy over the module so that was my mistake. But since it uses the eu module for it's FP, i gave the module a try again. Apparently... it works now. I'm not entirely sure what's at fault, but i was messing with NFC's secure element position setting. Not sure what it was before, but i now changed it to HCE wallet instead. Not sure if this is the contributor, but I also cleared all cache/data of Gwallet/Play Store/Play services.

For those who cleared Play services data/cache, Gwallet would ask for SMS permissions on the play services, in which you would not be able to access the permissions in the usual/traditional way. To fix this, install "hidden settings" from the play store, allow it permission to access your installed apps, then open it, Manage application > google play services > permission > allow SMS.

Then just proceed to Gwallet and login to your Google account. Thanks everyone for the contribution.
 
  • Like
Reactions: Jacometto
Thanks man. Appreciate it. I did not copy over the module so that was my mistake. But since it uses the eu module for it's FP, i gave the module a try again. Apparently... it works now. I'm not entirely sure what's at fault, but i was messing with NFC's secure element position setting. Not sure what it was before, but i now changed it to HCE wallet instead. Not sure if this is the contributor, but I also cleared all cache/data of Gwallet/Play Store/Play services.

For those who cleared Play services data/cache, Gwallet would ask for SMS permissions on the play services, in which you would not be able to access the permissions in the usual/traditional way. To fix this, install "hidden settings" from the play store, allow it permission to access your installed apps, then open it, Manage application > google play services > permission > allow SMS.

Then just proceed to Gwallet and login to your Google account. Thanks everyone for the contribution.

All steps that you mentioned are correct.
So PI and Payments should be fine now.
 
Had an issue with my F6 Pro today.

Not Google Play Certified but ran the ID through their website anyways to see if it changes at some point.

All Google services work fine.

Using PIF and keeping EU Inject Module disabled. This allowed for payments to work about 1 hour from this post.

Fingers crossed it stays that way lol...
 
Thanks man. Appreciate it. I did not copy over the module so that was my mistake. But since it uses the eu module for it's FP, i gave the module a try again. Apparently... it works now. I'm not entirely sure what's at fault, but i was messing with NFC's secure element position setting. Not sure what it was before, but i now changed it to HCE wallet instead. Not sure if this is the contributor, but I also cleared all cache/data of Gwallet/Play Store/Play services.

For those who cleared Play services data/cache, Gwallet would ask for SMS permissions on the play services, in which you would not be able to access the permissions in the usual/traditional way. To fix this, install "hidden settings" from the play store, allow it permission to access your installed apps, then open it, Manage application > google play services > permission > allow SMS.

Then just proceed to Gwallet and login to your Google account. Thanks everyone for the contribution.

The Hidden Settings is a great app, but in this case it isn't needed.

 
  • Like
Reactions: Jacometto